/usr/bin/address-book-app:url-dispatcher-bad-url

Bug #1466759 reported by errors.ubuntu.com bug bridge on 2015-06-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
address-book-app (Ubuntu)
High
Renato Araujo Oliveira Filho

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding address-book-app. This problem was most recently seen with version 0.2+15.10.20150611-0ubuntu1, the problem page at https://errors.ubuntu.com/problem/d15cb347ddde80e9b25f32ff1422a49c45720d16 contains more details.

This happens when the user taps on the phone number instead of the icon.

Test Case
1. Open the address book
2. Open a contact
3. Tap on the phone number (not the icon)

Actual Result
The phone vibrates but nothing happens

Expected Result
The dialler opens with the phone number

Related branches

Changed in address-book-app (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Bill Filler (bfiller)
Jean-Baptiste Lallement (jibel) wrote :

Note that this bug as no impact on he user other than a not really god user experience since nothing happens while the user expects the phone to do something. It is ranking number 3 on errors.u.c and seems to be a rather common action.

Changed in canonical-devices-system-image:
importance: High → Medium
description: updated
tags: added: testcase
Jean-Baptiste Lallement (jibel) wrote :

Also note that if bug 1370008 is fixed, it'll have the effect of prompting the user when he taps on a phone number which will worst than today's experience.

Bill Filler (bfiller) on 2015-10-28
Changed in canonical-devices-system-image:
milestone: none → ww46-2015
status: Confirmed → In Progress
importance: Medium → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package address-book-app - 0.2+16.04.20151028.2-0ubuntu1

---------------
address-book-app (0.2+16.04.20151028.2-0ubuntu1) xenial; urgency=medium

  * Does not export contact extend detail into vcard. (LP: #1510259)
  * Ignore default actions on contact view. (LP: #1466759)
  * Updated autopilot tests, with the new ABContactEditorPage.
  * Use Runnable implementation instead of thread to avoid overload cpu
    usage. Implement async copyImage support. (LP: #1469005)
  * Used import icon in the "import from sim" button (LP: #1424819)

 -- Renato Araujo Oliveira Filho <email address hidden> Wed, 28 Oct 2015 20:36:53 +0000

Changed in address-book-app (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers