Ubuntu Touch 15.05 (r1) - Google Contacts not synchronizing

Bug #1421889 reported by Aang on 2015-02-14
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
address-book-app (Ubuntu)
Medium
Unassigned
sync-monitor (Ubuntu)
Undecided
Unassigned

Bug Description

Device: Nexus 4
OS: Ubuntu Touch 15.04 (r1)
Channel: devel

Steps:
1.) Access "Contacts" app from apps scope
2.) Prompt: "Would you like to sync contacts from your google online accounts now?"
3.) Tap "Yes"
4.) Enter Google account email and password
5.) Screen: Ubuntu would like to: Have offline access
6.) "Accept"
7.) Pop-up: Synchronization: Start Sync
8.) Pop-up: Synchronization: Done

Expected: Google contacts to appear on Phone

Result: No contacts appear on phone

Additionally attempted manual refresh by tapping to refresh button Contacts, still no contacts synced.

Under System Settings --> Accounts --> Google --> Contacts has a check mark

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in address-book-app (Ubuntu):
status: New → Confirmed
TenLeftFingers (tenleftfingers) wrote :

I get a few contacts but about 90% don't arrive. I'm fully up to date as of today.

Sujeevan Vijayakumaran (svij) wrote :

I've got my Meizu MX4 today and had a different behaviour. Step 8 on my phone was, that it said that it's sychronising, but it didn't finish after a couple of minutes. After I've closed the contacts app and started it again, the Google contacts appeared.

Device: Meizu MX4
OS: Ubuntu 15.04 (r1)

Ronnie Tucker (ronnietucker) wrote :

My contacts did eventually show, but I had to hit refresh several times for it to successfully get the contacts.

Pablo (u-contacto) wrote :

I've got the same problem in my Meizu MX4 and my BQ4.5.

I tried to desactivate 2factor and delete the Google Account Permission, and try again, and the same.

In my phone appear 7 random contacts. My Google account have almost 100 contacts, and always see only this 7 contacts.

Aitzol Berasategi (aitzol76) wrote :

Solved.

 I've noticed that deleting google account from my device, do not know how, also removed all contacts from google. That's why when synchronize not loading any. Luckily I had a backup of my contacts and could restore them.

Device: Meizu MX4
OS: Ubuntu 15.04 (r2)

Could you attach your : /home/phable/.cache/upstart/sync-monitor.log file?

Changed in address-book-app (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sync-monitor (Ubuntu):
status: New → Confirmed
GTriderXC (gtriderxc) wrote :

Synchronizing contacts is the only reason I still use my old Nokia phones. First of all Google doesn't sync all the data from the files that Windows or Nokia programs spit out. Second (and that's the reason why I join this bug report): if the synchronization with Google succeed, my Aquaris 4.5 doesn't get all the information from Google! I could understand the details as address, fax etc. but in my contacts I get empty names without a stupid, simple phone number which makes my ubuntu device useless. My Nokias have something like 500 complicated contants which I'm not gonna copy by hand half a Year. This bug is critical for me.

GTriderXC (gtriderxc) wrote :

I also join the problem I forgot to mention above but Pablo had not. Not all contacts from google are synchronized.

Similar issue on MX4 with OTA 9-1. Nothing happens and no contact added.

To detail:I don't have the sync pop up displayed

Bug still here in OTA 11 even with a complete reset of the phone.
On thing to add is that the Contacts application is not appearing in the Settings->Accounts for the google account concerned.

another point, I have tried with another google account with very few contacts and no difference. No contacts imported.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers