[address book] No access to contacts on SIM

Bug #1331346 reported by cm-t 🦄🏂🌈🎵
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Fix Released
Wishlist
Unassigned
Ubuntu UX
Fix Released
High
Olga Kemmet
address-book-app
Fix Released
Undecided
Unassigned
address-book-app (Ubuntu)
Fix Released
High
Renato Araujo Oliveira Filho
ofono (Ubuntu)
Fix Released
Wishlist
Alfonso Sanchez-Beato
ofono (Ubuntu RTM)
Confirmed
Wishlist
Unassigned

Bug Description

Hi,

There are no option to sync contact for a human being form the Contacts apps, from SIM.

Steps :

 * Launch contacts
 * no option to sync, import/export contact are found on the interface (only a search option and a + option)
 * swipe from down to access the + menu, users might expect to add manually contact here, no more option like importing SIM contact.
 * To be sure I checked in the system settings, no import option found there

User should be able to add contact from his SIM card (no one want to import hundreds of contacts manually)

----------UX comment-----------

Please see as per comment #6

Tags: bq usability

Related branches

Tony Espy (awe)
Changed in ofono (Ubuntu):
status: New → Confirmed
Changed in address-book-app (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
Changed in ofono (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Tony Espy (awe) wrote :

Importing contacts from SIM is not currently planned for the first version of Ubuntu Touch. This decision is currently being reviewed internally by product management.

That said, the basic ofono support exists for SIM import. This is supported by the phonebook feature of ofono. The documentation can be found here:

https://github.com/rilmodem/ofono/blob/master/doc/phonebook-api.txt

The rilmodem code to support this exists in the following pending pull request:

https://github.com/rilmodem/ofono/pull/68

Revision history for this message
Tony Espy (awe) wrote :

It also should be noted that SIM contact write support ( one-time, or sync ) is a much more complicated task as it's not currently supported by ofono. This would require working with upstream to extend the existing API and implementing it in the rilmodem driver.

My suggestion would be for a separate bug to be opened for SIM export/sync vs. trying to track both in a single bug.

Revision history for this message
cm-t 🦄🏂🌈🎵 (cm-t) wrote :

HI,

Just for the record, I created the similar bug for SIM, file and account :

 * SIM (this bug report)
 * file : bug #1331348 ( No access to contacts on File )
 * account : bug #1331351 ( contacts syncing is not enough intuitive )

Librement

Revision history for this message
Tony Espy (awe) wrote :

As the ofono phonebook import code referenced in comment #1 has now been merged into our github repo, I'm changing the status of the ofono task to FixCommitted. To be clear, this is import-only support.

Changed in ofono (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Alfonso Sanchez-Beato (alfonsosanchezbeato)
Changed in ubuntu-ux:
assignee: nobody → Olga Kemmet (olga-kemmet)
Changed in address-book-app (Ubuntu):
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Bill Filler (bfiller)
Changed in address-book-app (Ubuntu):
importance: Wishlist → High
Bill Filler (bfiller)
tags: added: usability
Changed in address-book-app (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntu-ux:
importance: Undecided → High
summary: - No access to contacts on SIM
+ [address book] No access to contacts on SIM
Changed in ubuntu-ux:
status: New → Triaged
Tony Espy (awe)
Changed in ofono (Ubuntu RTM):
status: New → Fix Committed
Revision history for this message
Tony Espy (awe) wrote :

Changed ofono (Ubuntu) status to FixReleased as this landed in ofono 1.12.bzr6882+15.04.20141126-0ubuntu1, and added a task for RTM set to Confirmed.

Changed in ofono (Ubuntu):
status: Fix Committed → Fix Released
Changed in ofono (Ubuntu RTM):
status: Fix Committed → Confirmed
importance: Undecided → Wishlist
Revision history for this message
Olga Kemmet (olga-kemmet) wrote :

The long term plan is to include an import option into the Address Book app settings. Design decided not to add an option in the header because in most cases importing SIM contacts is going to be a one time operation.
I believe the interim plan is to include an icon in the landing view of the app, as an individual list item. This item is removed once user did the import.
However, is this item always present or only if the device detects any contacts on the inserted SIM card?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package address-book-app - 0.2+15.04.20150319-0ubuntu1

---------------
address-book-app (0.2+15.04.20150319-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Renato Araujo Oliveira Filho ]
  * Implemented simcard import feature. (LP: #1331346)
 -- CI Train Bot <email address hidden> Thu, 19 Mar 2015 02:02:54 +0000

Changed in address-book-app (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-ux:
status: Triaged → In Progress
description: updated
tags: added: bq
Revision history for this message
John McAleely (john.mcaleely) wrote :

This has been specifically requested by our initial customers.

Revision history for this message
John McAleely (john.mcaleely) wrote :

@pmcgowan, please triage this for canonical-devices-system-image

Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

Its fixed in vivid so will be in the next update.

Changed in canonical-devices-system-image:
status: New → Fix Released
milestone: none → ww13-2015
importance: Undecided → Wishlist
Bill Filler (bfiller)
Changed in address-book-app:
status: New → Fix Released
Revision history for this message
FAUTVOIR (fautvoirplusclair) wrote : Re: [Bug 1331346] Re: [address book] No access to contacts on SIM

Thank's so much for your reactivity and efficience.

Fabien

"Ce n'est pas parce que l'on possède peu que l'on est pauvre,
c'est parce que l'on désire plus."

Sénèque

Le 17/04/2015 17:14, Bill Filler a écrit :
> ** Changed in: address-book-app
> Status: New => Fix Released
>

Revision history for this message
Renato Araujo Oliveira Filho (renatofilho) wrote :

Some people are complaining that still nor working there are receiving timeout messaging from dbus while trying to use ofono test script.

phablet@ubuntu-phablet:~$ /usr/share/ofono/scripts/test-phonebook /ril_0
Traceback (most recent call last):
  File "/usr/share/ofono/scripts/test-phonebook", line 23, in <module>
    print(phonebook.Import(timeout=100))
  File "/usr/lib/python3/dist-packages/dbus/proxies.py", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python3/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python3/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

Revision history for this message
Olga Kemmet (olga-kemmet) wrote :

Marking as Fix Released - Tested on arale 15.04 (r76)

Changed in ubuntu-ux:
status: In Progress → Fix Released
Revision history for this message
vallee (jeanpaul-vallee1) wrote :

Hi,

I'am at the origin of the comment #12,

-Thanks for the fix, will i be able to import old contacts (and may be messages) stored on the sim or is it a workaround ie. will it be a fix to make the soft quit properly ?
- could you tell us when this release will be available on my phone (i 'm a new user of ubuntu phones and i'm not aware of the updates' schedule/process)

Not urgent.
Regards.

Revision history for this message
Renato Araujo Oliveira Filho (renatofilho) wrote :

@Valee

Would be nice if you could open a new bug, describing your problem and
attach your syslog file: "/var/log/syslog"

Thanks

On Mon, Aug 17, 2015 at 9:54 AM, vallee <email address hidden> wrote:
> Hi,
>
> I'am at the origin of the comment #12,
>
> -Thanks for the fix, will i be able to import old contacts (and may be messages) stored on the sim or is it a workaround ie. will it be a fix to make the soft quit properly ?
> - could you tell us when this release will be available on my phone (i 'm a new user of ubuntu phones and i'm not aware of the updates' schedule/process)
>
> Not urgent.
> Regards.
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1331346
>
> Title:
> [address book] No access to contacts on SIM
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/address-book-app/+bug/1331346/+subscriptions

Revision history for this message
vallee (jeanpaul-vallee1) wrote :
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers