crash opening contact detail in qt5.2

Bug #1275841 reported by Bill Filler on 2014-02-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
address-book-app (Ubuntu)
Critical
Renato Araujo Oliveira Filho

Bug Description

upgrade latest image to Qt5.2 using these steps:
https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta2

Steps to reproduce:
1) Launch address-book-app
2) open contact
3) press back button on toolbar
4) open another contact, and crash happens

Running in gdb I see this:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x42b1c0f0 (LWP 4557)]
0x00000000 in ?? ()
(gdb) bt
#0 0x00000000 in ?? ()
#1 0x45b37540 in ?? () from /usr/lib/arm-linux-gnueabihf/qt5/qml/QtContacts/libdeclarative_contacts.so
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
(gdb)

Bill Filler (bfiller) wrote :

updated stack trace from core file
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/arm-linux-gnueabihf/libthread_db.so.1".
Core was generated by `address-book-app --desktop_file_hint=/usr/share/applications/address-book-app.d'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x41c0ab52 in QtContacts::QContact::saveDetail(QtContacts::QContactDetail*) ()
   from /usr/lib/arm-linux-gnueabihf/libQt5Contacts.so.5
(gdb) bt
#0 0x41c0ab52 in QtContacts::QContact::saveDetail(QtContacts::QContactDetail*) ()
   from /usr/lib/arm-linux-gnueabihf/libQt5Contacts.so.5
#1 0x41a6a874 in ?? () from /usr/lib/arm-linux-gnueabihf/qt5/qml/QtContacts/libdeclarative_contacts.so
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
(gdb) bt
#0 0x41c0ab52 in QtContacts::QContact::saveDetail(QtContacts::QContactDetail*) ()
   from /usr/lib/arm-linux-gnueabihf/libQt5Contacts.so.5
#1 0x41a6a874 in ?? () from /usr/lib/arm-linux-gnueabihf/qt5/qml/QtContacts/libdeclarative_contacts.so
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
(gdb) pwd
Working directory /home/phablet.
(gdb)

This was caused by a bug on qtpim, the fix was merged on mainstream: https://codereview.qt-project.org/#change,77393

Changed in address-book-app (Ubuntu):
status: New → In Progress
status: In Progress → Fix Committed
Timo Jyrinki (timo-jyrinki) wrote :
Changed in address-book-app (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers