[NATTY] Adblock 1.3.1doesn't load up in FF 3.6.12

Bug #674171 reported by Chad Waters
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
adblock-plus (Ubuntu)
Fix Released
High
Benjamin Drung
mozilla-devscripts (Ubuntu)
Fix Released
High
Benjamin Drung

Bug Description

Binary package hint: adblock-plus

Adblock 1.3.1-1 does not load up in Firefox 3.6.12.

Reverting to 1.2.2-3build1 corrects the issue.

Revision history for this message
Benjamin Drung (bdrung) wrote :

Thanks for reporting. The underlying problems is that mozilla-devscripts adds quotation marks to the links in /usr/share/mozilla/extensions.

affects: adblock-plus (Ubuntu) → ubuntu
Changed in ubuntu:
importance: Undecided → High
status: New → Triaged
affects: ubuntu → adblock-plus (Ubuntu)
Changed in mozilla-devscripts (Ubuntu):
importance: Undecided → High
Benjamin Drung (bdrung)
Changed in mozilla-devscripts (Ubuntu):
status: New → In Progress
Benjamin Drung (bdrung)
Changed in mozilla-devscripts (Ubuntu):
assignee: nobody → Benjamin Drung (bdrung)
Changed in adblock-plus (Ubuntu):
assignee: nobody → Benjamin Drung (bdrung)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mozilla-devscripts - 0.25

---------------
mozilla-devscripts (0.25) unstable; urgency=low

  * Fix additional quotation marks in extension ID (LP: #674171).
    - update src/dh_xul-ext
    - update src/install-xpi
  * Update package list for Debian experimental and Ubuntu natty.
    - update src/xul-app-data.csv.Debian
    - update src/xul-app-data.csv.Ubuntu
  * Drop backwards compatibility for Icedove/Thunderbird << 3.0.
    - update src/install-xpi
  * Switch from CDBS to dh 7 and simplifying packaging by improving Makefiles.
    - add Makefile
    - update debian/compat
    - update debian/control
    - remove debian/manpages
    - update debian/rules
    - update src/Makefile
  * Use versioned target applications in Depends instead of unversioned target
    applications in Recommends. All extensions have to add ${xpi:Depends} to
    Depends. (Closes: #602051)
    - update src/dh_xul-ext
    - update src/xpi.mk
 -- Benjamin Drung <email address hidden> Fri, 26 Nov 2010 01:02:35 +0100

Changed in mozilla-devscripts (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package adblock-plus - 1.3.1-2

---------------
adblock-plus (1.3.1-2) unstable; urgency=low

  * Add ${xpi:Depends} to Depends and rebuild with mozilla-devscripts 0.25.
    (LP: #674171)
 -- Ubuntu Archive Auto-Sync <email address hidden> Mon, 29 Nov 2010 11:24:19 +0000

Changed in adblock-plus (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers