[UIFe] Blacklisted special folder icons (from nautilus). Upload activity-log-manager 0.9.4

Bug #960498 reported by Manish Sinha (मनीष सिन्हा) on 2012-03-20
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
activity-log-manager (Ubuntu)
Undecided
Unassigned

Bug Description

This release fixes a few i18n issues and also introduces a UI change which aligns it as per the mockups provided by the desktop team

Changelog
==========

i18n:
* Fix LP #957891 and #958483 to make Diagnositics tab translatable
* Fix LP #949849 when X-GNOME-Keywords is changed to Keywords
* Fix untranslated strings in Application and History tab

Bug Fix:
* Fixed a segmentation fault dued to null pixbufs.
* Use "gtk-execute" as application's icon if the application's icon isn't in the current IconTheme.

Major UI Changes:
* Added "Today" and "Yesterday" instead of the date, matching the mockup.
* The Folders blacklisted have icons if they are special folders
* The blacklisted Folders list show the folder name and the folder path for each entry

Minor UI Changes:
* Add border to folder blacklist TreeView
* Force the size of the blacklisted directory's text to be consistent with the size of the label above.
* Make the AppSelection dialog to be orderer automatically by usage.

Relevant Links
============

Release announcement
https://launchpad.net/activity-log-manager/+announcement/9775

Download files
https://launchpad.net/activity-log-manager/0.9/0.9.4

Mail to ubuntu-translators: https://lists.ubuntu.com/archives/ubuntu-translators/2012-March/005236.html
Mail to ubuntu-doc: https://lists.ubuntu.com/archives/ubuntu-doc/2012-March/016432.html

Jeremy Bicha (jbicha) wrote :

Since we have no documentation at all for the new Privacy panel, I don't believe there's any objection from the Docs Team. There's still a few more days to get some help content written though! Any volunteers?

Since we're changing some strings anyway, I think the text on the Files tab should be
"Don't record activity for the following file types:" instead of
"Don't record activity for following type of files:"

Martin Pitt (pitti) wrote :

Seems reasonable, and doc team approved.

Changed in activity-log-manager (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package activity-log-manager - 0.9.4-0ubuntu1

---------------
activity-log-manager (0.9.4-0ubuntu1) precise; urgency=low

  * New upstream release
    - make Diagnositics tab translatable (LP: #957891, #958483)
    - X-GNOME-Keywords is changed to Keywords (LP: #949849)
    - Fix untranslated strings in Application and History tab
    - Add border to folder blacklist TreeView
    - Fixed a segmentation fault dued to null pixbufs.
    - Make the AppSelection dialog to be orderer automatically by usage.
    - Force the size of the blacklisted directory's text to be consistent
      with the size of the label above.
    - Use "gtk-execute" as application's icon if the application's icon
      isn't in the current IconTheme.
    - Added "Today" and "Yesterday" instead of the date, matching the mockup.
    - The Folders blacklisted have icons if they are special folders
    - The blacklisted Folders list show the folder name and the folder
      path for each entry
    - [UIFe] Blacklisted special folder icons (from nautilus). (LP: #960498)
  * debian/watch:
    - update to latest upstream url
  * debian/control:
    - bump Standards-Version
 -- Didier Roche <email address hidden> Wed, 21 Mar 2012 11:16:03 +0100

Changed in activity-log-manager (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers