Privacy Delete history is not deleting download history

Bug #947856 reported by Troels S on 2012-03-06
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Michal Hruby
unity-lens-files
Medium
Michal Hruby
activity-log-manager (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
unity-lens-files (Ubuntu)
Undecided
Unassigned
zeitgeist (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 12.04 beta 1

Problem 1:
When going to system settings --> Privacy --> setting "forget activities" to "all" an pushing "Delete history" button the download history is not deleted an still visible from the dash home, all other activities is deleted just fine.

Problem 2:
If I set "Record Activity" to "off" the download history is not recorded. But if I instead set "Record Activity" to "on" and select "Image" under the "Don't record activity for the following type of files" and then open firefox and download a image, I still see the image in the dash home.

Related branches

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/947856/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Troels S (troelss) on 2012-03-06
affects: ubuntu → gnome-control-center (Ubuntu)
Troels S (troelss) on 2012-03-06
tags: added: precise
affects: gnome-control-center (Ubuntu) → activity-log-manager (Ubuntu)

I think the issue is to do with fts extension not refreshing the index once the events are deleted.

Mikkel (kamstrup) or Michal (mhr3), can you check out if this is the case?

Michal Hruby (mhr3) wrote :

It's not a problem with FTS, the Downloads category in files lens isn't using Zeitgeist and therefore doesn't respect the blacklist filters.

Changed in unity-lens-files:
status: New → Triaged
milestone: none → 5.8.0
assignee: nobody → Michal Hruby (mhr3)
importance: Undecided → Medium
Michal Hruby (mhr3) on 2012-03-09
Changed in unity:
milestone: none → 5.8.0
assignee: nobody → Michal Hruby (mhr3)
status: New → Triaged
importance: Undecided → Medium

Looks like this is a Unity issue than a zeitgeist issue

Changed in activity-log-manager (Ubuntu):
status: New → Invalid
Changed in zeitgeist (Ubuntu):
status: New → Invalid
Michal Hruby (mhr3) on 2012-03-13
Changed in unity:
status: Triaged → In Progress
Changed in unity-lens-files:
status: Triaged → In Progress
Michal Hruby (mhr3) on 2012-03-20
Changed in unity-lens-files:
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-lens-files:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-files - 5.8.0-0ubuntu1

---------------
unity-lens-files (5.8.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - clicking on folders in the file lens does not open nautilus
      (LP: #921665)
    - Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Privacy Delete history is not deleting download history (LP: #947856)
    - Locate scope doesn't respect privacy settings (LP: #955229)
    - \\192.168.1.x opens http:\\192.168.1.x in firefox as opposed to
      smb://192.168.1.x in nautilus (LP: #773841)
    - Web url regexp matches non url (LP: #948086)
  * debian/control:
    - build-dep on newer zeitgeist
 -- Didier Roche <email address hidden> Fri, 23 Mar 2012 15:05:24 +0100

Changed in unity-lens-files (Ubuntu):
status: New → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers