Upgrade Activity Log Manager to 0.9.6

Bug #1189253 reported by Jeremy Bicha on 2013-06-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
activity-log-manager (Ubuntu)
Wishlist
Unassigned

Bug Description

Update:

Activity Log Manager 0.9.6 is out
https://launchpad.net/activity-log-manager/+announcement/11669

This release has diagnostic tab fixed and working even in standalone mode.

Changelog:
* Diagnostic Tab is added back (LP #1192040)
* Diagnostic Tab now even shows in Standalone App Mode (LP #1192778)
* "Send a report automatically" has been disabled (LP $#1192777)
* Drops dependency on zeitgeist-1.0, adds dep on zeitgist-20 (LP #1197269)
* "Privacy Policy" and "Show Previous reports" is now a LinkButton (LP #940483)
* Mimetype Includes are sorted alphabetically (LP #1189266)
* Use Plural in Include List
* Put enough padding between GtkSwitch and "Record file and Application Usage"
* Rename activity-log-manager-ccpanel.desktop.in
  to gnome-activity-log-manager-panel.desktop.in
* Privacy panel in gnome-control-center is only shown in Unity
* Activity Log Manager standalone app does not show in Unity

-----------------------------------------------------------------------------------------
Previous Bug Report Description:

https://launchpad.net/activity-log-manager/+announcement/11547

The new release includes all but one of the Ubuntu patches and combines the Recent Items, Files, and Applications tabs into a single redesigned tab that should be more usable. It also fixes bug 1167531 where activity-log-manager won't run in standalone mode.

Unfortunately, the Diagnostics tab was dropped for this release so to avoid regressions we will need that to be fixed before uploading to Ubuntu.

I'm attaching my .debdiff in case I'm not around later to upload this and in case anyone else wants to try it out.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: activity-log-manager 0.9.4-0ubuntu6.1
ProcVersionSignature: Ubuntu 3.9.0-4.9-generic 3.9.4
Uname: Linux 3.9.0-4-generic x86_64
ApportVersion: 2.10.2-0ubuntu1
Architecture: amd64
Date: Sun Jun 9 17:12:19 2013
MarkForUpload: True
SourcePackage: activity-log-manager
UpgradeStatus: Upgraded to saucy on 2013-05-07 (32 days ago)

Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :
tags: added: patch
Evan (ev) wrote :

This patch works well for me.

Changed in activity-log-manager (Ubuntu):
status: New → Triaged
summary: - Upgrade to 0.9.5
+ Upgrade to 0.9.6
description: updated
summary: - Upgrade to 0.9.6
+ Upgrade Activity Log Manager to 0.9.6
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package activity-log-manager - 0.9.6-0ubuntu1

---------------
activity-log-manager (0.9.6-0ubuntu1) saucy; urgency=low

  * New upstream release. (LP: #1189253, #1050620, #1167531)
  * Don't split control-center plugin to a separate package
  * debian/control:
    - Bump minimum vala
    - Build-depend on libwhoopsie-dev, libzeitgeist-2.0-dev, and
      libgcrypt11-dev (LP: #1197569)
  * debian/watch: Fixed
  * Dropped patches applied in new version:
    - 01_move_to_personal_section.patch
    - 02_handle_upstart_in_whoopsie.patch:
    - 03_correct_path_to_whoopsie_preferences.patch:
    - 04_correct_privacy_policy_url.patch:
    - 05_add_missing_configvapi.patch
    - 05_fix_userdirs.patch
  * debian/patches/01_really_hide_automatic_reports.patch:
    - Don't show "Send automatic reports" since that feature isn't
      implemented yet
  * debian/patches/02_update_standalone_title.patch:
    - Update the title of the standalone app to Activity Log Manager too
  * debian/patches/06_add_unity_dash_privacy.patch:
    - Refreshed and set to only show when Unity is running (LP: #1082552)
 -- Jeremy Bicha <email address hidden> Thu, 04 Jul 2013 12:32:19 -0400

Changed in activity-log-manager (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers