Needs icon for high contrast theme

Bug #1082097 reported by Jeremy Bicha on 2012-11-22
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
activity-log-manager (Ubuntu)
High
Unassigned
gnome-control-center-signon (Ubuntu)
High
Unassigned
gnome-disk-utility (Ubuntu)
High
Unassigned
gnome-themes-standard (Ubuntu)
High
Unassigned
landscape-client (Ubuntu)
High
Unassigned
software-properties (Ubuntu)
High
Unassigned
update-manager (Ubuntu)
High
Unassigned

Bug Description

GNOME provides high contrast icons for all of the panels in System Settings. Ubuntu needs to provides icons for their customizations.

At a minimum, it needs an icon that looks good at 48x48 as I believe that's what System Settings and the Unity dash uses. A 256x256 icon is needed for Unity's Alt-Tab switcher and GNOME Shell's Activities Overview. Also, Unity supports launcher icon size from 32 up to 64 pixels.

To turn on the High Contrast theme, open System Settings. Click Universal Access and switch High Contrast on.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: activity-log-manager-control-center 0.9.4-0ubuntu6
ProcVersionSignature: Ubuntu 3.7.0-3.9-generic 3.7.0-rc6
Uname: Linux 3.7.0-3-generic x86_64
ApportVersion: 2.6.2-0ubuntu5
Architecture: amd64
Date: Thu Nov 22 11:28:33 2012
MarkForUpload: True
SourcePackage: activity-log-manager
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :

This is what System Settings looks like today in raring.

tags: added: kanban
tags: removed: kanban
Jeremy Bicha (jbicha) on 2012-11-22
description: updated
tags: added: a11y
Adolfo Jayme (fitojb) wrote :

Impacts accessibility of a core application => High

Changed in activity-log-manager (Ubuntu):
importance: Undecided → High
Changed in gnome-control-center-signon (Ubuntu):
importance: Undecided → High
Changed in landscape-client (Ubuntu):
importance: Undecided → High
Changed in software-properties (Ubuntu):
importance: Undecided → High
Changed in ubuntuone-control-panel (Ubuntu):
importance: Undecided → High
Changed in landscape-client:
status: New → Opinion
Adolfo Jayme (fitojb) wrote :

@Taowa: Sadly I don't consider this an "opinion", as I'm visually impaired myself.

Changed in activity-log-manager (Ubuntu):
status: New → Triaged
Changed in gnome-control-center-signon (Ubuntu):
status: New → Triaged
Changed in landscape-client (Ubuntu):
status: New → Triaged
Changed in software-properties (Ubuntu):
status: New → Triaged
Changed in ubuntuone-control-panel (Ubuntu):
status: New → Triaged
Jeremy Bicha (jbicha) on 2013-06-03
Changed in landscape-client:
status: Opinion → New
Sam Hewitt (snwh) wrote :

I'd be willing to make all of these, is there a specific (total) list of icons that are needed?

Hello Sam,
These five panels need high contrast icon

1) Privacy Panel
2) Online Accounts
3) Landscape Client
4) Software Properties
5) Ubuntu One

Jeremy Bicha (jbicha) wrote :

Sam, thanks for your interest. This is part of a GNOME goal to get high contrast app icons for at least the default apps:
https://live.gnome.org/GnomeGoals/HighContrastAppIcons

Here's the names of needed icons for current Ubuntu and Ubuntu GNOME default apps:

activity-log-manager
checkbox
credentials-preferences
gnome-tweak-tool
ibus
preferences-management-service (landscape)
remmina
session-properties http://bugzilla.gnome.org/695136
softwarecenter
software-properties
ubuntuone
usb-creator-gtk
microscope -- but should be renamed xdiagnose

You may want to ask around to see if any Ubuntu Touch apps are expected on the Desktop soon (like friends-app).

Additionally,

* Disk Usage Analyzer
* Chrome/Chromium
* Mines
* Software Updater
* Startup Applications
* VLC Media Player
* Disks
* Steam (this might be difficult to get included by default, as it is for a proprietary application)

Sam Hewitt (snwh) on 2013-06-21
Changed in ubuntuone-control-panel (Ubuntu):
assignee: nobody → Sam Hewitt (snwh)
Changed in landscape-client (Ubuntu):
assignee: nobody → Sam Hewitt (snwh)
Changed in software-properties (Ubuntu):
assignee: nobody → Sam Hewitt (snwh)
Jeremy Bicha (jbicha) wrote :

Manish, maybe you're still on 13.04 because Mines and Disk Usage Analyzer have high contrast icons in 13.10. Software Updater will be fixed in the next release of gnome-themes-standard.

Disks is fixed in 3.8 so we either update to 3.8 (LP: #1092719) or we can backport the new icons for 13.10.

no longer affects: gnome-mines (Ubuntu)
Changed in gnome-disk-utility (Ubuntu):
status: New → Fix Committed
no longer affects: baobab (Ubuntu)
Sam Hewitt (snwh) on 2013-06-21
Changed in activity-log-manager (Ubuntu):
assignee: nobody → Sam Hewitt (snwh)

Sam, if you can design the Activity Log Manager (privacy) icon as a hotel-door lock or padlock or anything like that, that would be great.

At the current moment, privacy icon looks like a backup icon and backup icon looks like privacy icon

Jeremy,
Yeah. My bad, I have OpenSUSE GNOME 3.8 snapshot which I should have cross checked to confirm before adding "Affects"

Sam Hewitt (snwh) on 2013-06-21
Changed in gnome-control-center-signon (Ubuntu):
assignee: nobody → Sam Hewitt (snwh)
Sam Hewitt (snwh) on 2013-06-21
Changed in landscape-client:
assignee: nobody → Sam Hewitt (snwh)
Sam Hewitt (snwh) on 2013-06-22
Changed in gnome-control-center-signon:
assignee: nobody → Sam Hewitt (snwh)
no longer affects: gnome-control-center-signon
Sam Hewitt (snwh) on 2013-06-22
Changed in gnome-control-center-signon (Ubuntu):
status: Triaged → Fix Committed
Changed in landscape-client (Ubuntu):
status: Triaged → Fix Committed
Changed in ubuntuone-control-panel (Ubuntu):
status: Triaged → In Progress
Changed in software-properties (Ubuntu):
status: Triaged → In Progress
Changed in activity-log-manager (Ubuntu):
status: Triaged → In Progress
Robert Roth (evfool) on 2013-07-06
Changed in update-manager (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Jeremy Bicha (jbicha) on 2013-09-07
affects: gnome-tweak-tool (Ubuntu) → gnome-themes-standard (Ubuntu)
Changed in gnome-themes-standard (Ubuntu):
status: New → Fix Committed
Changed in gnome-themes-standard (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-themes-standard - 3.8.3-0ubuntu1

---------------
gnome-themes-standard (3.8.3-0ubuntu1) saucy; urgency=low

  [ Jeremy Bicha ]
  * New upstream release
    - Add more high contrast app icons including gnome-tweak-tool
      (LP: #1082097)

  [ Tim Lunn ]
  * Backport new blinds background from 3.10 (LP: #1222043)
 -- Tim Lunn <email address hidden> Sat, 07 Sep 2013 16:34:48 +1000

Changed in gnome-themes-standard (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-disk-utility - 3.8.2-1ubuntu2

---------------
gnome-disk-utility (3.8.2-1ubuntu2) saucy; urgency=low

  * Depend on gnome-icon-theme-symbolic
 -- Jeremy Bicha <email address hidden> Wed, 18 Sep 2013 10:10:52 -0400

Changed in gnome-disk-utility (Ubuntu):
status: Fix Committed → Fix Released
Sam Hewitt (snwh) on 2014-02-18
Changed in activity-log-manager (Ubuntu):
assignee: Sam Hewitt (snwh) → nobody
Changed in gnome-control-center-signon (Ubuntu):
assignee: Sam Hewitt (snwh) → nobody
Changed in landscape-client:
assignee: Sam Hewitt (snwh) → nobody
Changed in landscape-client (Ubuntu):
assignee: Sam Hewitt (snwh) → nobody
Changed in software-properties (Ubuntu):
assignee: Sam Hewitt (snwh) → nobody
Changed in ubuntuone-control-panel (Ubuntu):
assignee: Sam Hewitt (snwh) → nobody
Adolfo Jayme (fitojb) on 2015-05-30
no longer affects: ubuntuone-control-panel (Ubuntu)

This bug has not seen any activity in the last 6 months, so it is being automatically closed.

If you are still experiencing this issue, please feel free to re-open.

Landscape Team

Changed in landscape-client:
status: New → Invalid
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1082097

tags: added: iso-testing
Changed in gnome-themes-standard (Ubuntu):
importance: Undecided → High
Changed in gnome-disk-utility (Ubuntu):
importance: Undecided → High
Changed in update-manager (Ubuntu):
importance: Undecided → High
affects: landscape-client → ubuntu
no longer affects: ubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers