Activity Log Manager crashes with GLib-GIO-CRITICAL **: g_application_list_actions: assertion `application->priv->is_registered' failed

Bug #1058037 reported by Alin Andrei on 2012-09-28
102
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Activity Log Manager
Critical
Manish Sinha (मनीष सिन्हा)
activity-log-manager (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
Saucy
Undecided
Unassigned

Bug Description

Activiy Log Manager 0.9.4-0ubuntu4 crashes on startup with the following error:

(activity-log-manager:20944): Gtk-CRITICAL **: gtk_box_pack: assertion `gtk_widget_get_parent (child) == NULL' failed

(activity-log-manager:20944): GLib-GIO-CRITICAL **: g_application_list_actions: assertion `application->priv->is_registered' failed

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: activity-log-manager 0.9.4-0ubuntu4
ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
Date: Fri Sep 28 13:55:17 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120914)
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: activity-log-manager
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Alin Andrei (nilarimogard) wrote :
Cliff Carson (ccarson1) wrote :

This crash occurred on my system. Apport started the bug collection but never completes and uploads the data. Just stops with no other indications.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in activity-log-manager (Ubuntu):
status: New → Confirmed
Balló György (ballogy) wrote :

This happens also on Arch Linux.

Maarten Baert (maarten-baert) wrote :

I found the problem. Apparently GtkApplication isn't used properly (see patch). I've almost no experience with Vala or GTK so I can't really say why the old code was crashing, but my patch apparently fixes it.

Maarten Baert (maarten-baert) wrote :

While I'm at it, I also have a fix for the other warning. The warning is harmless though, it's just a widget that's added twice.

The attachment "patch for src/alm.vala" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Steve Dodier-Lazaro (sidi) wrote :

I tested the patch and it did fix the segfault and warning for me.

Changed in activity-log-manager:
importance: Undecided → Low
milestone: none → 0.9.5
status: New → Confirmed
Changed in activity-log-manager:
assignee: nobody → Manish Sinha (मनीष सिन्हा) (manishsinha)
importance: Low → Critical
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

I'll add quantal tasks for the SRU. Can you please check the status of this in raring and saucy? This can't be SRUed before it gets fixed in the development release. Thanks!

Changed in activity-log-manager (Ubuntu):
status: Confirmed → In Progress

Hello Martin,
I will get it in Saucy asap

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in activity-log-manager (Ubuntu Quantal):
status: New → Confirmed
Prunus dulcis (prunus-dulcis) wrote :

In Raring it still crashes:
(activity-log-manager:31543): Gtk-CRITICAL **: gtk_box_pack: assertion `gtk_widget_get_parent (child) == NULL' failed
(activity-log-manager:31543): GLib-GIO-CRITICAL **: g_application_list_actions: assertion `application->priv->is_registered' failed
Segmentation fault (core dumped)

activity-log-manager:
  Installed: 0.9.4-0ubuntu6.1
  Candidate: 0.9.4-0ubuntu6.1

Jeremy Bicha (jbicha) wrote :

This was fixed for Saucy at the same as bug 1050620 was fixed.

Changed in activity-log-manager (Ubuntu Saucy):
status: In Progress → Fix Released

Also needs a task for Raring

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in activity-log-manager (Ubuntu Raring):
status: New → Confirmed
Changed in activity-log-manager:
status: Fix Committed → Fix Released

Hello Alin, or anyone else affected,

Accepted activity-log-manager into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/activity-log-manager/0.9.4-0ubuntu6.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in activity-log-manager (Ubuntu Raring):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in activity-log-manager (Ubuntu Quantal):
status: Confirmed → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Alin, or anyone else affected,

Accepted activity-log-manager into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/activity-log-manager/0.9.4-0ubuntu4.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Sami Jaktholm (sjakthol) wrote :

Activity Log Manager from raring proposed doesn't crash when started in standalone mode.

tags: added: verification-done-raring
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package activity-log-manager - 0.9.4-0ubuntu6.2

---------------
activity-log-manager (0.9.4-0ubuntu6.2) raring; urgency=low

  * debian/patches/07_fix_gtkapplication.patch:
    - Fixes bug for wrong usage of GtkAPplication.
      (LP: #1058037, #1050620, #1197904)
 -- Manish Sinha <email address hidden> Thu, 04 Jul 2013 11:06:33 -0700

Changed in activity-log-manager (Ubuntu Raring):
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in activity-log-manager (Ubuntu Quantal):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers