activity-log-manager crashed with SIGSEGV in g_action_muxer_insert()

Bug #1050620 reported by Logan Rosen on 2012-09-13
124
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Activity Log Manager
High
Manish Sinha (मनीष सिन्हा)
activity-log-manager (Ubuntu)
Medium
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
Saucy
Medium
Unassigned

Bug Description

This crash occurred when attempting to run activity-log-manager from Terminal.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: activity-log-manager 0.9.4-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-14.16-generic 3.5.3
Uname: Linux 3.5.0-14-generic x86_64
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
Date: Thu Sep 13 16:52:01 2012
ExecutablePath: /usr/bin/activity-log-manager
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120821)
ProcCmdline: activity-log-manager
ProcEnviron:
 TERM=xterm
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7fcc0ae2cbf8: mov (%rax),%rsi
 PC (0x7fcc0ae2cbf8) ok
 source "(%rax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rsi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: activity-log-manager
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 gtk_window_set_application () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 g_cclosure_marshal_VOID__OBJECTv () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: activity-log-manager crashed with SIGSEGV in gtk_window_set_application()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Logan Rosen (logan) wrote :

StacktraceTop:
 g_action_muxer_insert (muxer=0xcc6d50, prefix=0x7fcc0b0fe11d "app", action_group=0x936010) at /build/buildd/gtk+3.0-3.5.16/./gtk/gactionmuxer.c:645
 gtk_window_set_application (window=window@entry=0x938110, application=application@entry=0x936010) at /build/buildd/gtk+3.0-3.5.16/./gtk/gtkwindow.c:2845
 gtk_application_window_added (application=0x936010, window=window@entry=0x938110) at /build/buildd/gtk+3.0-3.5.16/./gtk/gtkapplication.c:507
 g_cclosure_marshal_VOID__OBJECTv (closure=0x934020, return_value=<optimized out>, instance=0x936010, args=<optimized out>, marshal_data=<optimized out>, n_params=<optimized out>, param_types=0x934050) at /build/buildd/glib2.0-2.33.12/./gobject/gmarshal.c:1312
 _g_closure_invoke_va (closure=0x934020, return_value=0x0, instance=0x936010, args=0x7fffe3d67528, n_params=1, param_types=0x934050) at /build/buildd/glib2.0-2.33.12/./gobject/gclosure.c:840

Changed in activity-log-manager (Ubuntu):
importance: Undecided → Medium
summary: - activity-log-manager crashed with SIGSEGV in
- gtk_window_set_application()
+ activity-log-manager crashed with SIGSEGV in g_action_muxer_insert()
tags: removed: need-amd64-retrace
Logan Rosen (logan) on 2012-09-13
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in activity-log-manager (Ubuntu):
status: New → Confirmed
tags: added: running-unity
Changed in activity-log-manager:
assignee: nobody → Manish Sinha (मनीष सिन्हा) (manishsinha)
importance: Undecided → High
milestone: none → 0.9.5
status: New → Confirmed

Fixed it long time back. It was caused because the GtkApplication was not initialized properly. Thanks to desrt for explaining how to it is done

Changed in activity-log-manager:
status: Confirmed → Fix Committed
Daniel Nyström (speakman) wrote :

Still not pushed out to 12.10 users. Still crashes here.

Yup. It hasn't been released yet. When it is released, then it won't crash.

I would try to get it patched on 12.10 even before release
On Apr 19, 2013 4:15 AM, "Daniel Nyström" <email address hidden>
wrote:

> Still not pushed out to 12.10 users. Still crashes here.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1050620
>
> Title:
> activity-log-manager crashed with SIGSEGV in g_action_muxer_insert()
>
> Status in Activity Log Manager for Zeitgeist:
> Fix Committed
> Status in “activity-log-manager” package in Ubuntu:
> Confirmed
>
> Bug description:
> This crash occurred when attempting to run activity-log-manager from
> Terminal.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.10
> Package: activity-log-manager 0.9.4-0ubuntu3
> ProcVersionSignature: Ubuntu 3.5.0-14.16-generic 3.5.3
> Uname: Linux 3.5.0-14-generic x86_64
> ApportVersion: 2.5.1-0ubuntu7
> Architecture: amd64
> Date: Thu Sep 13 16:52:01 2012
> ExecutablePath: /usr/bin/activity-log-manager
> InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64
> (20120821)
> ProcCmdline: activity-log-manager
> ProcEnviron:
> TERM=xterm
> SHELL=/bin/bash
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SegvAnalysis:
> Segfault happened at: 0x7fcc0ae2cbf8: mov (%rax),%rsi
> PC (0x7fcc0ae2cbf8) ok
> source "(%rax)" (0x00000000) not located in a known VMA region (needed
> readable region)!
> destination "%rsi" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: activity-log-manager
> StacktraceTop:
> ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
> gtk_window_set_application () from
> /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
> ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
> g_cclosure_marshal_VOID__OBJECTv () from
> /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> Title: activity-log-manager crashed with SIGSEGV in
> gtk_window_set_application()
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/activity-log-manager/+bug/1050620/+subscriptions
>

Daniel Nyström (speakman) wrote :

What's taking so long?

I proposed an bug-fix update for quantal
https://code.launchpad.net/~zeitgeist/activity-log-manager/fix-bug-1058037/+merge/159896

It needs to be approved and uploaded by the developers.

Martin Pitt (pitti) wrote :

I'll add quantal tasks for the SRU. Can you please check the status of this in raring and saucy? This can't be SRUed before it gets fixed in the development release. Thanks!

Changed in activity-log-manager (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in activity-log-manager (Ubuntu Quantal):
status: New → Confirmed
Prunus dulcis (prunus-dulcis) wrote :

In Raring it still crashes:

activity-log-manager:
  Installed: 0.9.4-0ubuntu6.1
  Candidate: 0.9.4-0ubuntu6.1

Prunus dulcis (prunus-dulcis) wrote :

Sorry, was a different crash – looking closer at the terminal output it was the same as https://bugs.launchpad.net/ubuntu/+source/activity-log-manager/+bug/1058037

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package activity-log-manager - 0.9.6-0ubuntu1

---------------
activity-log-manager (0.9.6-0ubuntu1) saucy; urgency=low

  * New upstream release. (LP: #1189253, #1050620, #1167531)
  * Don't split control-center plugin to a separate package
  * debian/control:
    - Bump minimum vala
    - Build-depend on libwhoopsie-dev, libzeitgeist-2.0-dev, and
      libgcrypt11-dev (LP: #1197569)
  * debian/watch: Fixed
  * Dropped patches applied in new version:
    - 01_move_to_personal_section.patch
    - 02_handle_upstart_in_whoopsie.patch:
    - 03_correct_path_to_whoopsie_preferences.patch:
    - 04_correct_privacy_policy_url.patch:
    - 05_add_missing_configvapi.patch
    - 05_fix_userdirs.patch
  * debian/patches/01_really_hide_automatic_reports.patch:
    - Don't show "Send automatic reports" since that feature isn't
      implemented yet
  * debian/patches/02_update_standalone_title.patch:
    - Update the title of the standalone app to Activity Log Manager too
  * debian/patches/06_add_unity_dash_privacy.patch:
    - Refreshed and set to only show when Unity is running (LP: #1082552)
 -- Jeremy Bicha <email address hidden> Thu, 04 Jul 2013 12:32:19 -0400

Changed in activity-log-manager (Ubuntu Saucy):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in activity-log-manager (Ubuntu Raring):
status: New → Confirmed
Changed in activity-log-manager:
status: Fix Committed → Fix Released

Hello Logan, or anyone else affected,

Accepted activity-log-manager into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/activity-log-manager/0.9.4-0ubuntu6.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in activity-log-manager (Ubuntu Raring):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in activity-log-manager (Ubuntu Quantal):
status: Confirmed → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Logan, or anyone else affected,

Accepted activity-log-manager into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/activity-log-manager/0.9.4-0ubuntu4.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Sami Jaktholm (sjakthol) wrote :

Activity Log Manager from raring proposed doesn't crash when started in standalone mode.

tags: added: verification-done-raring
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package activity-log-manager - 0.9.4-0ubuntu6.2

---------------
activity-log-manager (0.9.4-0ubuntu6.2) raring; urgency=low

  * debian/patches/07_fix_gtkapplication.patch:
    - Fixes bug for wrong usage of GtkAPplication.
      (LP: #1058037, #1050620, #1197904)
 -- Manish Sinha <email address hidden> Thu, 04 Jul 2013 11:06:33 -0700

Changed in activity-log-manager (Ubuntu Raring):
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in activity-log-manager (Ubuntu Quantal):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers