Ubuntu

acroread 9.5.1 is not installable on Ubuntu Precise amd64 system

Reported by Jeffery von Ronne on 2012-04-28
462
This bug affects 40 people
Affects Status Importance Assigned to Milestone
adobe-isv
Undecided
Unassigned
acroread (Ubuntu)
Undecided
Unassigned
Nominated for Precise by Adam Stokes
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned

Bug Description

----
Adobe Reader is missing from Ubuntu Raring & Quantal;
meanwhile, Adobe Reader 9.5.3 has been released upstream,
see bug #1106447.
----

The acroread_9.5.1-1precise1_i386.deb package cannot be installed on a x86_64 Ubuntu 12.04 where i386 is enabled as a foreign architecture, because it depends on acroread-common and acroread-common_9.5.1-1precise1_all.deb does not satisfy this dependency.

This can be reproduced using aptitude, synaptic, apt-get, and dkpg. For example:
$ apt-get install acroread-common
...
$ apt-get install acroread:i386
 Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 acroread:i386 : Depends: acroread-common:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.

I believe the problem is that acroread-common package is not being created with a "Multi-Arch: foreign" field.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in acroread (Ubuntu):
status: New → Confirmed

It looks like the amd64 deb isn't building properly - see https://launchpad.net/ubuntu/+source/acroread/9.5.1-1precise1/+build/3404003

From the build log, this looks like an issue with the ia32-libs build dependency.

I'm not sure if the intent here is to build separate i386 and amd64 debs as with the previous releases (acroread itself will be 32-bit in either case, I think), or to have acroread installed as acroread:i386 from precise on, which leads to the problem reported by Jeffery.

I'm not a multiarch expert (yet :-)), so I'm hoping someone who knows more about muliarch and this package will weigh in.

Bob Bib (bobbib) on 2012-05-01
tags: added: amd64 multiarch packaging precise
Sergio Callegari (callegar) wrote :

IMHO it would be great to abandon the 'fake' 64 bit deb of acroread, fix multiarch and let ia32-libs disappear.

Incidentally, note that acroread in kde relies on the gtk engine qtcurve and that i386 gtk engines do not seem to be installable in precise 64bit. This too needs to be fixed via proper multiarch support.

Bob Bib (bobbib) wrote :

The description of acroread 9.5.1 package suggests this bug affects security.
---
acroread (9.5.1-1precise1) precise; urgency=low

  * New upstream release, addresses security issues:
    - http://www.adobe.com/support/security/bulletins/apsb12-08.html

security vulnerability: no → yes
summary: - acroread 9.5 not installable on x86_64 precise pangolin
+ acroread 9.5.1 is not installable on Ubuntu Precise amd64 system

This bug is caused by multiple issues.

The AMD64 deb that is available depends on ia32-libs, but this transitional package is not installable at all on Ubuntu Precise. It depends on 32-bit libraries that still conflict with 64-bit libraries.

MultiArch support is broken regarding architecture independent packages. There is no such thing as acroread-common:i386 because acroread-common is an architecture independent "all" package and the exact same package can be used with both the 64-bit and 32-bit version. MultiArch somehow adds :i386 everywhere, but this is nonsense in this case. It should not do that with "all" packages and just use the plain version.

Of course, it's also silly that acroread can't be compiled for AMD64.

Bob Bib (bobbib) wrote :

A patch has been provided in a duplicate bug report:
https://bugs.launchpad.net/ubuntu/+source/acroread/+bug/998837/comments/1

Lalo Martins (lalo.martins) wrote :

I'll confirm that the patch makes things work for me, if in a slightly roundabout way. Details in the duplicate.

Ron Johnson (ron-l-johnson) wrote :

I this something that Precise users will have to live with?

Mark Fraser (launchpad-mfraz) wrote :

I hope this isn't something we've got to live with. They shouldn't be expecting every user to have to run a patch just to get a new version of Acroread.

Colin Watson (cjwatson) wrote :

Julius, this is intentional behaviour laid out in the multiarch spec (https://wiki.ubuntu.com/MultiarchSpec#Dependencies_involving_Architecture:_all_packages).

The simple and correct fix here is just to make acroread-common "Multi-Arch: foreign".

Liviu Andronic (landronimirc) wrote :

That's a nasty bug. Is there some PPA available that allows to nicely install acroread on Precise?

tags: added: patch
Liviu Andronic (landronimirc) wrote :

I used the patch in Bug #998837 to publish a build of 'acroread' v9.5.1 on my PPA. [1]
# add-apt-repository ppa:landronimirc/experimental
# apt-get update
# aptitude

And then install 'acroread:i386'. It works for me on a fresh Precise install, 64-bit.

[1] https://launchpad.net/~landronimirc/+archive/experimental

Mark Fraser (launchpad-mfraz) wrote :

Still the same with Ubuntu 12.10.

Mark Fraser,
> Still the same with Ubuntu 12.10.

It seems that acroread hasn't arrived into Ubuntu 12.10 yet: https://launchpad.net/ubuntu/+source/acroread

Liviu Andronic (landronimirc) wrote :

Using the patch in Bug #998837 I published a build of 'acroread' v9.5.1 on the 'acroread (multiarch)' PPA. [1]
# add-apt-repository ppa:landronimirc/acroread
# apt-get update
# aptitude

And then installing 'acroread:i386' should work on a 64-bit installation. The PPA comes with packages for Raring, Quantal, and Precise.

[1] https://launchpad.net/~landronimirc/+archive/acroread/

Bob Bib (bobbib) wrote :

Liviu Andronic (landronimirc),
why aptitude?

I hope you've meant:
$ sudo add-apt-repository ppa:landronimirc/acroread
$ sudo apt-get update
$ sudo apt-get install acroread:i386

---
Still no 'acroread' in Quantal? Nobody cares :)

Liviu Andronic (landronimirc) wrote :

> why aptitude?

I couldn't manage to install the packages from the PPA using Synaptic, but it went fine with aptitude. You can also use apt-get, as you note above.

Bob Bib (bobbib) wrote :

Well, the latest version of Adobe Reader for Linux is 9.5.3;
the latest Ubuntu package version is still acroread 9.5.1-1precise1;
it seems that maintainer this package is orphaned.

Bob Bib (bobbib) wrote :

I've reported a request for acroread 9.5.3 as bug #1106447.

Liviu Andronic (landronimirc) wrote :

It seems that maintainer this package is orphaned. I tried to provide a PPA for the package but I deleted it upon request from Launchpad.

I would gladly help someone with commit rights to update the package. If a developer reads this please let me know. (On a personal note, it is a big deal that such an important package as Acrobat Reader isn't really available in Ubuntu.)

Bob Bib (bobbib) on 2013-02-11
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in acroread (Ubuntu Quantal):
status: New → Confirmed

Aobe reader 9.5.4 is available for lucid+ releases

Changed in acroread (Ubuntu Quantal):
status: Confirmed → Fix Released
Changed in acroread (Ubuntu Raring):
status: Confirmed → Fix Released
Changed in adobe-isv:
status: New → Fix Released
Bob Bib (bobbib) wrote :

Well, thank you all for fixing this long-running problem!

Laurent Dinclaux (dreadlox) wrote :

How is that solved ??????

$ cat /etc/apt/sources.list | grep partner
## 'partner' repository.
deb http://archive.canonical.com/ubuntu raring partner

$ sudo apt-get install acroread
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package acroread is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'acroread' has no installation candidate

Sergio Gelato (sergio-gelato) wrote :

On Sun, 28 Apr 2013 00:35:20 -0000, Laurent Dinclaux
<email address hidden> wrote:
> How is that solved ??????
>
> $ cat /etc/apt/sources.list | grep partner
> ## 'partner' repository.
> deb http://archive.canonical.com/ubuntu raring partner
>
> $ sudo apt-get install acroread
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Package acroread is not available, but is referred to by another
package.
> This may mean that the package is missing, has been obsoleted, or
> is only available from another source
>
> E: Package 'acroread' has no installation candidate

I won't speculate on why the package hasn't been included in the
partner repository for raring (yet?), but:
(a) as a stop-gap measure you could try installing the version
from quantal;
(b) maybe this warrants a new bug report, since the title of this
one refers explicitly to Ubuntu precise and to an outdated
version (9.5.1) of Adobe reader.

Bob Bib (bobbib) wrote :

Request for Acroread in Raring & Saucy repositories is filed as bug #1176131.

Roland Giesler (lifeboy) wrote :

When I use landronimirc's patched PPA I get prompted to install a whole lot of i386 code on my 64bit Ubuntu 12.04

#sudo apt-get install adobereader-enu
Reading package lists... Done
Building dependency tree
Reading state information... Done
adobereader-enu:i386 is already the newest version.
You might want to run 'apt-get -f install' to correct these:

Then
#apt-get -f install

The following NEW packages will be installed:
  libatk1.0-0:i386 libcairo2:i386 libdatrie1:i386 libgdk-pixbuf2.0-0:i386 libgtk2.0-0:i386 libjasper1:i386 libpango1.0-0:i386 libpixman-1-0:i386
  libthai0:i386 libxcb-render0:i386 libxcb-shm0:i386 libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386 libxfixes3:i386 libxft2:i386
  libxinerama1:i386 libxrandr2:i386

What is the effect of this and won't it mess things up on my machine

There is no bad effect on installing ia32libs, anyway please DON'T use any ppas for acroread, but just the ubuntu repository instead

To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers