Karmic 64 bit: Package acroread is missing from partner repo

Bug #437566 reported by philinux on 2009-09-27
56
This bug affects 8 people
Affects Status Importance Assigned to Milestone
acroread (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by nanog

Bug Description

Binary package hint: acroread

Package acroread-fonts is present, from medibuntu, but not acroread.

Changed in acroread (Ubuntu):
status: New → Confirmed
Jean.c.h (slug71) wrote :

As is the 32bit.

Are you positive that you have the partner repository enabled?

$ apt-cache policy acroread
acroread:
  Installed: (none)
  Candidate: 9.1.0-7jaunty2
  Version table:
     9.1.0-7jaunty2 0
        500 http://archive.canonical.com karmic/partner Packages

Make sure you have the following line in /etc/apt/sources.list

deb http://archive.canonical.com/ubuntu karmic partner

Changed in acroread (Ubuntu):
status: Confirmed → Incomplete
Khem Raj (khem-raj) wrote :

May be its there for 32-bit but on 64-bit it still is missing. I do have partner repo enabled and your command says this and I am uptodate till today on packages.

$ apt-cache policy acroread
acroread:
  Installed: (none)
  Candidate: (none)
  Version table:

philinux (philcb) wrote :

Definitely missing on 64bit
## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu karmic partner

Is enabled.
apt-cache policy acroread
acroread:
  Installed: (none)
  Candidate: (none)
  Version table:

philinux (philcb) wrote :

Jaunty partner repo.
http://archive.canonical.com/ubuntu/dists/jaunty/partner/binary-amd64/Packages
acroread, alfresco-pdf2swf, alfresco-community, openbravo-erp

Karmic partner repo
http://archive.canonical.com/ubuntu/dists/karmic/partner/binary-amd64/Packages
Is Empty

Confirmed. Is there any plan to re-add acroread package to 64-bit karmic?

Changed in acroread (Ubuntu):
status: Incomplete → Confirmed

If there is no soon plan for 64-bit Adobe Reader, it would at least be useful to include a 32-bit version with proper libraries, like they do in debian-multimedia repository:
http://debian-multimedia.org/

David E. Fox (dfox94085) wrote :

OK. A couple of things:

1) A partner repository cannot exist on a beta product until release, as far as my understanding of the release process. I could be wrong.

2) a PPA may exist, but unlikely as Adobe isn't a GPL product.

3) We are still unaware of a roadmap for Acrobat for Karmic, since it still is in beta,

32 bit support for a 64 bit architecture is doable via ia32-libs support. (Googleearth etc.) Not optimal, but it works.

Apparently, newer versions of "acroread" do support native 64 bit. This is preferred.
I have done a few google searches and none seem accurate enough to point me to a repository that has it. One suggestion was to install a deb. That may work, but require a "force-architecture" switch to get the deb to install (exact error message indicates basically wrong architecture). Undesirable for several reasons.

Conclusion - I'd mark the bug as "invalid" but we need a better roadmap, or a reason until Karmic is officially released. Once Karmic is out of beta, we can address that issue.

2009/10/17 Michał Gołębiowski <email address hidden>:
> @David E. Fox
> Ad. 1) See
> http://archive.canonical.com/ubuntu/dists/karmic/partner/binary-i386/Packages
> As You see, it is *not* empty. Opposite to this one:
> http://archive.canonical.com/ubuntu/dists/karmic/partner/binary-amd64/Packages

That is almost useless. I double checked the links - the first one
says it is a Karmic repository, but it is in fact a Jaunty package as
per the description, unless of course it actually is verifiable as a
valid solution, and if it is, then it mighyt be the right suggestion.
In generalities though, it is improper to suggest putting something up
saying it is for a specific version of Ubuntu where it clearly states
that it may not be. That could lead to a broken box.

I suspect I had a 64 bit reader for some time when I ran 64 bit (and I
have been 64 bit on Ubuntu since 5/2008) but my memory is a bit
fading.

Of course, should a bona fide verifiable link to "acroread" exist then
maybe it's a valid bug. But if even so, it should be filed "wishlist"
just on the general principle that the original filer of the bug is
really asking that he wishes acroread to be in Karmic, not that it is
an omission to not have it yet.

--
thanks for letting me change the magnetic patterns on your hard disk.

philinux (philcb) wrote :

I filed the bug as an omission not a wishlist. Jaunty 64 bit partner repo has the acroread package, I'm pretty sure it had it during development. Why cant the package just be copied over to karmic?

David E. Fox (dfox94085) wrote :

On Sun, Oct 18, 2009 at 3:53 AM, philinux <email address hidden> wrote:

Semantic quibbling. You might like not liike the reasons I see where
bug filing status is important - the latter was only meant to be a
suggestion why wishilst is preferred to omisison. Raising the issue is
or may be more important, of course.

It is clearly not my desire or intent to decide what the status is,
but I wanted to be clear as to why I'd choose one status over the
other. It is not relavant at all now that Karmic is in beta release.

It of course is a valid to the extent that some poople like to use
acrobat reader. Ubuntu by definition cannot legally provide Acrobat
per se. That in effect could just mark the status of the bug invalid.
Preferable here to get the package in a few weeks (by live in ca 12
days we can reopen the issue. Finding a good repository that gives me
a working up to date acrobat reader is of course beneficial to the
community. We can't predict that now. And because it is unsupported I
see now the status of the bug marked as invalid by developers, but
comments raised with more authority than me (Ubuntu Development team,
that sort of thing, or whoever may maintain acroread when Karmic goes
live.

getting the maintainer of a package is basically trivial in Ubuntu as
in any modern distribution that is open source (god help those who are
unable to ask people such questions, of course, but I think he is
subscribing to the bug.

I shall of course listen to him... :)

--
thanks for letting me change the magnetic patterns on your hard disk.

@David E. Fox
As for a working repository - here:
deb http://www.debian-multimedia.org squeeze main
You can find working acroread package. It is 32-bit and uses ia32-libs.

I use acroread package from this repo. However, Mozilla plugin seems not working (all files opens in a separate Adobe Reader window).

CyrusCT (cyrusct) wrote :

Can the partner repository exist for Release Candidate?
(I still don't see it in the repository)

Given a choice of installing the 64-bit Jaunty release:
http://archive.canonical.com/pool/partner/a/acroread/acroread_9.1.3-1jaunty1_amd64.deb
or installing the one from Adobe's Website:
http://get.adobe.com/reader/thankyou/?installer=Reader_9.1.2_English_for_Linux_%28.deb%29
using a "force-architecture" switch, which would be more stable in Karmic?

Does anyone have an estimate for how long until the 64-bit version will be available in the Karmic repositories?
(depending on how long the wait might be, would it be better to wait?)

Changed in acroread (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers