cooling fan not turning on while in screen saver Aspire 5100

Bug #428721 reported by stlubuntu on 2009-09-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
acpid (Ubuntu)
Undecided
Unassigned

Bug Description

Cooling fan does not turn on when it should while in screen save (or powersave screen off) causing an overheat and safety shutdown of laptop at 95 degrees C.

Acer Aspire 5100 laptop running 64-bit Ubuntu 8.04.3 LTS. 1 MG RAM 2 Mhz dual core AMD processor (Turion 64-bit), acpi 0.09-3ubuntu1, acpid 1.0.4-5ubuntu9.3, acpi-support 0.109-0hardy2.

This is a new issue. This machine has been running 64-bit Ubuntu 8.04 since April 2008 and this problem only recently began to occur. I would expect the fan to be turned on when necessary even when in screen saver or monitor powersave off mode to keep the cpu within acceptable operating parameters. This being a new issue is why I am not attributing this to a hardware issue and am wondering if a recent update caused a regression.

My temporary workaround is I installed a cpu temperature monitoring applet which resides on my upper panel and not only displays the current temperature but also sounds a repeating alarm whenever the cpu temp exceed 72 C.

I can reproduce this by leaving the machine alone and allowing it to go into screensaver and after some time the alarms will sound. Once I wiggle the mouse the fan will then turn on and bring the temperature back to acceptable levels.

While using the computer normally, I notice that it usually operates in the mid 50's C and the fan will turn on when it reaches 63 C and bring it back to the mid fifties.

I have not yet attempted a BIOS upgrade to see if that would help (I feel like since this is a new problem that I should not have to resort to that.)

Thanks for taking a look at this and attempting to resolve it.

stlubuntu (jlrbennett) wrote :

Update: This also occurs while playing a youtube video in firefox (currently running Shiretoko 3.5.4pre.) Again, temporary workaround is to close the tab playing the video and temperature returns to normal operating range.

stlubuntu (jlrbennett) wrote :

Updated BIOS to v3.13. Problem persists.

stlubuntu (jlrbennett) wrote :

Update: Currently, I am running 2.6.24-24-generic #1 SMP x86_64 and I did still have 2.6.24-23-generic #1 SMP x86_64 in my GRUB menu from the last kernel upgrade, which clearly was prior to when this problem began to occur. So, I rebooted and selected this older kernel, but much to my dismay, the problem persists. Looks like it might not be a kernel issue.

Also, tried operating on battery only -- problem persists. Also, tried operating with battery removed and plugged in -- problem persists.

stlubuntu (jlrbennett) wrote :

Recently, I bought a aerosol can of compressed air (used for cleaning electronics.) I sprayed a finely directed burst of air in one of the side airvents of the laptop and a cloud of dust came out the other vent. LIkewise, I sprayed another burst of air in the other side airvent and again a cloud of dust came out the other side. Now the laptop cpu operates about 20 degrees C cooler and has not exhibited the problem since.

Appears to be solved for me at this point. Changing this bug to invalid. However, I do plan on hanging on to Hardy as others appear to be having this problem in Jaunty. I probably will wait for 10.04 LTS Lucid Lynx to upgrade.

stlubuntu (jlrbennett) wrote :

Status Change to invalid as bug was not confirmed by another user and the problem appears to have been caused by excessive dust obstructing airflow.

Changed in acpid (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers