acpica-unix: New upstream release 20120913 whit full support for the ACPI 5.0 specification

Bug #1060791 reported by Karma Dorje on 2012-10-03
This bug affects 1 person
Affects Status Importance Assigned to Milestone
acpica-unix (Debian)
Fix Released
acpica-unix (Ubuntu)

Bug Description

$ LANG=C apt-cache policy iasl
  Installed: 20100528-3
  Candidate: 20100528-3
  Version table:
 *** 20100528-3 0
        500 precise/main amd64 Packages
        100 /var/lib/dpkg/status


Karma Dorje (taaroa) on 2012-10-03
tags: added: upgrade-software-version
Karma Dorje (taaroa) on 2012-10-03
Changed in acpica-unix (Ubuntu):
status: New → Confirmed
Karma Dorje (taaroa) wrote :

it seems that the new version requires a small change in the build process

 #YACC= byacc
 #YFLAGS += -v -d
-YACC= bison
+YACC= LC_ALL=C bison
 YFLAGS += -v -d -y

-LEX= flex
+LEX= LC_ALL=C flex
 LFLAGS += -i -s

and finally we do
make BITS=64

compiled without problems.

Changed in acpica-unix (Debian):
status: Unknown → New
Martin Pitt (pitti) wrote :

Nothing to sponsor here, unsubscribing sponsors.

Changed in acpica-unix (Debian):
status: New → Fix Committed
Changed in acpica-unix (Debian):
status: Fix Committed → Fix Released
Hans Joachim Desserud (hjd) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
I see that acpica-unix version 20140214-1ubuntu1 is available in Ubuntu 14.04 LTS, so I believe this issue can be considered fixed.

Changed in acpica-unix (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.