must unload, reload ipw3945 module after hibernate

Bug #66266 reported by Michael Blakeley on 2006-10-15
10
Affects Status Importance Assigned to Milestone
acpi (Ubuntu)
Low
Unassigned

Bug Description

Kubuntu 6.10 beta 1, plus dist-upgrades to 2006-10-15. I'm running on an HP nc6400 with an Intel T7200 CPU, bios rev F.05. I'm using the acpi-support /etc/acpi/hibernate.sh script.

Before hibernating, the ipw3945 is working fine: I can iwlist and I can associate with wifi access points. Hibernate and resume both succeed. However, after resuming, iwlist shows no results:

$ iwlist eth1 scan
eth1 Interface doesn't support scanning.

The problem is simple enough to work around:

$ sudo modprobe -r ipw3945; sudo modprobe ipw3945

After that, my wifi works again.

I've added ipw3945 to the /etc/default/acpi-support MODULES list, to see if that helps. Per the comments in that file, though, all network modules should already be unloaded and reloaded by acpi-support. Perhaps this module isn't being flagged correctly? I don't know how to check on that.

Hardware details:

$ lspci | grep 3945
10:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

Packages that may be relevant:

acpi/edgy uptodate 0.09-1
acpi-support/edgy uptodate 0.89
kde-guidance-powermanager/edgy uptodate 0.7.0-0ubuntu1
linux-image-generic/edgy uptodate 2.6.17.10
linux-image-2.6.17-10-generic/edgy uptodate 2.6.17-10.33
linux-restricted-modules-2.6.17-10-generic/edgy uptodate 2.6.17.5-10
linux-restricted-modules-common/edgy uptodate 2.6.17.5-10

Please let me know if I can provide any other information that would help.

Michael Blakeley (mike+ubuntu) wrote :

I've confirmed the suggested workaround:

$ grep ^MODULES /etc/default/acpi-support
MODULES="ipw3945"

Zak B. Elep (zakame) wrote :

I can confirm this on my MSI MegaBook S262 running both Kubuntu Dapper and Ubuntu Edgy. The two workarounds do just as nicely. ;-)

Setting Importance to Low for now, as I believe users may probably just want ipw3945 working in and out of hibernation.

Changed in acpi:
importance: Undecided → Low
status: Unconfirmed → Confirmed
Mikael Gerdin (mgerdin) wrote :

I have seen the same problem a couple of times on my laptop, but it was the binary-blob daemon that had been killed, if you experience the problem again, you could try "sudo /sbin/ipw3945d-`uname -r`" in a terminal.

FiNeX (finex) wrote :

@Michael: can you test your laptop with the new Gutsy Gibbon? The #58247 is resolved in Gutsy, maybe if it is related we can close this bug too.

Michael Blakeley (mike+ubuntu) wrote :

Yes, this seems to be fixed in gutsy. I've been running it for months, but hadn't removed ipw3945 from the MODULES line from /etc/default/acpi-support. Now I've done so, and rebooted, and after a suspend-resume cycle my ipw3945 is still working.

Changed in acpi:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers