Ubuntu

Suspend doesn't work on a Latitude E6500

Reported by Marc on 2010-05-31
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
acpi (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: acpi

Binary package hint: xorg

Laptop:
- Latitude E6500 with an intel video card.
- Clean Lucid Lynx install
-

Problem: Going to Suspend, the backgroundlight of the display stays on and therefore the powerbutton stays glowing. not blinking like on a successful suspend.
Afterwards:
- Resume does`nt work.
- Magic-Keys doesn`t work.
- It seems not to be a kernel-panic because the Caps-Lock and the othere LEDs are not blinking
- it seems not to be the intel-driver - because the special ppa from "Glasen" with version 2.11 has the same problem

I've been searching around launchpad and others related sites with no luck. I've already tested:
- Turn off backlight with some commads, like XSET ... - all working fine
- windows and fedora 13 - Suspend working very fine and like expected
- karmic with no security-updates also working fine, I got the failure after an update, but i don´t no which
- I've tried 2.6.34 mainline with the same result.
- I will try to check which update under karmic brings the problem up

---
Architecture: x64
DistroRelease: Ubuntu 10.04
InstallationMedia: DistUpgrade from Interpid->Karmic-> Ubuntu 10.04 LTS "Lucid Lynx" - Release x64
Test-Installation with clean Lucid -> same problem
MachineType: Dell Inc. Latitude E6500
Package: xorg 1:7.5+5ubuntu1
PackageArchitecture: x64

I will test suspend today evening, and search for
Log-Files.

Marc (schuetz-marc) wrote :

Ok, I must add that I'm confused.

I thinked about the last kernelchanges for suspend, and that there are some fixes from TUXonICE.
So I searched for an PPA/Patch and found one, tried it. And, woohoo. Suspend with TUXonICE works fine.

So I booted back in the Lucid-Kernel, tried Suspend. And now it doesnt go in suspend, but it locks only the screen. When I type my password, I'm back on the Desktop. So but I think from the TuxOnIce-PPA I only installed the kernel. No other packages.
Whats wrong?

---
checked dpkg, so I think the changes come from this package:
ii tuxonice-userui 1.0.git20100407~ppa6~lucid1 user-space interfaces for TuxOnIce

So I will try to go back to get log-files of the issue.
You will hear from me. regards Marc

Marc (schuetz-marc) wrote :

Hi all,

Ok interesting. After a few minutes, I played around and would check if hibernate is working.
I don´t have a swap, so I created one. Tested hibernate. Suspend to disk seems to work, but it don´t get on. It booted like a normal start, with TUXonICE it doesn´t go into suspend to disk. But this is another issue.

So I played again with suspend to ram, and no its working, with the LUCID-KERNEL! ?? So ubuntu needs a swap on my hardware to go into. Is it in generell so in ubuntu? WHY`?

I don´t like a swap, but no I need to have one. OK better with SuspendToRAM as without.
But why, Windopws, Fedora, TUXonICE and earlier versions of ubuntu don´t need a swap.
Technical there is no ned of a swap.

Now I have 8GB swap. So how much I need for working? 1MB? 32MB? I don´t no. (I have 4GB RAM)

Regards Marc

Marc (schuetz-marc) wrote :

So. actually:

when the package "tuxonice-userui" is installed the following failure will prevent the standard-lucid-kernel going into S2RAM:

#/usr/lib/pm-utils/sleep.d/99tuxoniceui suspend suspend:/usr/lib/pm-utils/sleep.d/99tuxoniceui: 10: cannot create /sys/power/tuxonice/user_interface/enable_escape: Directory nonexistent
#Returned exit code 2.
#Fri Jun 4 07:30:47 CEST 2010: Inhibit found, will not perform suspend
#Fri Jun 4 07:30:47 CEST 2010: Running hooks for resume

---

when the package is removed it is functional:

#Fri Jun 4 07:33:38 CEST 2010: performing suspend
#Fri Jun 4 07:33:48 CEST 2010: Awake.

---

Marc (schuetz-marc) wrote :

I don't no why, but at the moment suspend without the tuxonice-userui package and with "only" disabled SWAP-Partition and Standard Lucid-Kernel is working.
After month of doing this not.

hinkie (hinkie) wrote :

My Dell E6500 with the NVIDIA NVS-160M video and 0.3 Webcam 4G RAM also fails to standby on lid close, (in both XP) and Ubuntu 10.04 32 bit (PAE). It does suspend using the Fn-Suspend key combination though. This is using the docking station. I'll notify more should I find it. There are many reports of this on the net under various OS, makes one wonder if its a hardware issue?

micred (tict) wrote :

Please report bios AND kernel version for working and nonworking machines.
Old bios revision A06 should be more stable for suspension issue (according to forum comments). You agree?
Latest kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/ should improve suspension issues. You agree?

micred (tict) wrote :

Please try to install uswsusp:
sudo apt-get install uswsusp

This actually solve my suspension issues.
I successfully do a batch of 20 suspend-resume tests:
sudo /usr/share/checkbox/scripts/suspend_test --enable repeat

Ubuntu 10.10 - 2.6.35-22-generic
Latitude E6500 - Intel video card - BIOS A23

David N. Welton (davidnwelton) wrote :

I get intermittent suspend problems with an E6500 and Maverick.

2.6.35-25-generic

Can I get the BIOS version from within Linux?

00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

I'm not using the proprietary Broadcom drivers - I tried them and it still seemed to run into problems.

TheMarquis (thehappymarquis) wrote :

I'm on a e6500 latitude and I just tested suspend, work fine here

David N. Welton (davidnwelton) wrote :

I have (fingers crossed) not encountered problems with this since upgrading to 11.10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers