Ubuntu

Fan spins at full speed all the time on various Fujitsu Siemens Amilos

Reported by Kristoffer Lundén on 2006-08-24
52
This bug affects 6 people
Affects Status Importance Assigned to Milestone
acpi (Ubuntu)
Undecided
Unassigned

Bug Description

This seems to be a problem on a number of Fujitsu Siemens Amilo models and also on other distros, so it's not Ubuntu specific. At least M3438G (which I have) M4438, 7440G, M1439G and probably more[1].

It was discussed on the kernel bugzilla[2] but was finally rejected as not an ACPI bug.

However, several of these models also carry a Linux-based media system called PowerCinema InstantOn, which has a working fan that adjusts after temperature. The company has a lot of source code available under GPL and similar on their homepage[3], but noone seems to know if there is a solution there.

I don't really expect any solution to this in the short term, but it is something that should be fixed sooner or later for proper laptop support - having it go full speed at all times affect both battery life, sound levels and the overall lifetime of the fan/computer.

1. http://www.amilo-forum.com/topic,46,-Amilo-M1439G-Fan-Problem.html
2. http://bugzilla.kernel.org/show_bug.cgi?id=5670
3. http://www.cyberlink.com/english/products/powercinema/pcm-linux/pcmlinuxgpl.jsp

I'm having the same problem on Fujitsu-Siemens Amilo M7440G

Vasily Kozlovskiy (kozlovsk) wrote :

Ubuntu 7.10 beta didn't solve this issue (at least on FujitsuSiemens Amilo m3438g). The bug still persists.

Iacopo Masi (iacopo-masi) wrote :

yes this annoing bus is present in 7.10 also with amilo m1425!
Please fix it1

Dmitry Zuikov (dzuikov) wrote :

Confirm this bug on Fujitsu-Siemens P7020. It's very annoing

Dmitry Zuikov (dzuikov) wrote :

$cat /etc/issue
Ubuntu 7.10 \n \l

$uname -r
2.6.22-14-generic

$ls /proc/acpi/fan/

$ cat /proc/acpi/thermal_zone/TZ00/cooling_mode
<setting not supported>

On 7.04 everething worked ok (at least fans did not work all the time)

Iacopo Masi (iacopo-masi) wrote :

My value:

$cat /etc/issue
Ubuntu 7.10 \n \l

$ uname -r
2.6.22-14-generic

$ls /proc/acpi/fan/

$cat /proc/acpi/thermal_zone/THRM/cooling_mode
<setting not supported>

I think we could made a tool to control the fan speed like the windows' s one Notebook Hardware Control:
http://nhc.justred.info/ Here you can grab a lot of ACPI files for NHC. Is it possible to transale that files for Fujitsu in the way to control fan?

My fan was noise also in 7.04

Marco De Angelis (o-slash) wrote :

Confirm same issue on Fujitsu-Siemens M1437G. Even if CPU Fan is always on, as reported by others, CPU temp growth fast over 70°C on every cpu-intensive application like media encoding or 3d graphics, making the notebook quite unusable for modern tasks.

Unfortunately, the only solution i've found by now, was to buy a 3-fan external cooling pad...

Vasily Kozlovskiy (kozlovsk) wrote :

Found this latest Nvidia driver release information:
http://www.nvidia.com/object/linux_display_ia32_169.09.html

Had an idea that this could probably solve this issue, at least some of the machines in the list have nvidia cards:
M1439G - NVIDIA GeForce Go 6600
M3438G, M4438G - NVIDIA GeForce Go 6800
They have only one fan for both CPU and graphics. Unfortunately can't test it right now.

Iacopo Masi (iacopo-masi) wrote :

mhh I have a ATI mobility radeon 9800

adrien (adrien5) wrote :

Hi,

I have a similar problem on the Amilo A7640W with Ubuntu 7.10.

The ACPI doesn't support FAN control

( I have disassembled the dsdt and no reference to the FAN from what I could see : http://pastebin.com/f11e37b0c )

My processor temperature is monitored by the K8temp driver (It's a Sempron 3000+).

the temp for the mobo ( I suppose ) is located at : /proc/acpi/thermal_zone/THRM/
the temp fro the proc is located at /sys/device/pci0000:00/0000:00:18.3/temp1_input

I am still in search of fan speed settings because I have realized my fan is spinning at 4 different speeds:

max speed when CPU temp is 75C / lower speed at 64C / lower speed at 61C / lowest speed at 54C.

However, I don't know yet what controls the speed and the fan is still very loud at its lowest speed.

erik veninga (ejopzee) wrote :

Fan spins at full speed on Fujitsu Amilo Pro 3515.

There was/is a workaround at http://ubuntuforums.org/showthread.php?t=482900&highlight=AMILO+Pro+V3515

However, the fan is starting/stopping after the laptop has been suspended.

This is the case on Ubuntu 7.10. On hardy 8.04 rd 6 it's spinning full speed, after suspend not tested yet.

Oliver Kalkbrenner (oliver-k) wrote :

Today I've installed the Beta Version of Ubuntu 8.10 with Nvidia Driver Version 177.76 but it seems that there will never be a solution. Everything seems to work except the fan, it spins all the time.
Why the hell is cyberlink able to control the fan :-(
So, no news at the Intrepid Ibex.

Tim (toudewolbers) wrote :

having the same issues. My fan on my dell D630C runs high speed constantly after a upgrade to ubuntu 8.04 > 8.10.

Tim (toudewolbers) wrote :

problem solved for now if you install the nvidia 173 driver.

> having the same issues. My fan on my dell D630C runs high speed constantly after a upgrade to ubuntu 8.04 > 8.10.

same here.

> having the same issues. My fan on my dell D630C runs high speed constantly after a upgrade to ubuntu 8.04 > 8.10.

I was able to fix the issue by downgrading "NVIDIA accelerated graphics driver" from version 177 to version 173.

dome (ildome) wrote :

I have the same problem with Ubuntu 8.10 (2.6.27-8-generic) on a laptop Fujitsu/siemens amilo pro 2010, pentium M 1600.

At pc start CPU fan won't stop and run at maximum speed, until the CPU temperature don't increase to 56°C (more or less). So I usually force the CPU up to 100% load for some minute.
After this the fan run only when necessary. My fan speed steps are: off, 50%, 100% of throttles.

I have a solution that worked for my pc on Ubuntu 7.04, 7.10, 8.04:
1- Generate a script with these lines:

#!/bin/bash
temp=`cat /proc/acpi/thermal_zone/THRM/temperature | awk '{print$2}'`
stop="56"
if [ $temp -le $stop ]
then
 echo "on" >/proc/acpi/fan/FN2/state
 echo 3 >/proc/acpi/fan/FN2/state
fi

2- Name it (in my case: cpufan.sh)

3- Make it run at start-up coping the file script in: /etc/init.d/

4- Make the script executable:
chmod +x /etc/init.d/cpufan.sh

5- Run the command:
sudo update-rc.d -f cpufan.sh start 1 2 3 4 5 .

This solution doesn't work on my Ubuntu 8.10 any more. :(
I've found it browsing internet:
http://www.slacky.eu/forum/viewtopic.php?p=88533&sid=270da7c2d488da31fc2100963412e4c0
http://www.hwupgrade.it/forum/showthread.php?p=17692680

I've tried to variate the value "56" in the script, but with no positive results.

Should I attach some log to show better the problem? Which one?

erik veninga (ejopzee) wrote :

I have tried it with the new karmic development ubuntu 2.6.31-3-generic #19-Ubuntu SMP Tue Jul 14 16:04:41 UTC 2009 i686 GNU/Linux beta 3 version.

The fan still runs at full speed. Would this be solved anytime?

Pipo (tijn) wrote :

Same problem with Amilo M3438G in Karmic Koala 2.6.31-20 kernel

eZFlow (breakdevize) wrote :

still happens on the dell d630c

erik veninga (ejopzee) wrote :

Now in version 11.04 fan is still running on full speed. After suspend the fan runs on low speed and only starts when the computer is heating up.

Fujitsu Siemens Amilo Pro V3515
uname -a
Linux ****-AMILO-PRO-V3515 2.6.38-11-generic
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.04
DISTRIB_CODENAME=natty
DISTRIB_DESCRIPTION="Ubuntu 11.04"

Laurent Dinclaux (dreadlox) wrote :

Lots of ASUS laptop have same sort of issue: #876335, for the fan. How is your power consumption? Normal?

Hi Power consumption seems to be normal. The fan has always shown the
same under all linux versions i used for ubuntu. Don't know whats not
normal and also don't know how to measure.

Erik

-------- Originele bericht --------
Onderwerp: [Bug 57617] Re: Fan spins at full speed all the time on
various Fujitsu Siemens Amilos
Van: Lox <email address hidden>
Aan: <email address hidden>
Datum: 31-10-11 13:03
> Lots of ASUS laptop have same sort of issue: #876335, for the fan. How
> is your power consumption? Normal?
>

mue.de (emuede) wrote :

https://bugs.launchpad.net/ubuntu/+source/acpi/+bug/57617/comments/22

Same Issue under a fresh installed Oneiric Ocelot on my Fujitsu-Siemens M7440

muelux@muelux-lt69a:~$ lsb_release -idr
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10

lshw
  *-core
       description: Motherboard
       product: AMILO M7440
       vendor: FUJITSU SIEMENS
       physical id: 0
       version: 0.5C
       serial: 9A5808456
     *-firmware
          description: BIOS
          vendor: FUJITSU SIEMENS
          physical id: 0
          version: 1.0F-1210-8A20
          date: 06/03/05
          size: 64KiB
          capabilities: isa pci pcmcia pnp apm upgrade shadowing escd cdboot acpi usb agp biosbootspecification
     *-cpu
          description: CPU
          product: Intel(R) Pentium(R) M processor 1.73GHz
          vendor: Intel Corp.
          physical id: 4
          bus info: cpu@0
          version: 6.13.8
          slot: U1
          size: 800MHz
          capacity: 800MHz
          width: 32 bits
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 mtrr pge mca cmov clflush dts acpi mmx fxsr sse sse2 ss tm pbe up bts est tm2 cpufreq

A patch ( http://wiki.ubuntuusers.de/Fujitsu_Siemens_Amilo_M7440 ) workes for the WLAN Switch (fsam7440) but not for the fan, since the structure under ''/proc/acpi/fan...'' doesn't exist (in this release of Ubuntu).

Phillip Susi (psusi) wrote :

Upstream was correct to reject this. The fan speed is controlled by the motherboard/bios. The lm-sensors package has two scripts, sensors-detect, and fancontrol, that you *may* be able to use to take over control to work around a buggy bios.

Changed in acpi (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers