ACPI error, Namespace lookup failure, AE_NOT_FOUND

Bug #551654 reported by Claudio Melis on 2010-03-30
122
This bug affects 26 people
Affects Status Importance Assigned to Milestone
acpi (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: acpi

On a new fresh Lucid installation in a brand new HP dv6 laptop i get this error on dmesg

[ 0.575433] ACPI Error (psargs-0359): [\_PR_.CPU0._PPC] Namespace lookup failure, AE_NOT_FOUND
[ 0.575440] ACPI Error (psparse-0537): Method parse/execution failed [\CPUT] (Node f741bb70), AE_NOT_FOUND
[ 0.575476] ACPI Error (psparse-0537): Method parse/execution failed [\PSSC] (Node f741bb88), AE_NOT_FOUND
[ 0.575510] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPCB.EC0_._REG] (Node f7412ed0), AE_NOT_FOUND
[ 0.585757] ACPI Error: No handler for Region [PCFG] (f744d708) [PCI_Config] (20090903/evregion-319)
[ 0.585761] ACPI Error: Region PCI_Config(2) has no handler (20090903/exfldio-295)
[ 0.585766] ACPI Error (psparse-0537): Method parse/execution failed [\J380._STA] (Node f744c510), AE_NOT_EXIST
[ 0.622836] ACPI Error: No handler for Region [PCFG] (f744d708) [PCI_Config] (20090903/evregion-319)
[ 0.622841] ACPI Error: Region PCI_Config(2) has no handler (20090903/exfldio-295)
[ 0.622845] ACPI Error (psparse-0537): Method parse/execution failed [\J380._STA] (Node f744c510), AE_NOT_EXIST
[ 0.622881] ACPI Error (uteval-0250): Method execution failed [\J380._STA] (Node f744c510), AE_NOT_EXIST
[ 0.716400] ACPI Error: No handler for Region [PCFG] (f744d708) [PCI_Config] (20090903/evregion-319)
[ 0.716405] ACPI Error: Region PCI_Config(2) has no handler (20090903/exfldio-295)
[ 0.716409] ACPI Error (psparse-0537): Method parse/execution failed [\J380._STA] (Node f744c510), AE_NOT_EXIST
[ 0.716446] ACPI Error (uteval-0250): Method execution failed [\J380._STA] (Node f744c510), AE_NOT_EXIST

I have a intel i5 430m processor.

Claudio Melis (mebitek) wrote :

error acpi messages disappear on kernel mainline 2.6.34-999-generic #201003311145

Claudio Melis (mebitek) wrote :

when I disconnect AC cable on /var/log/messages i get:

r 15 09:52:34 marmidha kernel: [ 171.358071] ACPI Error (psargs-0359): [^^^RP05.J380.D3EF] Namespace lookup failure, AE_NOT_FOUND
Apr 15 09:52:34 marmidha kernel: [ 171.358085] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPCB.EC0_._Q20] (Node f7412f30), AE_NOT_FOUND
Apr 15 09:52:42 marmidha kernel: [ 179.778245] ACPI Error (psargs-0359): [^^^RP05.J380.D3EF] Namespace lookup failure, AE_NOT_FOUND
Apr 15 09:52:42 marmidha kernel: [ 179.778258] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPCB.EC0_._Q20] (Node f7412f30), AE_NOT_FOUND

kernel is fresh 2.6.32-21

I get the following errors on amd64 in my /var/log/messages. I have a fresh install of Lucid Lynx.

  0.683901] ACPI Error: No handler for Region [SACS] (ffff88012ba46870) [PCI_Config] (20090903/evregion-319)
May 3 09:01:46 home kernel: [ 0.683901] ACPI Error: Region PCI_Config(2) has no handler (20090903/exfldio-295)
May 3 09:01:46 home kernel: [ 0.683901] ACPI Error (psparse-0537): Method parse/execution failed [\PRID.P_D0._STA] (Node ffff88012bb462a0), AE_NOT_EXIST
May 3 09:01:46 home kernel: [ 0.683901] ACPI Error (uteval-0250): Method execution failed [\PRID.P_D0._STA] (Node ffff88012bb462a0), AE_NOT_EXIST
May 3 09:01:46 home kernel: [ 0.683901] ACPI Error: No handler for Region [SACS] (ffff88012ba46870) [PCI_Config] (20090903/evregion-319)
May 3 09:01:46 home kernel: [ 0.683901] ACPI Error: Region PCI_Config(2) has no handler (20090903/exfldio-295)
May 3 09:01:46 home kernel: [ 0.683901] ACPI Error (psparse-0537): Method parse/execution failed [\PRID.P_D1._STA] (Node ffff88012bb46380), AE_NOT_EXIST
May 3 09:01:46 home kernel: [ 0.683901] ACPI Error (uteval-0250): Method execution failed [\PRID.P_D1._STA] (Node ffff88012bb46380), AE_NOT_EXIST
May 3 09:01:46 home kernel: [ 0.683901] ACPI Error: No handler for Region [SACS] (ffff88012ba46870) [PCI_Config] (20090903/evregion-319)
May 3 09:01:46 home kernel: [ 0.683901] ACPI Error: Region PCI_Config(2) has no handler (20090903/exfldio-295)
May 3 09:01:46 home kernel: [ 0.683901] ACPI Error (psparse-0537): Method parse/execution failed [\SECD.S_D0._STA] (Node ffff88012bb46560), AE_NOT_EXIST
May 3 09:01:46 home kernel: [ 0.683901] ACPI Error (uteval-0250): Method execution failed [\SECD.S_D0._STA] (Node ffff88012bb46560), AE_NOT_EXIST
May 3 09:01:46 home kernel: [ 0.683901] ACPI Error: No handler for Region [SACS] (ffff88012ba46870) [PCI_Config] (20090903/evregion-319)
May 3 09:01:46 home kernel: [ 0.683901] ACPI Error: Region PCI_Config(2) has no handler (20090903/exfldio-295)
May 3 09:01:46 home kernel: [ 0.683901] ACPI Error (psparse-0537): Method parse/execution failed [\SECD.S_D1._STA] (Node ffff88012bb46640), AE_NOT_EXIST
May 3 09:01:46 home kernel: [ 0.683901] ACPI Error (uteval-0250): Method execution failed [\SECD.S_D1._STA] (Node ffff88012bb46640), AE_NOT_EXIST

Alan Treadway (alantreadway) wrote :

Same errors here as the OP, same hardware (HP Pavilion dv6); error messages occur whenever AC power is plugged/unplugged.

Repeated errors in /var/log/syslog:
May 5 12:55:50 flolap010 kernel: [13957.798431] ACPI Error (psargs-0359): [^^^RP05.J380.D3EF] Namespace lookup failure, AE_NOT_FOUND
May 5 12:55:50 flolap010 kernel: [13957.798446] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPCB.EC0_._Q20] (Node ffff88013ba3c780), AE_NOT_FOUND

As a consequence (?) laptop-mode-tools do not detect the switch from AC to battery power (and vice-versa), and neither does gnome-power-manager (system tray battery icon remains in "charging" state).

Claudio Melis (mebitek) wrote :

On latest kernel 2.6.34-rc7 message error disappear. Now I get:

HP WMI: Unknown response received

Those are the errors on my dmesg:

mebitek@marmidha:~$ dmesg |grep -i error
[ 0.456092] ACPI Error: No handler for Region [ERAM] (f7420be0) [EmbeddedControl] (20100121/evregion-369)
[ 0.456096] ACPI Error: Region EmbeddedControl(3) has no handler (20100121/exfldio-293)
[ 0.456101] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0._INI] (Node f742a738), AE_NOT_EXIST

mebitek@marmidha:~$ dmesg |grep -i warning
[ 0.504988] ACPI Warning for \_SB_.PCI0.P0P1._PRT: Return Package has no elements (empty) (20100121/nspredef-456)
[ 91.010839] warning: `VirtualBox' uses 32-bit capabilities (legacy support in use)

Claudio Melis (mebitek) wrote :

on kernel 2.6.34 stable vanilla some as last rc7 version

Paul Pace (openletter) wrote :

I get the same problem on fresh install:

Jun 7 16:19:10 MythTV kernel: [ 16.595374] ACPI Error: No handler for Region [SACS] (ffff88006dfe8678) [PCI_Config] (20090903/evregion-319)
Jun 7 16:19:10 MythTV kernel: [ 16.595383] ACPI Error: Region PCI_Config(2) has no handler (20090903/exfldio-295)
Jun 7 16:19:10 MythTV kernel: [ 16.595389] ACPI Error (psparse-0537): Method parse/execution failed [\PRID.P_D0._STA] (Node ffff88006dfd4840), AE_NOT_EXIST
Jun 7 16:19:10 MythTV kernel: [ 16.595418] ACPI Error (uteval-0250): Method execution failed [\PRID.P_D0._STA] (Node ffff88006dfd4840), AE_NOT_EXIST
Jun 7 16:19:10 MythTV kernel: [ 16.595434] ACPI Error: No handler for Region [SACS] (ffff88006dfe8678) [PCI_Config] (20090903/evregion-319)
Jun 7 16:19:10 MythTV kernel: [ 16.595439] ACPI Error: Region PCI_Config(2) has no handler (20090903/exfldio-295)
Jun 7 16:19:10 MythTV kernel: [ 16.595444] ACPI Error (psparse-0537): Method parse/execution failed [\PRID.P_D1._STA] (Node ffff88006dfd4940), AE_NOT_EXIST
Jun 7 16:19:10 MythTV kernel: [ 16.595471] ACPI Error (uteval-0250): Method execution failed [\PRID.P_D1._STA] (Node ffff88006dfd4940), AE_NOT_EXIST
Jun 7 16:19:10 MythTV kernel: [ 16.595487] ACPI Error: No handler for Region [SACS] (ffff88006dfe8678) [PCI_Config] (20090903/evregion-319)
Jun 7 16:19:10 MythTV kernel: [ 16.595492] ACPI Error: Region PCI_Config(2) has no handler (20090903/exfldio-295)
Jun 7 16:19:10 MythTV kernel: [ 16.595497] ACPI Error (psparse-0537): Method parse/execution failed [\SECD.S_D0._STA] (Node ffff88006dfd4b40), AE_NOT_EXIST
Jun 7 16:19:10 MythTV kernel: [ 16.595524] ACPI Error (uteval-0250): Method execution failed [\SECD.S_D0._STA] (Node ffff88006dfd4b40), AE_NOT_EXIST
Jun 7 16:19:10 MythTV kernel: [ 16.595538] ACPI Error: No handler for Region [SACS] (ffff88006dfe8678) [PCI_Config] (20090903/evregion-319)
Jun 7 16:19:10 MythTV kernel: [ 16.595543] ACPI Error: Region PCI_Config(2) has no handler (20090903/exfldio-295)
Jun 7 16:19:10 MythTV kernel: [ 16.595548] ACPI Error (psparse-0537): Method parse/execution failed [\SECD.S_D1._STA] (Node ffff88006dfd4c40), AE_NOT_EXIST
Jun 7 16:19:10 MythTV kernel: [ 16.595575] ACPI Error (uteval-0250): Method execution failed [\SECD.S_D1._STA] (Node ffff88006dfd4c40), AE_NOT_EXIST

TobiThu (tober) wrote :
Download full text (12.2 KiB)

Same errors here on a fresh install.

I'm using a ASUS M51Ta with switchable graphics ( AMD HD3200 and HD3650 ).

# grep ACPI /var/log/syslog
Jun 8 09:35:34 fire kernel: [ 0.272981] ACPI: Using PIC for interrupt routing
Jun 8 09:35:34 fire kernel: [ 0.281082] ACPI Error: No handler for Region [SACS] (ffff88013bf6f168) [PCI_Config] (20090903/evregion-319)
Jun 8 09:35:34 fire kernel: [ 0.281224] ACPI Error: Region PCI_Config(2) has no handler (20090903/exfldio-295)
Jun 8 09:35:34 fire kernel: [ 0.281330] ACPI Error (psparse-0537): Method parse/execution failed [\PRID.P_D0._STA] (Node ffff88013bebf840), AE_NOT_EXIST
Jun 8 09:35:34 fire kernel: [ 0.281498] ACPI Error (uteval-0250): Method execution failed [\PRID.P_D0._STA] (Node ffff88013bebf840), AE_NOT_EXIST
Jun 8 09:35:34 fire kernel: [ 0.281664] ACPI Error: No handler for Region [SACS] (ffff88013bf6f168) [PCI_Config] (20090903/evregion-319)
Jun 8 09:35:34 fire kernel: [ 0.281785] ACPI Error: Region PCI_Config(2) has no handler (20090903/exfldio-295)
Jun 8 09:35:34 fire kernel: [ 0.281903] ACPI Error (psparse-0537): Method parse/execution failed [\PRID.P_D1._STA] (Node ffff88013bebf920), AE_NOT_EXIST
Jun 8 09:35:34 fire kernel: [ 0.282091] ACPI Error (uteval-0250): Method execution failed [\PRID.P_D1._STA] (Node ffff88013bebf920), AE_NOT_EXIST
Jun 8 09:35:34 fire kernel: [ 0.282254] ACPI Error: No handler for Region [SACS] (ffff88013bf6f168) [PCI_Config] (20090903/evregion-319)
Jun 8 09:35:34 fire kernel: [ 0.282373] ACPI Error: Region PCI_Config(2) has no handler (20090903/exfldio-295)
Jun 8 09:35:34 fire kernel: [ 0.282493] ACPI Error (psparse-0537): Method parse/execution failed [\SECD.S_D0._STA] (Node ffff88013bebfb00), AE_NOT_EXIST
Jun 8 09:35:34 fire kernel: [ 0.282676] ACPI Error (uteval-0250): Method execution failed [\SECD.S_D0._STA] (Node ffff88013bebfb00), AE_NOT_EXIST
Jun 8 09:35:34 fire kernel: [ 0.282840] ACPI Error: No handler for Region [SACS] (ffff88013bf6f168) [PCI_Config] (20090903/evregion-319)
Jun 8 09:35:34 fire kernel: [ 0.282959] ACPI Error: Region PCI_Config(2) has no handler (20090903/exfldio-295)
Jun 8 09:35:34 fire kernel: [ 0.283079] ACPI Error (psparse-0537): Method parse/execution failed [\SECD.S_D1._STA] (Node ffff88013bebfbe0), AE_NOT_EXIST
Jun 8 09:35:34 fire kernel: [ 0.283261] ACPI Error (uteval-0250): Method execution failed [\SECD.S_D1._STA] (Node ffff88013bebfbe0), AE_NOT_EXIST
Jun 8 09:35:34 fire kernel: [ 0.284496] PCI: MCFG area at e0000000 reserved in ACPI motherboard resources
Jun 8 09:35:34 fire kernel: [ 0.303247] ACPI Error: No handler for Region [SACS] (ffff88013bf6f168) [PCI_Config] (20090903/evregion-319)
Jun 8 09:35:34 fire kernel: [ 0.303380] ACPI Error: Region PCI_Config(2) has no handler (20090903/exfldio-295)
Jun 8 09:35:34 fire kernel: [ 0.303486] ACPI Error (psparse-0537): Method parse/execution failed [\PRID.P_D0._STA] (Node ffff88013bebf840), AE_NOT_EXIST
Jun 8 09:35:34 fire kernel: [ 0.303668] ACPI Error: No handler for Region [SACS] (ffff88013bf6f168) [PCI_Config] (20090903/evregion-319)
Jun 8 09:35:34 fire kernel: [ 0.303814] ACPI Error: Regi...

Claudio Melis (mebitek) wrote :

in newer kernel 2.6.35.rc4 same behaviour:

[ 0.444224] ACPI Error: No handler for Region [ERAM] (f7420be0) [EmbeddedControl] (20100428/evregion-369)
[ 0.444228] ACPI Error: Region EmbeddedControl(0x3) has no handler (20100428/exfldio-293)
[ 0.444233] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0._INI] (Node f742a738), AE_NOT_EXIST

and when I unplug AC i get :

HP WMI: Unknown response received

Csaba Lack (csabka) wrote :

HP dv6 2160eh, BIOS version F.16 (01/22/2010), Ubuntu Lucid 10.04 32 bit
 from kernel.org 2.6.34 stable working fine. ( I used Ubuntu's stock 2.6.32-23-pae config)

- Only suspend/hibernate is working not yet (display does not come back).
- Nvidia working with Ubuntu's current, but I used the manufacturer's driver
- Broadcom Wlan is not working until you patch the 2.6.33 above (downloadable from manufacturer's site)
- ACPI/CPU temperature now shows its value
- LCD light higher/lower buggy since Ubuntu 9.10

David Duffey (dduffey) wrote :

Similar error messages on my amb64, Ubuntu 10.4, Asus motherboard (with latest bios)

# dmesg | grep ACPI | grep -i error
[ 0.671811] ACPI Error (psargs-0359): [ECEN] Namespace lookup failure, AE_NOT_FOUND
[ 0.671811] ACPI Error (psparse-0537): Method parse/execution failed [\] (Node ffffffff81a0e440), AE_NOT_FOUND

# hal-device | grep system.board
  system.board.serial = 'MT7002K27400423' (string)
  system.board.product = 'M4A79XTD EVO' (string)
  system.board.version = 'Rev X.0X' (string)
  system.board.vendor = 'ASUSTeK Computer INC.' (string)

# hal-device | grep system.firmware
  system.firmware.vendor = 'American Megatrends Inc.' (string)
  system.firmware.version = '2003' (string)
  system.firmware.release_date = '04/21/2010' (string)

Claudio Melis (mebitek) wrote :

also kernel 2.6.34.2 have same issue as other ones.

Claudio Melis (mebitek) wrote :

same behaviour in kernel vanilla 2.6.35.6

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in acpi (Ubuntu):
status: New → Confirmed
martin suc (martin-suc) wrote :

any solution ?

Csaba Lack (csabka) wrote :

In Ubuntu 12.04 LTS... I could not see this issue anymore (and suspend/resume; LCD light as well not buggy with Fn+F7/F8)

Still active in 2016. I get this in Linux Mint Debian Edition 2, with kernel 3.16.0-4-amd64
But it seems a possible BIOS bug, and that the BIOS manufacturer isn't willing to do anything about it:
http://unix.stackexchange.com/questions/92366/acpi-errors-exeptions-why-they-spam-how-to-know-and-fix-it
https://bugzilla.kernel.org/show_bug.cgi?id=43229
But it seems fixed in some newer hardare:
https://bugzilla.redhat.com/show_bug.cgi?id=491588

Forgot to mention my hardware: I have a Dell Inspiron 14 with 3rd generation Intel i3.

Fabien Z (z-fabien-7) wrote :

I get the following message in the file /var/log/dmesg with Linux Mint 17.3 Cinnamon and the kernel 3.19.0-32-generic :

[ 0.155414] ACPI Error: [NSTA] Namespace lookup failure, AE_NOT_FOUND (20141107/psargs-359)
[ 0.155420] ACPI Error: Method parse/execution failed [\_SB_.PCI0.RP05._STA] (Node ffff88015a8ba078), AE_NOT_FOUND (20141107/psparse-536)

on Ubuntu 16.04.1 I'm getting the following errors on every boot.

[ 1.290468] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[ 1.290485] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT1._GTF] (Node ffff8804100c3c08), AE_NOT_FOUND (20150930/psparse-542)
[ 1.290668] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[ 1.290681] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT5._GTF] (Node ffff8804100c3de8), AE_NOT_FOUND (20150930/psparse-542)
[ 1.291428] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[ 1.291440] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT1._GTF] (Node ffff8804100c3c08), AE_NOT_FOUND (20150930/psparse-542)
[ 1.291754] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[ 1.291765] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT5._GTF] (Node ffff8804100c3de8), AE_NOT_FOUND (20150930/psparse-542)
[ 1.291870] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[ 1.291881] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT3._GTF] (Node ffff8804100c3cf8), AE_NOT_FOUND (20150930/psparse-542)
[ 1.292700] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[ 1.292711] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT3._GTF] (Node ffff8804100c3cf8), AE_NOT_FOUND (20150930/psparse-542)
[ 1.304822] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[ 1.304839] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT0._GTF] (Node ffff8804100c3b90), AE_NOT_FOUND (20150930/psparse-542)
[ 1.314822] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[ 1.314839] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT0._GTF] (Node ffff8804100c3b90), AE_NOT_FOUND (20150930/psparse-542)

Tabi G (twitchett) wrote :

Encountering the same on Ubuntu 16.04, kernel 4.6.0-040600-generic
Running on a Dell XPS 9550, bios version 1.2.19

The following errors occur in /var/log/syslog when the AC adapter is plugged in/out:

Feb 11 15:49:58 xenon kernel: [31200.587332] ACPI Error: [\_SB_.PCI0.LPCB.H_EC.CHRG] Namespace lookup failure, AE_NOT_FOUND (20160108/psargs-359)
Feb 11 15:49:58 xenon kernel: [31200.587349] ACPI Error: Method parse/execution failed [\PNOT] (Node ffff88089d0db8e8), AE_NOT_FOUND (20160108/psparse-542)
Feb 11 15:49:58 xenon kernel: [31200.587359] ACPI Error: Method parse/execution failed [\_SB.AC._PSR] (Node ffff88089d0ee6e0), AE_NOT_FOUND (20160108/psparse-542)
Feb 11 15:49:58 xenon kernel: [31200.587369] ACPI Exception: AE_NOT_FOUND, Error reading AC Adapter state (20160108/ac-128)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.