eeepc-acpi-scripts is not installable

Bug #262679 reported by RobotII on 2008-08-29
This bug affects 50 people
Affects Status Importance Assigned to Milestone
EasyPeasy Overview
Jon Ramvi
acpi (Ubuntu)
Nominated for Jaunty by Luis Silva
Nominated for Karmic by Jason M. Christos
Nominated for Lucid by Usama Akkad
Nominated for Maverick by Alessandro Ghersi
eeepc-acpi-scripts (Ubuntu)
Nominated for Jaunty by Luis Silva
Nominated for Karmic by Jason M. Christos
Nominated for Lucid by Usama Akkad
Nominated for Maverick by Alessandro Ghersi

Bug Description

Binary package hint: eeepc-acpi-scripts

eeepc-acpi-scripts depends on acpi-support-base, which is not available in intrepid. Furthermore, the scripts attempt to load the ath_pci module, which is known not to work with the eeepc. Instead it needs to be updated to use the ath5k module which is included with 2.6.27 kernel, and works fine, providing the ath_pci driver is blacklisted. Otherwise, there is no point in having the package available.

Daniel Holm (danielholm) wrote :

Confirmed and agreed.

Fabrice Coutadeur (fabricesp) wrote :

confirmed here also

Changed in eeepc-acpi-scripts:
status: New → Confirmed

Confirmed and I made some research.

Installing eeepc-acpi-scripts next to acpi-support works for the installation process (no file conflicts) but fails from usage point of view since there are some conflicts between acpi events.

It seems that debian's acpi-support package has been split in two packages (since 2007-10-12): acpi-support-base and acpi-support; where acpi-support-base contains some common acpi events not needed by all platforms, and acpi-support contains the remaining files that may conflicts with some platforms specific files, like the eeepc one.

For the wireless module, the latest upstream eeepc-acpi-scripts (1.0.7) contains a configurable key that let you define which wireless driver to use (either atH_pci or ath5k or whatever you want)

Sitsofe Wheeler (sitsofe) wrote :

Which problems does eeepc-acpi-scripts solve?

For some ACPI hotkeys, the eeepc does not emit standards codes and in that case needs specific ACPI events mapping (that for some of them overlaps with standard/common one).

Also, for some actions triggered by ACPI events, there are some specific scripts to be run, like for example the wireless card on/off toggle.

This package should add the needed acpi scripts to solve those problems.

But from what I have seen some scripts needs adaptation for Ubuntu (like the wireless one that may use the ath5k driver instead of the madwifi one).

I'm trying to get some reliable scripts/package and I will send a patch here when it's working on my 701 eeepc.

Sitsofe Wheeler (sitsofe) wrote :

Watch out - there are already changes floating around that fix things like the volume keys (see bug #232170 and the fedora bug referenced within ) in the kernel.

Alex Cornejo (acornejoc) wrote :

this package is still uninstallable in latest intrepid, hopefully this can be fixed, but meanwhile it should be removed since it is useless/confusing to have uninstallable packages listed for the user.

For me, if the kernel patch proposed in bug #232170 is applied this package should be removed at all.

 2.6.27-7-generic #1 SMP Fri Oct 24 06:42:44 UTC 2008 i686 GNU/Linux
...still not working.

Psy[H[] (vovik-wfa) wrote :

week after release... no change

Christopher (chriruud) wrote :

ubuntu-eee doesn't use these scripts for it's event-handling and relies solely on eeepc-config (and eeepc_laptop for hardare hotplug events when it's finished debuggung...)

Changed in ubuntu-eee:
status: New → Invalid
nyarnon (cabal) wrote :

Jaunty has the package available but is still does not install as it demands acpi-support-base which is not available.

This package is not necessary anymore as everything needed to handle eeepc acpi signals in the standard way is now in the linux kernel.

Just load the eeepc_laptop module and everything just works.

If the package isn't necessary, perhaps it should be removed from the repositories, then.

Troy Ready (troyready) wrote :

In Jaunty beta, the wireless toggle hotkey still has no effect. (Eee PC 901 with Ralink RT2860 card).

Thought the scripts here might help, but as previously discussed the package has an impossible dependency.

If the correct patches are applied, as described in bug 232170, everything is working. Those patches are included in kernel 2.6.29, but unfortunately jaunty will ship with kernel 2.6.28.

Ron B. (flybye882001) wrote :

with Jaunty NBR updated to 05-apr-09 I tried a forced install but immediatly got a red-halt icon telling me to run synaptic-update which then uninstalled the package.

also carries over too karmic NBR seems acpi-support-base is not in repository

Changed in eeepc-acpi-scripts (Ubuntu):
status: New → Confirmed
Darren Salt (dsalt) wrote :

I'd call you lot not having acpi-support-base a bug. That said, if you're prepared to help us make eeepc-acpi-scripts not conflict with acpi-support...

Rolf Leggewie (r0lf) wrote :

Do I understand correctly that the eepc-acpi-scripts package is not needed for a kernel > 2.6.29?

Changed in eeepc-acpi-scripts (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete

Changes for the volume and network switch have been incorporated in the linux kernel since this commit:;a=commit;h=a195dcdcff33b8ef01a23cbc489fdfcdfa28c88e

Those changes have been chipped with kernel 2.6.29 and are in Karmic.

It can still be required to manually add the eeepc-laptop kernel module but aside of that, everything should work out of the box.
(If not, it's probably a bug in this kernel driver)

Sitsofe Wheeler (sitsofe) wrote :

The eeepc kernel module should/will autoload if you are on a recognised EeePC (it does here on my 900 and I'd imagine most models older than 6 months are known).

Usama Akkad (damascene) wrote :

This bug is still with Ubuntu Lucid 10.04 Alpha.

Usama Akkad (damascene) wrote :

the normal thing for the Eee user who is missing some of the original system chipped with it's laptop is to search for Eee and there is only two or three packages with that name.

but the user find the eeepc-acpi-script broken

Confirmed in Lucid.

ftoperso (ftoperso) wrote :

same bug in lucid beta2

Landy Mann (landymann) wrote :

Same in Lucid RC on eee pc 1000

mori (mori150) wrote :

Same in Lucid RC on eee pc 1005 HA-M

Jon Ramvi (ramvi) on 2010-04-25
Changed in easypeasy-project:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Jon Ramvi (ramvi)
fioghual (fioghual) wrote :

I don't know if I'm correct, but in my case, after doing some research, it proves unnecessary to install it.
What solves everything is:

sudo gedit /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

and then:
sudo update-grub

I did what floghual said in post #35 and it doesn't work. When I restart the system, the BIOS settings are reset.

Tested on Kubuntu 10.04, Asus EeePC 1201NL.

Sitsofe Wheeler (sitsofe) wrote :

That issue (hotkeys not working on 2009+ Eeepcs like the 1005HA) is different to this one (it's hard to tell that though). That is somewhat covered by Bug #505452.

I suspect this bug report is at risk of becoming too general...

Disregard my comment #36, I confused this bug with some other.

BTW doing what fioghual said makes hotkeys work.

This bug is still present in maverick.

There is also this bug with a removal request for eeepc-acpi-scripts

If someone with an eeepc can confirm that this package eeepc-acpi-scripts is not required anymore to run Ubuntu or Kubuntu we should really considering to remove this package that confuses users.

Sorry when I said "There is also this bug with a removal request for eeepc-acpi-scripts" I mean this:

Changed in eeepc-acpi-scripts (Ubuntu):
milestone: none → ubuntu-10.10

On my eeepc 701 with Xubuntu Lucid installed, almost all the function keys (F1-sleep, F2-WiFi on-off, F3-brightness down, F4-brightness up, F7-volume mute, F8-volume down, and F9-volume up) work out of the box. I have not yet tried the key to switch between internal and external monitor.

On my eeepc 1000HA, with Ubuntu Netbook Edition maverick, the function keys described in #42 work. This package should be removed.

Sebastian Mares (smares) wrote :

On my 1005HGO (1005HAG with UMTS modem) running Xubuntu 10.10, the following keys work:

Volume up (F12), Volume down (F11), Mute (F10), Brightness up (F6), Brightness down (F5) and Sleep (F1).

The following keys do not work:

Display off (F7), Mousepad off (F3), WLAN off (F2) and the non-keyboard button for turning off the mousepad.

Since I don't have an external display to test, I cannot tell if the Switch dsplay (F8) key works. I also don't know what exactly the F4 key does. Its icon is a rectangle with rounded corners and inside there are four arrows pointing outwards to the edges - reminds me of a full-screen key or something. I also cannot test the F9 key that opens the task manager under Windows because I don't have any graphical task manager installed.

By the way, all Fn keys that don't trigger "special" actions, such as Home, End, Page up, Page down, Num lock, etc. work fine.

Sitsofe Wheeler (sitsofe) wrote :

Alessandro Ghersi:
Last year patches were integrated into the mainline kernel that sent additional hotkeys via the input layer (using the eeepc-laptop module) rather than as ACPI events for the EeePCs that were out of the time (you can see this in Bug #232170 and this was mentioned by Olivier). At that point, my EeePC 900's hotkeys for wireless toggling, brightness and volume all worked without additional scripts as the hotkey events were being sent a standardised way and GNOME was configured to respond to them out of the box. For "standard" hotkeys it is better for events to be sent directly via the input layer rather than as ACPI events (which may in turn need redirecting to input events or special dedicated scripts) as it gives a more consistent experience with less quirks.

There are some features that eeepc-acpi-scripts does (such as switching between the slow and fast modes (using SHE) depending on whether you are on battery or not) which will never be added out-of-the-box. An additional function of these scripts appears to be to work around bugs in a particular wireless driver when suspending. However, it might be by now that the original bugs in those drivers have been fixed in the kernel thus eliminating the need for the workarounds and just confusing matters on new setups.

Of course there may be new EeePC models whose hotkeys do not work out of the box. However, eeepc-acpi-scripts does not seem to provide support for hotkeys aside from wireless, brightness and volume so if keys aside from those are not working this package would not help (but if ACPI events were being sent it would help. However it sounds like laptop vendors are moving away from sending hotkeys as ACPI events and towards things like WMI).

I can see these scripts being invaluable if you are on an old kernel but many of the functions it provides are directly supported by the kernel in modern distros (since 2.6.28 I would guess). Further, this bug will continue to attract comments because if a new EeePC comes out whose hotkeys do not work a Google search will often turn up this bug report when really this bug is for the original range of EeePCs whose issues have been long fixed.

fioghual (fioghual) wrote :

Now I find myself having the problem of not being able to install the mentioned packages. I did post a workaround to get the buttons to work. Unfortunately, after the upgrade to Maverick, my workaround is not working anymore. The only buttons not working are wifi and touchpad on/off.
Just wanted to let ya know. But would be thankful of any advice.

Rolf Leggewie (r0lf) wrote :

fioghual, your issue is related but separate from this ticket. Please follow the steps outlined in and open a new ticket. Your best bet is to report the issue upstream as well.

Alex Young (alex-blackkettle) wrote :

I installed 32-bit Maverick Desktop edition on my Asus 1005P (mainly because I can't stand Unity in its current form, but that's another story...). The volume keys work, the brightness keys don't. Not only that, but I can't see where to get the eeepc-laptop module from.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers