Thinkpad sleep button stopped working

Bug #162895 reported by nopoles on 2007-11-15
2
Affects Status Importance Assigned to Milestone
acpi (Ubuntu)
Undecided
Unassigned

Bug Description

I have a Thinkpad X61 Tablet, 7767a4u, on which I originally installed 7.04. I only used 7.04 for a week before upgrading to 7.10. Since then the sleep function has worked perfectly. My last successful sleep & wake-up was 3 days ago.

Today I went to put the laptop to sleep and the button wouldn't respond. I have not changed any settings relating to ACPI or the power management. I don't know why this broke.

Also, seemingly at the same time the volume buttons have also stopped working. Since upgrading to 7.10 they didn't function, but pushing the button would bring up the volume display which didn't work. Now the volume button does not even show the display.

Pressing the sleep button does produce an ACPI event:

[Thu Nov 15 10:16:40 2007] received event "ibm/hotkey HKEY 00000080 00001004"
[Thu Nov 15 10:16:40 2007] notifying client 4941[107:114]
[Thu Nov 15 10:16:40 2007] notifying client 5331[0:0]
[Thu Nov 15 10:16:40 2007] executing action "/etc/acpi/sleepbtn.sh"
[Thu Nov 15 10:16:40 2007] BEGIN HANDLER MESSAGES
[Thu Nov 15 10:16:40 2007] END HANDLER MESSAGES
[Thu Nov 15 10:16:40 2007] action exited with status 0
[Thu Nov 15 10:16:40 2007] completed event "ibm/hotkey HKEY 00000080 00001004"

The script does not put the laptop to sleep.

Does anybody have any idea why this happened? Is three anything else you need to diagnose?

Thank you,

~Paul

nopoles (paul-2byteconsulting) wrote :

If I remove the thinkpad_acpi module, the laptop will successfully sleep, and resume. The volume buttons still produce no event in the acpi log.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers