screen brightness reset after closing lid and opening again.

Bug #772300 reported by Andreas Herrmann on 2011-04-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: acpi-support

I'm using Ubuntu Natty on an HP ProBook 5320m.
The screen brightness is reset when closing the lid and opening it again.

On maximum brightness /sys/devices/virtual/backlight/acpi_video0/brightness contains the value 24.
After closing and opening the lid it contains the value 0.

I tried to write /etc/apci/local/lid.sh.{pre,post} scripts to remember and reset the brightness.
However, there seems to be a bug in the /etc/acpi/lid.sh script that prevents lid.sh.post from being executed.
I've attached a patch, that solves this problem.

The pre and post scripts are attached, too. They are just quick hacks and probably won't work properly on other laptops.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: acpi-support 0.138
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
NonfreeKernelModules: wl
Architecture: i386
Date: Thu Apr 28 12:48:38 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: acpi-support
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in acpi-support (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers