asus brightness hotkeys

Bug #76593 reported by Nicolò Chieffo on 2006-12-20
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: acpi-support

I have valid scripts for asus hotkeys for brightness. I will attach them

Related branches

Nicolò Chieffo (yelo3) wrote :

Please upload them soon to acpi-support

Nicolò Chieffo (yelo3) on 2007-01-19
Changed in acpi-support:
status: Unconfirmed → Fix Committed
Nicolò Chieffo (yelo3) on 2007-02-22
Changed in acpi-support:
status: Fix Committed → Confirmed
Paul Sladen (sladen) wrote :

Matching on:

  event=hotkey ATKD 0000002[123456789abcdef]

is a bit too broad, can you include the output from running:

  acpi_listen

and pressing the up and down brightness keys.

Changed in acpi-support:
status: Confirmed → Needs Info

it is so broad because the event changes in relation to the brightness value.
for example if the value is 0 the event will end with "1"! if the
value is 15 instead it will end with "f"

Paul Sladen (sladen) wrote :

Ah, so in fact the hardware is keeping track of the brightness for us!

Nicolò Chieffo (yelo3) wrote :

Yes! I've tested these scripts in my asus m6ne and also in asus a8js. I think that every asus laptop generate these keycodes.

Nicolò Chieffo (yelo3) wrote :

patch, if you need it

Paul Sladen (sladen) wrote :

Okay, I think what we can do here is similar to some of the ThinkPad handling; I'll add the keys, but I'll have the script that they execute do a check whether it's on an Asus.

Could all of you with an Asus laptop that where this applies paste the output of:

  grep . /var/lib/acpi-support/*-*

so that we can figure out how to identify the common traits. Based on checking:

  /etc/init.d/hotkey-setup

it should be possible to match "ASUS*".

Paul Sladen (sladen) on 2007-03-30
Changed in acpi-support:
importance: Undecided → Wishlist
Nicolò Chieffo (yelo3) wrote :

/var/lib/acpi-support/bios-version:0208
/var/lib/acpi-support/system-manufacturer:ASUSTeK Computer Inc.
/var/lib/acpi-support/system-product-name:M6Ne
/var/lib/acpi-support/system-version:1.0

Nicolò Chieffo (yelo3) wrote :

will we have this in feisty?

lambfrier (jkl-exemail) wrote :

I originally was getting no events for the two hotkeys. I have since updated by bios and now receive the same events as described by Nicolò, i.e. ATKD 0000001* for brightness up & ATKD 0000002* for brightness down. However, I have disabled Nicolò's scripts and the screen brightness still changes (woo!).

/var/lib/acpi-support/bios-version:206
/var/lib/acpi-support/system-manufacturer:ASUSTeK Computer Inc.
/var/lib/acpi-support/system-product-name:F3JV
/var/lib/acpi-support/system-version:1.0

I originally had bios version 202.

Below are the entries received in /var/log/acpid if you're interested:
Brightness up:
[Tue Jun 19 22:26:08 2007] received event "video LCDD 00000086 00000000"
[Tue Jun 19 22:26:08 2007] notifying client 5037[107:114]
[Tue Jun 19 22:26:08 2007] notifying client 5195[0:0]
[Tue Jun 19 22:26:08 2007] completed event "video LCDD 00000086 00000000"
[Tue Jun 19 22:26:08 2007] received event "hotkey ATKD 00000015 00000001"
[Tue Jun 19 22:26:08 2007] notifying client 5037[107:114]
[Tue Jun 19 22:26:08 2007] notifying client 5195[0:0]
[Tue Jun 19 22:26:08 2007] completed event "hotkey ATKD 00000015 00000001"

Brightness down:
[Tue Jun 19 22:26:08 2007] received event "video LCDD 00000086 00000000"
[Tue Jun 19 22:26:08 2007] notifying client 5037[107:114]
[Tue Jun 19 22:26:08 2007] notifying client 5195[0:0]
[Tue Jun 19 22:26:08 2007] completed event "video LCDD 00000086 00000000"
[Tue Jun 19 22:26:08 2007] received event "hotkey ATKD 00000015 00000001"
[Tue Jun 19 22:26:08 2007] notifying client 5037[107:114]
[Tue Jun 19 22:26:08 2007] notifying client 5195[0:0]
[Tue Jun 19 22:26:08 2007] completed event "hotkey ATKD 00000015 00000001"

Let me know if you need any more info.

Nicolò Chieffo (yelo3) wrote :

to tell the truth my scripts helps gnome-network-manager to keep
synchronized with the brightness you choose

lambfrier (jkl-exemail) wrote :

Ah - I see. Fantastic: I get the gnome brightness level meter now. Thanks.

Mephisto (ferrylandzaat) wrote :

/var/lib/acpi-support/bios-version:207
/var/lib/acpi-support/system-manufacturer:ASUSTeK Computer Inc.
/var/lib/acpi-support/system-product-name:A6K
/var/lib/acpi-support/system-version:1.0

got the brightness meter in gnome to work using these files, i'd like to see it included by default in gutsy...

Nicolò Chieffo (yelo3) wrote :

I don't really know what's happening and why they are still not included

Nicolò Chieffo (yelo3) on 2007-08-16
Changed in acpi-support:
status: Incomplete → Confirmed
Matthew Garrett (mjg59) on 2007-08-31
Changed in acpi-support:
status: Confirmed → Fix Committed
Whoopie (whoopie79) wrote :

Hi,

shouldn't the acpi events files look like this?

event=hotkey ATKD 0000002[0123456789abcdef]
action=/etc/acpi/asus-brn-down.sh

event=hotkey ATKD 0000001[0123456789abcdef]
action=/etc/acpi/asus-brn-up.sh

I added the 0 to the [] so that the lowest/highest brightness is also recognized.
I have a Samsung P35 here which also uses the asus acpi module.

Rafael Sachetto (rsachetto) wrote :

My output for: grep . /var/lib/acpi-support/*-* is :

/var/lib/acpi-support/bios-version:203
/var/lib/acpi-support/system-manufacturer:ASUSTeK Computer Inc.
/var/lib/acpi-support/system-product-name:F3Sc
/var/lib/acpi-support/system-version:1.0

and the gnome brightness control doesn't work.

When I press Fn+F5/F6 the screen gets dark and I have to run the command gnome-power-manager to restore my brightness to the normal.

Nicolò Chieffo (yelo3) wrote :

the brightness problem with gnome-power-manager is caused by another
bug (of gnome-power-manager itself).
I think that, yes, the 0 can be added. It was my mistake

Nicolò Chieffo (yelo3) wrote :

reconfirming the bug since since the 0 is needed. I will attach a patch

Changed in acpi-support:
status: Fix Committed → Confirmed
Nicolò Chieffo (yelo3) wrote :
Rafael Sachetto (rsachetto) wrote :

The last update fixed the problem! Now is working fine on my asus F3Sc :)

Rafael Sachetto (rsachetto) wrote :

Shouldn't this bug be marked as fix released?

I dont't but here on my asus laptop this things are working fine.

Nicolò Chieffo (yelo3) wrote :

It is working but one keycode is not present in the list: try to
reduce the brightness to the minimum and you will see that the minimum
keycode does not produce the 0 brightness OSD

Ryan Chew (ryanchew) wrote :

I'm using an Asus A8Js and when I run acpi_listen, it registers when i hit FN+F5 to reduce the brightness but no event is registered when I hit FN+F6 to try to increase it.

Any idea on how to fix this? I've upgraded my BIOS to 213 from 210 but it still doesn't work.

fsando (stfs) wrote :

> Shouldn't this bug be marked as fix released?
I don't think this is fixed yet

I can confirm this is still a problem on gutsy (was the same on feisty)
Laptop: asus w1j:

:~$ grep . /var/lib/acpi-support/*-*
/var/lib/acpi-support/bios-version:W1JAS.212
/var/lib/acpi-support/system-manufacturer:ASUSTeK Computer Inc.
/var/lib/acpi-support/system-product-name:W1J
/var/lib/acpi-support/system-version:1.0

Pressing Fn+F5 when running acpi_listen produces 2 lines (Fn+F6 produces nothing):
~$ acpi_listen
hotkey ATKD 0000002e 00000005
video LCDD 00000087 00000000

As a work-around to get the brightness back: put the brightness applet on the panel (so you can move the brightness slider back up again):
Right click on the panel, choose 'Add to Panel', under 'System and Hardware' choose 'Brightness Applet'.

asusrookie (aceofdiamonds00) wrote :

hello everyone, im also having problems with my brightness key. It only goes down and not up. So right now i cant really see my monitor. Im trying hard to understand how you guys fixed it with a bright bar meter, but im pretty computer illiterate. I was hoping if someone can show me what to do in laymens terms please.

Im really frustrated, all help and advice will be truely appreciated. Thank you.

There hasn't been any recent activity in this bug report. Just curious if someone can comment if this is still and issue in the latest Hardy Alpha release? You can download and try the new Hardy Heron Alpha release from http://cdimage.ubuntu.com/releases/hardy/ . You should be able to then test using the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/ . Thanks.

Changed in hal:
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package acpi-support - 0.112

---------------
acpi-support (0.112) intrepid; urgency=low

  * acpi-support.docs: Add installation of README
  * control: Add laptop-mode-tools to Suggests
  * Add installation for ac.d/ and battery.d/ directories.
    (LP: #274599)
  * wireless.sh: Fix obviously wrong typo in function call name -
    toggleWirelessStates is a non-existant function
    (LP: #108897, deb #430895)
  * Fix asus brightness hotkeys so lowest/highest brightness recognized
    (LP: #76593)

 -- Bryce Harrington <email address hidden> Thu, 25 Sep 2008 17:50:26 -0700

Changed in acpi-support:
status: Incomplete → Fix Released
Binnette (binnette) wrote :

I use version 0.114 of acpi-support with Ubuntu 8.10 and this bug is still present on my Asus F3JV.

Changed in acpi-support:
status: Fix Released → Confirmed
Binnette (binnette) wrote :

Hello,

There is the same mater on my Asus F3JV. The real hot key for Screen Lock is Fn+Suppr.

== There is also a lot of bugs with all my hot-keys : ==

=== Config ===
* PC : Asus F3JV (alias Z53JV-AP030M)
* OS : Ubuntu 9.10 Karmic Koala

=== No event in xev ===
* Fn+F2 (Wifi on/off)
* Fn+F5 (Brightness down)
* Fn+F6 (Brightness up)
* Fn+F9 (Touchpad on/off)

=== Errors in log file ===
* Fn+F2
no error message

* Fn+F5
kernel: [ 2569.550813] ACPI Error (psargs-0359): [\_SB_.PCI0.P0P2.VGA_.LCDD] Namespace lookup failure, AE_NOT_FOUND
kernel: [ 2569.550831] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_._Q0E] (Node f701acf0), AE_NOT_FOUND

* Fn+F6
kernel: [ 2656.167994] ACPI Error (psargs-0359): [\_SB_.PCI0.P0P2.VGA_.LCDD] Namespace lookup failure, AE_NOT_FOUND
kernel: [ 2656.168036] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_._Q0F] (Node f701ad08), AE_NOT_FOUND

* Fn+F9
no error message

=== acpi_listen events ===
* Fn+F1 (Zzzz) : button/sleep SLPB 00000080
* Fn+F2 (wifi on/off) : nothing
* Fn+F3 (mail) : hotkey ATKD 00000050
* Fn+F4 (internet) : hotkey ATKD 00000051
* Fn+F5 (Brightness down) : nothing
* Fn+F6 (Brightness up) : nothing
* Fn+F7 (screen light off) : hotkey ATKD 00000034
* Fn+F7 (screen light on) : hotkey ATKD 00000033
* Fn+F8 (LCD/CRT) : hotkey ATKD 00000061
* Fn+F9 (touchpad on/off) : hotkey ATKD 0000006b
* Fn+F10 (mute) : hotkey ATKD 00000032
* Fn+F11 (volume down) : hotkey ATKD 00000031
* Fn+F12 (volume up) : hotkey ATKD 00000030
* Fn+espace (screen lock) : hotkey ATKD 0000005c
* Fn+← (previous) : hotkey ATKD 00000040
* Fn+→ (next) : hotkey ATKD 00000041
* Fn+↑ (stop) : hotkey ATKD 00000043
* Fn+↓ (play/pause) : hotkey ATKD 00000045

== Question ==

Do i have to create a new bug in launchpad ? Please answer me by mail. Also if you can help me, i never report a bug on launchpad.

Thanks ! ;-)

Steve Langasek (vorlon) wrote :

This output shows that the problem with your hotkeys is a kernel problem. Please file a new bug report against the kernel package, using the command 'ubuntu-bug linux' from a console.

I'm marking this bug as fixed again, since the acpi scripts this bug report was about are still present and should work correctly when the kernel is also working correctly.

Changed in acpi-support (Ubuntu):
status: Confirmed → Fix Released
Binnette (binnette) wrote :

Well, it's done I report a new bug (480999)
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/480999

Can you tell me, if my report is comprehensible and well categorized ?
Also, if I have to put more informations.

Thanks you ;-)

Chan Ju Ping (rewarp) wrote :

I have an ugly workaround for my Asus K40IJ.

Fn F5/F6 does nothing. The Brightness indicator flashes on the first push, and then seems to delay its indication long after I have pressed the keys.

My default power management brightness is set to 30%, and the laptop appears to respect this option. However, upon adding the brightness applet and attempting to adjust the brightness, the screen instantly outputs at maximum brightness. No further toggling changes anything.

However, the following solution works, albeit it only functions for individual windows, and not system wide.

In CompizConfig Settings Manager > Accessibility > Opacity, Brightness and Saturation

In the Brightness tab, I added key bindings to my scroll wheel that enabled me to change the brightness of the screen by scrolling at the right edge of the screen.

It achieves what I want, and I wonder if this may be a clue to fixing this problem.

Sasa Stamenkovic (umpirsky) wrote :

I have this issue. How can I install this update under 12.10?

Binnette (binnette) wrote :

Hi Sasa, the simpliest way to fix this bug is to flash your BIOS. I assume that you have an Asus F3J computer.
----
--Extract from https://bugs.launchpad.net/ubuntu/+source/linux/+bug/480999
== To upgrade your BIOS ==
Go on the Asus website, download the new BIOS with optionally the BIOS upgrade utility. But keep in mind, there is a little risk to damage your computer !
----

Finaly, I flash my bios with version 207. I encounter no problem and it fix this bug. I encourage you to do the same.

Chan Ju Ping (rewarp) wrote :

I don't know whether these patches are suppose to be automated, but I should report I just fixed my brightness key for my ASUS K401J running 12.04.

$ gksudo gedit /etc/default/grub

Find GRUB_CMDLINE_LINUX_DEFAULT=

Add "acpi_osi=Linux acpi_backlight=vendor" such that it read

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Save file.

$ sudo update-grub2

My brightness keys finally work correctly 2 years after I first purchased it. Couldn't be happier.

Binnette (binnette) wrote :

In my concern, i was obliged to flash the bios on my Asus F3JV. Also, I observe that using this lines in grub file improved my computer compatibility with brightness. I test this grub line on Asus F3JV and Asus G74Sx, with great success.

Chan Ju Ping (rewarp) wrote :

I should clarify too that I tried flashing my BIOS to the latest version too. It may or may not have helped with the addition to the grub configuration file.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers