[patch] [regression] Lenovo Thinkpad T61 x61: FN+F8 missing action

Bug #506442 reported by Hans-Gerd van Schelve on 2010-01-12
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Low
Unassigned

Bug Description

I tested Lucid on a Lenovo Thinkpad T61 and x61. The Function Key FN+F8 should change the mouse Trackpoint or Touchpad behaviour. In Karmic I was able to enable / disable the Touchpad for the current X session.

In Lucid nothing happens for this Key. I get an acpi event: ibm/hotkey HKEY 00000080 00001008.

I think it would be the best to open gnome-mouse-properties or a similar application for other desktop environments when a user press this key.

summary: - Lenovo Thinkpad T61 x61: FN+F8 missing action
+ [regression] Lenovo Thinkpad T61 x61: FN+F8 missing action

This is probably a bug in Ubuntu, which is a different project from Lucid, an editor. So I have marked the bug invalid for Lucid, but reassigned it to the Ubuntu team for them to take a look at.

Changed in lucid:
status: New → Invalid
affects: ubuntu → linux (Ubuntu)
tags: added: lucid
Jeremy Foshee (jeremyfoshee) wrote :

Hans,
      Could you run apport-collect -p linux 506442
so that we can get the relevant data on this issue?

Thanks in advance,

-JFo

Jeremy Foshee (jeremyfoshee) wrote :

also, could you identify for me the kernel in which this last worked? We'd like to bisect the posibility to determine the exact issue.

-JFo

Changed in linux (Ubuntu):
status: New → Incomplete
importance: Undecided → Low

JFo

i tried apport-collect -p linux 506442 and answered several questions. At the end the tool exited with an error message: "The problem cannot be reported: It is not a Ubuntu package". So I'm not able to provide the requested data at the moment.

The Kernel I used in Karmic was 2.6.31-16-generic #53 Ubuntu.

I used acpi_listen to see what happens when pressing fn + f8. The event is the same in karmic and lucid:
ibm/hotkey HKEY 00000080 00001008

The next I did is that I have compared the relevant acpi related files in /etc/acpi/ for this hotkey:
/etc/acpi/events/lenovo-touchpad
/etc/acpi/thinkpad-stretchortouchpad.sh
and /etc/acpi/asus-touchpad

All three files are the same in lucid and karmic.

I checked the scripts itself and found the following differences:
In Karmic I get the number for the correct Synaptics input device using this command line from
asus-touchpad:
xinput list 'SynPS/2 Synaptics TouchPad' | sed -n -e's/.*id=\([0-9]\+\).*/\1/p'

Instead in Lucid I only get
"unable to find device SynPS/2 Synaptics TouchPad"

In Xorg.0.log I found
...
"SynPS/2 Synaptics TouchPad" : touchpad found

Turning off the touchpad does not seem to work in Karmic reliably either
- after a few minutes of operating the mouse with the stick, the
touchpad was functional again.

Test:
Press Fn-F8 to disable touchpad
Use touchpad, it's disabled
Open a terminal, write and use the stick for mouse operation
Use touchpad, it's enabled

Expected outcome:
Touchpad stays disabled

xinput list seems to behave differently. I added a pipe grep statement to the script and it works for me now in Lucid.

Torsten Spindler (tspindler) wrote :

Here the debdiff for the patch.

summary: - [regression] Lenovo Thinkpad T61 x61: FN+F8 missing action
+ [patch] [regression] Lenovo Thinkpad T61 x61: FN+F8 missing action
Martin Pitt (pitti) wrote :

I committed the patch to acpi-support bzr (with a few formal fixes). However, bzr head currently has a lot of other changes, so I need to coordinate with Steve whether this is okay to upload.

affects: linux (Ubuntu) → acpi-support (Ubuntu)
Changed in acpi-support (Ubuntu):
status: Incomplete → In Progress
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package acpi-support - 0.133

---------------
acpi-support (0.133) lucid; urgency=low

  * Repair asus-touchpad.sh by using grep. (LP: #506442)
 -- Torsten Spindler (Canonical) <email address hidden> Thu, 04 Mar 2010 12:00:21 +0100

Changed in acpi-support (Ubuntu):
status: Fix Committed → Fix Released
Fabián Rodríguez (magicfab) wrote :

Reopening, as in the latest Lucid the trackpad is disabled by default and the f8 doesn' t enable it.

Changed in acpi-support (Ubuntu):
status: Fix Released → New
Steve Langasek (vorlon) wrote :

> the trackpad is disabled by default

That's an unrelated bug, then; please open a separate report - probably against the kernel. (Definitely not acpi-support)

Changed in acpi-support (Ubuntu):
status: New → Fix Released
Aiman Baharna (aiman) on 2010-03-29
affects: lucid → launchpad
affects: launchpad → null
Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers