[regression] Suspend [to-RAM and to-disk] is broken in 2.6.15-25.43

Bug #50031 reported by siriusnova on 2006-06-16
134
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Critical
Unassigned
Nominated for Feisty by Olek Wojnar
linux-source-2.6.15 (Ubuntu)
Undecided
Unassigned
Nominated for Feisty by Olek Wojnar

Bug Description

Regression introduced with 2.6.15-25 (worked fine with all previous kernels) - the machine will not suspend and thus will not resume.

Matthew East (mdke) wrote :

I see this on my T43 too. Please raise the severity, I'm not able to any more, but obviously introducing a bug like this with a post-release update is bad news.

Dan Loda (danloda) wrote :

I confirm this on an R32.

Daniel T Chen (crimsun) wrote :

Confirmed for 2.6.15-25.43-686 on an IBM ThinkPad X41-2527.

Matthew East (mdke) on 2006-06-16
description: updated
Marius Gedminas (mgedmin) wrote :

My T42 doesn't even go to sleep fully. The screen blanks, hard disk spins down, and the little moon LED lights up, but the fan never stops spinning, and I can press Caps Lock and see the LED light up. The moon LED remains lit up, and the screen remains blank, even if I try to wake it up by pressing Fn or opening the lid.

I can also reboot my laptop with Alt+SysRq+S, U, B while it is in this half-sleep state.

Tobias Heinemann (theine) wrote :

Regarding the above patch, the libata module is not loaded on my system.

2 comments hidden view all 123 comments
Milosz Tanski (mtanski) wrote :

Same here, on a thinkpad z61t.

i have to agree with Marius here, i thought the laptop suspended fully in my original bug report but now i can see that it doesn't even do that as i can activate the thinklight and the fan keeps running on my T30.

so i guess as Marius said, its in a 1/2 suspended state.

I also dont have the libata module loaded on my system as the T30 doesnt have sata hardware..

Not related to aforementioned libata-core.c patch.

Sean Kelley (sean-sweng) wrote :

I can confirm this on a Lenovo Thinkpad T60. It has also broken ACPI Hibernation (Suspend2Disk). I have since reverted back to linux-image-2.6.15-23-686

Sean

Sean Kelley (sean-sweng) wrote :

I will also add that ACPI Hibernation is broken going into Suspend2Disk. The Lenovo Thinkpad T60 basically locks up and never shuts down completely. Again, linux-image-2.6.15-23-686 works fine and never had a problem. I would concur with other comment above that this is a pretty nasty bug in a post release.

Sean

Dan Menssen (dan-menssen) wrote :

Ditto on my t43. Probably not related to the libata patch, as that patch affects resuming from suspend, while this bug means the affected computers won't even suspend fully.

Daniel T Chen (crimsun) wrote :

After numerous hours of reverting commits, building, compiling, installing, and attempting to suspend, I can rule out with certainty any libata, usb, and pci restoration changes as culprits.

description: updated
Jason Simpson (xiojason) wrote :

Confirmed on Thinkpad T40:
2.6.15-23-386 suspended/resumed well.
2.6.15-25-386 does not fully suspend. Moon LED lights, battery LED remains lit, Caps-lock LED still toggles in this state, machine will not wake. Hibernate also fails and power must be forced off to reboot.

siriusnova (siriusnova) wrote :

So im just curious, what's the status of this bug? Do the devs know there is a serious problem?

Thanks..

Daniel T Chen (crimsun) wrote :

Many of the devs are enroute to Paris, so I don't expect there to be additional comment until Monday at the earliest.

Simon Rönnqvist (simon-iki) wrote :

Just confirming that this affects the IBM Thinkpad R51 too, I guess someone could have guessed that. :-)

medha (hiddenface) wrote :

Same here. Thinkpad T43 does not suspend with -25 kernel.

Tobias Heinemann (theine) wrote :

Does anybody know how one can monitor the dmesg output when the machine tries to go to sleep? I can only think of something like "dmesg | tail -f", but that doesn't work.

Manuel Siggen (manuel-siggen) wrote :

Same problem here with a Thinkpad X40.

Daniel T Chen (crimsun) wrote :

Update: The nsc/irda update [0] appears to cause this issue; it can be worked around via acpi-support.

[0] http://www.kernel.org/git/?p=linux/kernel/git/bcollins/ubuntu-dapper.git;a=commit;h=c0aff2d0dcf910e440b49087cf118d3cccb10fe3

Changed in linux-source-2.6.15:
status: Confirmed → In Progress
Daniel T Chen (crimsun) on 2006-06-18
Changed in linux-source-2.6.15:
status: In Progress → Fix Committed

The attached syslog covers a boot sequence with acpi=force on an A20m. Suspend put the machine in a coma: I had to remove the power cord and battery to recover.

The attached kern.log covers a boot sequence with acpi=force on an A20m. Suspend put the machine in a coma: I had to remove the power cord and battery to recover.

Peter Whittaker (pwwnow) wrote :

Confirmed on A20m; please refer also to bug #50274, which contains syslog and kern.log for boot sequence with APM (default on this machine; logs for boot sequence with ACPI are attached above).

Tobias Heinemann (theine) wrote :

Upgrading acpi-support to 0.85 fixed this issue for me. My Thinkpad R51 now suspends fine with the most recent kernel 2.6.15-25-686.

siriusnova (siriusnova) wrote :

Upgrading to the new acpi-support fixed my suspend and hibernate problem on my Thinkpad T30, good job folks!

Daniel T Chen (crimsun) wrote :

acpi-support (0.85) dapper-updates; urgency=low

  * Don't unload nsc-ircc on suspend

 -- Matthew Garrett <email address hidden> Mon, 19 Jun 2006 10:38:09 +0100

Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
Dan Allen (dan.j.allen) wrote :

I can confirm that the update to acpi-support 0.85 also solved my problem.

IBM Thinkpad T43, ATI X300 (M300), fglrx driver

I noticed after the recent update to the kernel 2.6.15-25-686 that suspend wasn't working (and almost burnt my hand taking my laptop out of its bag), and sure enough, there was an update waiting for me when I turned it out.

Great job folks!

Installed ACPI 0.85, rebooted with ACPI=force, problem described when attaching syslog and kern.log persists: Attempt to suspend, machine "goes away", have to remove battery and unplug to be able to reboot. Will attach new logs.

Refer to recent comment: ACPI 0.85 does not fix problem on A20m.

Refer to recent comment: ACPI 0.85 does not fix problem on A20m.

Peter Whittaker (pwwnow) wrote :

Changed status because fix changes nothing on Thinkpad A20m. Please advise if this was a) correct action, b) correct status.

Changed in linux-source-2.6.15:
status: Fix Released → In Progress
Dan Loda (danloda) wrote :

Fix works for me (R32).

Peter: Did ACPI suspend work for you before the -25 kernel update? If not, I'd say you have a seperate bug. Seeing that your A20 uses APM by default, ACPI is probably broken in general for your machine. If this is the case this bug should remain marked as fixed.

Peter Whittaker (pwwnow) wrote :

I've always had mixed results with ACPI with Dapper - IIRC, ACPI worked better in Breezy. You are right, the Ubuntu default for this machine is APM (because of the age of the BIOS). However, under Windows, the A20m uses ACPI and it works like a charm.

So the A20m doesn't "use APM by default": during boot, HW detection simply indicates that this machine fails a cutoff - because of the age of the BIOS, Linux chooses APM. I've never been happy with that "logic".

If this is another bug, then, yes, let's revert status to fixed release. Is there a consensus on this?

Ram Vijapurapu (rvijapurapu) wrote :

I can confirm this bug on HP Tablet PC TC4200 with 2.6.15-25-686, this model is similar hardware as in IBM ThinkPad X41.

The latest update for acpi-support 0.85 doesn't help either.

I have also found a strange issue that the Suspend to RAM (Suspend) does not work without first doing a Suspend to Disk (Hibernate).

Adriaan Peeters (apeeters) wrote :

Another confirmation on a Dell Latitude D505.

The last action on this bug is more than a week ago, what is the status?

Florian Boucault (fboucault) wrote :

Thinkpad T43 1871-W34 and also an R52 still experience the same bug. They half-suspend (fan still on and reactive to SysRQ) most of the time (sometimes just work fine!).

drx (drx) wrote : Confirmed on X41

On my X41 it seems to work 1 out of 100 times, but i came to switching it off rather than risking a crash.

43 comments hidden view all 123 comments
txshtkckr (crf) wrote :

Since I ran into this, I have done a complete fresh install of edgy. The problem disappeared with the fresh install. That leads me to believe that this is one of:
- Differences between the resulting images of upgrade and fresh install
- Problems introduced by one or more of the ACPI settings changes
- Incompatibilities caused by specific packages, such as that which would exist with mysql if the ACPI scripts weren't deliberately working around it.

For reference, I'm on a ThinkPad T42p, and the ec_intr=0 workaround had no effect.

TuxMe posted this workaround which I have not tried, but I don't see it listed here, so just in case it works for somebody... "[...] you might try appending the following parameters to your kernel entry in /etc/boot/menu.lst:
    pci=noacpi acpi_sleep=s3_bios
[...]"

On Mon, 2006-10-30 at 22:14 +0000, katsumi wrote:
> I tried the above adjustments from Simon Rönnqvist but they didn't
> change anything apparently. This is a pretty serious bug for a laptop!
> Please help Ubuntu kernel team! :)

  Wierd, I don't have 6.10 on my R60 but on my R51 6.10 works with the
adjustment that you're talking of. I first installed Kubuntu Edgy 6.10
beta, first it worked with the adjustment, then it stopped working after
some system upgrade, then again with a later upgrade it started working
again. (I always kept my added kernel parameter in the GRUB
configuration.) Sorry I didn't register any details about the different
upgrades. :-(

Vince (v-brz) wrote :

It doesn't work for me either (while it worked in dapper).

Toshiba Portégé M200
nvidia drivers

I tried re-installing apmd and acpi,acpi-support,acpid and removing
the existing configurations carried over from the dapper installation,
but still no luck. Please Ubuntu team -- if the hiberation problem
related to the dapper -> edgy upgrade can be repaired, please tell us
how! :)

Fresh install 6.10 on Toshiba Tecra M2 with 2GB RAM. Kernel 2.6.17-10-generic
Very first suspend resulted in screen blanking, and then after 10 second of some suspending activity, a password challenge. Upon submitting password I was back online. Nothing broke but no suspend.
2..N suspends result in partial suspend with CAPsLock blinking. Can only recover from forced power down depressing power button for 10 seconds. Suspend is an essential feature for me.

Since this looks like an ACPI issue, I checked the ACPI website:

http://acpi.sourceforge.net/

Their bug tracking system asks that you /not/ report bugs there that
aren't vanilla kernels. (I suspect the Ubuntu one isn't). However, they
do provide details about what debugging feedback they need to track down
issues:

* The output from dmesg -s40000 or the serial console log
* The output from dmidecode, available in /usr/sbin/ or at
savannah.nongnu.org or at kernel.org
* The output from acpidump, available in /usr/sbin/ or in the PM Tools
at kernel.org
* Please attach the output from lspci -vv and cat /proc/interrupts

( In the HTML version on the site, they provide links to get the
non-standard utilities they reference ).

So to the other bug reporters: It would be useful if you post requested
details about your systems.

With some of that gathered, perhaps we could point the ACPI developers
to this ticket and they would be willing to help. (Since I'm also
experiencing a similar regression on new Mandriva's I assume this is
actually an upstream issue and not a Ubuntu issue. )

Thanks!

   Mark

Status update. I found some related info. and made some progress on fixing the Suspend feature on my laptop. My laptop has an ATI graphics card. When I was using Dapper, I had enabled hardware 3D acceleration by using the ATI proprietaty driver. When I upgraded to Edgy, I lost the 3D support because the configuration went back to using the open Ubuntu graphics driver. So I followed the steps under https://help.ubuntu.com/community/BinaryDriverHowto/ATI to re-enable the 3D support. There is a reference there that use of the ATI proprietary driver is necessary for Hibernate support. After successfully re-enabling 3D graphics support, the laptop now also successfully resumes after going into Suspend. A small problem still remains that neither Suspend nor Hibernate activates if the screen lid is closed when the idle timeout is reached.

Michael Trunner (trunneml) wrote :

Same here, after installing the proprietary ATI driver (fglrx) Suspend to RAM works fine.
What do you meen with "A small problem still remains that neither Suspend nor Hibernate activates if the screen lid is closed when the idle timeout is reached." ?
With the radeon dirver the system resums from Suspend but not the display. The screen is black and Strg+alt+del reboots the system.

manuel fernandez (mfg) wrote :

154ce97f81f6101ae8d02bdc49be6ed6
dell inspiron 6400, intel 945 driver

edgy 2.6.17-10-generic
(upgraded from dapper)

System resumes form suspend but not the display. Only possibility I have found is to reboot. Similar result with lid closed and reopened.

Paul Fisher (thetorpedodog) wrote :

HWDB: 47c07df951a3e5e2ecb3ff5f9f64332f

ACPI Hibernate (or Suspend-2-Disk) doesn't work especially well on my Thinkpad T60p. It sometimes wakes up, but it takes really long, and I don't necessarily get all my drivers back (including wireless networking). However, sleep (to RAM) *does* work, including the Fn+F4 combination, and it automagically comes back after opening the lid just fine.

Working fine on R60:
Download and install the latest packages from ubuntu mirror manually (ftp://ftp.belnet.be/mirrors/ubuntu.com/ubuntu/pool/main/):
1) libnotify
2) gnome-network-manager

Edit /etc/default/acpi-support:
ACPI_SLEEP_MODE=standby
SAVE_VBE_STATE=true
VBESTATE=/var/lib/acpi-support/vbestate
POST_VIDEO=true
SAVE_VIDEO_PCI_STATE=true
USE_DPMS=true
DOUBLE_CONSOLE_SWITCH=true
If you've got Radeon card: RADEON_LIGHT=true

Add "ec_intr=0" as kernel boot parameter to /boot/grub/menu.lst and resume=/dev/swap_device

Add Option "VBERestore" "yes" to device session in /etc/X11/xorg.conf

Restart your computer!!! (or restart all alsa services and Xorg)

Use gnome-power-manager's right click menu for suspend/hibernate.

Not solved:
- Wifi adapter not working after wakeup from suspend.
- ACPI sleep using ACPI button not working (suspend using gnome-power-manager only)

Jakub Kocourek

Download full text (3.2 KiB)

ThinkPad A20m running 2.6.17-10-33, all stock, no special patches or packages (FWIW, HWDB 2ad3fb6ba7d8b4d771bf8186b697277f).

At boot, all works well. S3 sleep (suspend-to-RAM) works well and reliably. S4 hibernate (suspend-to-disk) also appears to work well (I've only used it a few times, I tend to use S3 exclusively). I can S3-and-resume repeatedly, with consistent results, as described herein.

Upon resume, "almost all" things work well.

Three remaining problems are:

1) Network isn't visible right away: There is a lag (a few seconds at most) between the machine waking up and Ethernet (eth0 Ethernet) being available. By the time I unlock my screen, the network is available (and I unlock as quickly as I can).

(This appears as an immediate error in Evolution: It attempts to retrieve and cannot resolve mail server addresses. E.g., when I dismiss the Evolution error dialog and immediately send-receive, all is well.)

For me, this is a nuisance more than anything. For someone with an unattended machine waking at a set time, this could be a major stumbling block.

2) No sound. Comes back when I reboot. One exception, booting with noapic and pci=noacpi, see below.

3) Video playback is "blocky", that is, all videos play in extreme slow motion and playback is jumpy. It can take 5-10 seconds to play a single second of video.

Other points of interest:

I am booting with ACPI=force, since thinkwiki.org recommends ACPI on this machine and since the machine appears more responsive when running with ACPI rather than APM. However, all problems described above occur with both APM and ACPI, and all features appear to work equally well under both power management schemes (S3, S4, etc.).

To workaround the problems described above, I've tried booting with various combinations of

    noapic, nolapic, and pci=noacpi

and various combinations of

    ec_intr=0, lapic, and pci=routeirq

all with ACPI=force.

None of these combos make the slightest difference, behavior is as described in this report. (I haven't yet tried adding pci=noacpi to the second combo set, i.e., with ec_intr=0 and pci=routeirq, but at this point, after dozens of reboots and S3s and resumes, I don't know that I will. Any guidance as to which combo might be worthy of further testing would be much appreciated).

To make it clear, for each set of 3 options, I've booted with all 7 possibilities, and have not been able to detect any improvements. The one exception is that sound was OK upon resume when I booted with noapic and pci=noacpi; other problems remained as described in this report.

One combination made things worse: Booting with noapic nolapic pci=noacpi broke S3, I could not suspend at all. The machine tried, but came back immediately.

Finally, I should note that my /etc/default/acpi-support matches Jakub's, and this by default (it's how the package management system made it). I also tried adding the VBErestore option to /etc/X11/xorg.conf on at least one boot (with ec_intr=0 as Jakub suggested) but that made no difference (I didn't expect it to, since the display does work, it's just playback that is mildly damaged).

Rather than overload the bug report with logs (and I have man...

Read more...

Peter Whittaker wrote:
>
> 2) No sound. Comes back when I reboot. One exception, booting with
> noapic and pci=noacpi, see below.

For reference, Mandriva solves sound-after-suspend with some shell
scripts that remove and reload some sound modules, as well as possibly
restarting some programs using the sound device. This has worked
reliably for me on a T20 with 2006. The scripts they use are GPL and
available here:

http://rpm.pbone.net/index.php3/stat/4/idpl/3564487/com/suspend-scripts-1.26-1mdv2007.0.noarch.rpm.html
(See "sound" in "suspend.d").

> 3) Video playback is "blocky", that is, all videos play in extreme slow
> motion and playback is jumpy. It can take 5-10 seconds to play a single
> second of video.

All video, or just DVDs? I noticed and documented that "DMA" doesn't
seem to come back after a suspend on the ThinkPad T20, which is the
cause of DVDs not playing well after suspend/resume.
http://www.thinkwiki.org/wiki/Installing_Mandriva_Linux_on_a_ThinkPad_T20#DVD_Notes
(The DMA details are buried somewhere else on the ThinkWiki website.

Thanks for the thorough testing and report!

  Mark

--
http://mark.stosberg.com/

Michael, this is in response to your query asking for clarification on my comment about the closed lid anomaly. What I mean is as follows. Under System-Preferences-Power Management, set "When laptop lid is closed:" to "Do nothing". Set "Put computer to sleep when it is inactive for:" to say 15 minutes. Under General tab, set "Sleep type when inactive:" to Suspend or Hibernate. Continue working/playing on the laptop. Then let's say you want a break and you prefer the lid closed during the break. So close the lid. Nothing should happen immediately because that's that's the setting we selected above. Then wait for more than 15 minutes idle time. Now the computer should activate either Suspend or Hibernate depending on what you set before. But it doesn't. It just remains on. The power light remains on continuously instead of going off (Hibernate) or going into blink (Suspend). When I open the screen, its still on and everything is still there, so the laptop didn't go into Suspend or Hibernate. Now repeat the above but leave the lid open during the break. This time the computer activates Suspend or Hibernate after 15 minutes idle time. I hope I've explained better this time.

On Fri, 2006-24-11 at 14:35 +0000, Mark Stosberg wrote:
> Peter Whittaker wrote:
> >
> > 3) Video playback is "blocky", that is, all videos play in extreme slow
> > motion and playback is jumpy. It can take 5-10 seconds to play a single
> > second of video.
>
> All video, or just DVDs?

Don't know about DVDs, don't have a DVD-ROM on this beast! :->

I get the blocky playback with video files I have on-disk: Load 'em up,
watch 'em take forever to play.

Peter Whittaker (pwwnow) wrote :

On Fri, 2006-24-11 at 13:35 +0000, Peter Whittaker wrote:
> ThinkPad A20m running 2.6.17-10-33, all stock, no special patches
> or packages (FWIW, HWDB 2ad3fb6ba7d8b4d771bf8186b697277f).
>
> To workaround the problems described above, I've tried booting
> with various combinations of
>
> noapic, nolapic, and pci=noacpi
>
> and various combinations of
>
> ec_intr=0, lapic, and pci=noacpi
>
> all with ACPI=force.
>
> I haven't yet tried adding pci=noacpi to the second combo set, i.e.,
> with ec_intr=0 and pci=routeirq... ...one exception is that sound
> was OK upon resume when I booted with noapic and pci=noacpi

Update: Booting with ACPI=force and ec_intr=0, I've now tested all
combinations of pci=noacpi, pci=noacpi, and noapic (that is, I use
ACPI=force and ec_intr=0 on all boots, and booted with the 7
combinations).

Result: Six out of the seven combinations work the same as described in
my 'Edgy on A20m "almost" works' report, above. That is, S3 and S4 work,
resume works, but upon resume, video playback is blocky and the network
wakes up "late".

One combination made things worse: When I boot with "acpi=force
ec_intr=0 pci=noacpi", the system become unresponsive upon resume from
S3 sleep. Load average spiked at 15, was never lower than 7, and typing
was painful. I had to BRS (big red switch). Good thing Evolution has a
recovery feature, otherwise I would have lost most of this report....

To summarize:

 ThinkPad A20m "likes" 2.6.17-10-386 and "likes" ACPI:
 "Almost everything" works, there are couple of things
 that don't work after a resume, as described above,
 and the system seems more responsive under ACPI than
 under APM, at least until the first S3. Upon resume,
 system responsiveness seems about the same with both
 ACPI and APM.

One last misc note: On the A20m, booting with lapic disables APIC. The
BIOS disables lapic (hadn't realized this until yesterday), and when I
boot with lapic , there is a message in the kernel log that Linux was
unable to initialize APIC.

As for suspend to RAM on my Toshiba Portege M200 with Edgy: it will wake up
immediately after suspending (or more appropriately, I dont think it actually
suspends, as the suspend LED doesnt ever go on).

If I manually *unload* all usb modules except usbcore with modprobe before
suspending, suspend works just fine (like in Dapper, even faster possibly)!

But obviously after resuming I won't have USB mouse and keyboard anymore.

I'm looking into automating this process with powersaved.

Ok, on my laptop (Toshiba Portege M200) the following works:

Install powersaved if you don't have it already.

Edit /etc/powersave/powersaved,

Change

UNLOAD_MODULES_BEFORE_SUSPEND2RAM=""

(possibly it's commented out, if so, uncomment it or has some modules in there
already, if so, you might want to keep them)

to something along the lines of (you might need other modules depending on
your hardware configuration)

UNLOAD_MODULES_BEFORE_SUSPEND2RAM="usb_storage usblp usbmouse ehci_hcd sbp2
ohci_hcd uhci_hcd stir4200 ohci1394 ipw2200 rt2500 prism54 ath_pci r8169
lt_modem Intel536 Intel537 ndiswrapper"

needs all be on ONE LINE.

Then try running powersave --suspend-to-ram.

For me, that did the job.

If you're a KDE user, also get kpowersave, quit guidance-powersave and start
knetworkmanager instead. I don't use gnome so I can't tell what
infrastructure you need.

If you run into issues with your display, you might want to install suspend
(especially the s2ram app) from suspend.sf.net. Just shout if you need help
with that.

Mark Stosberg (markstos) wrote :

I have now opened a bug in Mandriva's bug tracker for what appears might be the same kind of regression happening there, as confirmed on a ThinkPad T20:

http://qa.mandriva.com/show_bug.cgi?id=27721

In the Mandriva case, a successful work around was to continue to use the older kernel (2.6.12) with the newer distribution.

  Mark

Simon Rönnqvist (simon-iki) wrote :

I wrote in https://launchpad.net/distros/ubuntu/+source/linux-source-2.6.17/+bug/50031/comments/61:
>You'll need to repeat this after each kernel update.

This is not necessarily true. Lately I don't think I've had to re-add the boot parameter upon upgrading the kernel. Let's say, if you experience problems after upgrading the kernel then check that you've still got your ec_intr=0 boot parameter in place. :-)

Does anyone know if this bug is still present in the 2.6.20 kernel which is shipping with Feisty?

On Saturday 31 March 2007 19:27:16 Olek wrote:
> Does anyone know if this bug is still present in the 2.6.20 kernel which
> is shipping with Feisty?

On my Toshiba Portege M200suspend to ram and disk works though I had to fiddle
with USB module unloading.

Olek Wojnar (olekw) wrote :

> On my Toshiba Portege M200suspend to ram and disk works
> though I had to fiddle with USB module unloading.

Do you remember what you did to make it work? Is it something that could be forwarded to the Kernel Team to either make a patch or at least include in documentation?

Jos Dehaes (jos-dehaes) wrote :

I also had to use the ec_intr=0 kernel option, and add the following in acpi-support:

MODULES="ehci_hcd uhci_hcd usbcore"

With these settings suspend/resume (RAM) works almost always.

Jim Hodapp (jhodapp) wrote :

I used to be able to suspend and hibernate with 6.10, but after installing the nVidia drivers, I can no longer resume from suspend or hibernate...the screen comes back up, I can move the mouse cursor around, but it remains black and I can't do anything but hard reboot the machine. This is on a Dell Latitude D820 laptop.

Hi, as workaround, did you try switching to a text console (ctrl-alt-F1)
and back?

It seems to me that at least with my ThinkPad R60 and the newest Ubuntu Edgy kernel (2.6.17-11) I'm better off not using the ec_intr=0 parameter at all. Cause suspend to RAM seems to work with the default kernel parameters, but stops working with ec_intr=0. (I just figured this out, so I'll let you know if suspend to RAM starts turning evil on me again. But for now it seems to work repeatedly...)

Hello Olek, the bug is no longer present on my HP nc8000 laptop.
Regards.

On 31/03/07, Gabriel Ambuehl <email address hidden> wrote:
> On Saturday 31 March 2007 19:27:16 Olek wrote:
> > Does anyone know if this bug is still present in the 2.6.20 kernel which
> > is shipping with Feisty?
>
> On my Toshiba Portege M200suspend to ram and disk works though I had to
> fiddle
> with USB module unloading.
>
> --
> [regression] Suspend [to-RAM and to-disk] is broken in 2.6.15-25.43
> https://launchpad.net/bugs/50031
>

I did try that after you suggested it, it didn't help any. The screen still
just stays black with the cursor able to move but nothing else happening and
GNOME not coming back. If it helps you any, I am using the nVidia restricted
drivers with Beryl and Emerald.

On 4/12/07, Ulrich Lukas <email address hidden> wrote:
>
> Hi, as workaround, did you try switching to a text console (ctrl-alt-F1)
> and back?
>
> --
> [regression] Suspend [to-RAM and to-disk] is broken in 2.6.15-25.43
> https://bugs.launchpad.net/bugs/50031
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Jim Hodapp

KingKookie (kingkookie) wrote :

Suspend-to-RAM successfully suspends the computer, but it fails to resume. I am left with a blank screen (no hard drive activity) and no backlight.

Suspend-to-disk fails more than it succeeds. Though, I've had luck with it on occasion.
HP Laptop (Pavilion ze4547wm 1GB RAM, PCMCIA Netgear, 100gb HD, DVD +/- R Dual-layer)

Kernel - 2.6.20-16 - generic

Sitsofe Wheeler (sitsofe) wrote :

For new people posting to this bug can you please make sure that you can reproduce the problem:
o When beryl/compiz/desktop-effects are turned off (NVIDIA binary users using these things may want to see Bug #96240 )
o Without _any_ binary drivers running.

Unless you are using the same (or extremely similar) hardware and BIOSes as the people originally reporting this bug your suspend issue is almost certainly different and you are probably better off looking for a bug that better matches your system or filing a new bug and carefully detailing your system.

Saitoh (awbailey001) wrote :

My suspend worked in 7.04 when in metacity, however right after the upgrade to 7.10 my suspend will not function even while in metacity. I am running a Dell XPS M1210.

Just wanted to report that with Kubuntu 7.10 my Thinkpad X41 still does not suspend to disk.

Mircea Deaconu (mirceade) wrote :

Hello! First of all let me say I am truly regretting doing this. This is a spam message sent to all critical bug message lists. It's purpose: making this (https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/59695) bug critical too. This is a long standing bug and has a very serious impact on laptop type of hardware. It's priority is set to "wishlist" and I just cannot take this anymore. I DO NOT CARE if my account gets suspended. I am doing what's right for all my friends using Ubuntu on their laptops.

abloylas (abloylas) wrote :

This bug has been "In progress" forever. Is it really in progress?

drx (drx) wrote :

The latest kernel sometimes kills the network connectivity after hibernating or sleeping on a TP X41 and a TP T41. ifconfig does not show any network interfaces apart from loop. A reboot fixes it. I don't like it. :)

Dara Adib (daradib) wrote :

Bug 92461 may be a duplicate of this bug, or at least related to this bug. Can anyone confirm? Thanks.

Dara Adib (daradib) wrote :

Additionally, please check Bug 68199, which is currently marked as a duplicate of Bug 63418. It may be related or a duplicate of this bug. Thank you.

Hi All,

I'm afraind that this report may have gotten a bit off track and therefore difficult for the development teams to debug. The symptom of this particular bug, failure to Suspend, is specific to the hardware used. So while many of you may have the same symptom they really should be different bugs. Also, the original bug reporter has commented that issue was resolved for them (https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.17/+bug/50031/comments/28). I'm therefore going to close this report.

If you are still experiencing issues, it would be helpful if you could test with a Hardy Alpha build, http://www.ubuntu.com/testing/ , and open a separate bug report for the hardware you are using. Please open the new bug report against the "linux" package. The bug report should contain the information requested at http://wiki.ubuntu.com/KernelTeamBugPolicies . Additionally, it would be great if you made the titles of a new bug report contain information about your system. I apologize for any inconvenience this might cause but appreciate your cooperation.

Changed in linux-source-2.6.17:
status: In Progress → Fix Released
Changed in linux-source-2.6.15:
status: New → Won't Fix
Jim Hodapp (jhodapp) wrote : hi

hi
Dear friend:
   We are an electronic products wholesale .Our products are of high
quality and low price. If you want to do business , we can offer you
the most reasonable discount to make you get more profits. We are
expecting for your business.
                    Please visit our website: http://www.sjmyz.com
E-mail : <email address hidden>
MSN: <email address hidden>
Looking forward to your contact and long cooperation with us!
  Our mainly products such the phones, PSP, display TV, notebook,
video, computers, Mp4, GPS, xbox 360, digital cameras and so on.
  Welcome to visit our website!

Displaying first 40 and last 40 comments. View all 123 comments or add a comment.