resume (after suspend) broken on ASUS W3V - Jaunty

Bug #367822 reported by Peter Harvey on 2009-04-27
10
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Undecided
Unassigned

Bug Description

ASUS W3V laptop - suspend/resume regression

Resuming from suspend results in completely blank screen, keyboard useless. Have to shutdown using power button. Happens every time.

Hibernate/resume works reliably.

Have been using Ubuntu since 7.04, and suspend/resume has worked until now.

Upgraded to the finished release of Jaunty but was given warning that some system degradation might be expected since "3rd party graphics drivers were not compatible with this release" (or some such). Google Earth is now broken, which is consistent with that warning, but I am not qualified to know whether this resume issue is related to the graphics driver. I have not experience the faster boot times that are reported (they seem as before under 8.10), though probably not related to this problem.

'System Information' seems to give too far much info. Please let me know what is needed.

Without a fix for this, I'll have to go back to 8.10

P

UPDATE May 6th: Have dug around for likely causes, and suspect a graphics driver problem. At the failed 'resume' various combinations of keys (function keys, control, etc) cause the screen to light up, go purple, grainy etc, but not create any discernible image.

The Graphics card is reported as:
"VGA compatible controller : ATI Technologies Inc M24 1P [Radeon Mobility X600]"
which is on the ATI 'older and no-longer-supported' cards list (i.e. condemned). The proprietary driver, which works just fine with 8.10, is NOT compatible with 9.04 (hence the warning before upgrading). I have reverted to 8.10 until an Open Source driver is sorted out which works with 9.04.

tags: added: resume suspend
teju (teju) on 2009-04-29
affects: ubuntu → acpi-support (Ubuntu)
A Kao (ak-ubuntu) wrote :

This also happens on the Thinkpad X40. Fresh install of 9.04. The same problem:A suspend to RAM appears to work fine, but it cannot resume. The status lights change, as if the machine was awake. The wireless indicator even blinks. But the screen is completely blank, it doesn't even look like the backlight is on.

I then did an update on the installed packages. Same behavior.

Doing a hibernation works, and resume from hibernation works fine too.

Peter Harvey (pdqharvey) on 2009-05-06
description: updated
A Kao (ak-ubuntu) wrote :

I think the graphics driver may be part of the problem, but it seems odd that I am not able to shutdown the computer with ctrl-alt-del. If the keyboard was still working as you hint at, shouldn't I able to do that?

Also, my Intel X40 has a intel graphics chip (Intel Extreme Graphics 2 ).

Peter Harvey (pdqharvey) wrote :

That is interesting, and will no doubt be useful to the people who might be able to provide a solution to this. It would seem that either we have different problems, or, IF we have the same problem, it is not directly caused by the new ATI graphics driver. (Incidentally, I am not certain that suspend/resume was reliable in versions earlier than 8.10, as I moved to Ubuntu full-time only last summer, and cannot be sure that my earlier experiments tested the suspend feature.)

I am at the limits of my expertise, now. Anyone with any ideas out there?

John Pye (jdpipe) wrote :

Suspend/Resume is broken on the DELL XPS M1530 as well, as of the 9.04 Jaunty upgrade. My system was previously suspending correctly.

hronir (hronir) wrote :

Any (good) news?

Peter Harvey (pdqharvey) wrote :

Sorry, no news of any kind from me - I have decided to stick with 8.10 for the life of this laptop and to remember to check that any future machines I buy do not have ATI graphics.

Mike (bild85) wrote :

Also experiencing this on fully-updated Karmic on a 5 yr old Intel D865GBF board with an NVIDIA NV44A [GeForce 6200] AGP card using driver version '185'. I tried removing the proprietary driver, but suspend still fails the same way.
I can't get any response using the keyboard, so I don't know how to get log files. Maybe I could remove the drive after power-off and mount it in another system to see if there is anything logged? If so, which file(s) would be helpful?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers