asus touchpad toggling doesn't work (synclient)

Bug #314376 reported by lumitoro on 2009-01-06
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: acpi-support

I have:
   ASUSTeK Computer Inc.
   F3Sc
   1.0
Some of my laptop hotkeys don't work. Used "acpi_listen" command to see if they where generating an event and they are. For fn+F9 (toggle touchpad) key "acpi_listen" returns:
   "hotkey ATKD 0000006b 00000001",
checked /etc/acpi/events/asus-touchpad:
   "event=hotkey (ATKD|HOTK) 0000006b
    action=/etc/acpi/asus-touchpad.sh"
it's ok and tested the asus-touchpad.sh script that it's working fine.
I'm not sure this is acpi-support bug since the event is properly raised.

Steve Langasek (vorlon) on 2009-10-06
summary: - [Intrepid] acpi hotkey not working
+ asus touchpad toggling doesn't work (synclient)
Steve Langasek (vorlon) wrote :

Thank you for taking the time to reporth this bug and help to improve Ubuntu.

It's reasonable that the asus-touchpad.sh script would work when run manually, but not when run by acpi-support; this script needs to connect to the X server to toggle the touchpad, and it doesn't do that, relying instead on an older insecure method of configuring the touchpad. This needs to be corrected, perhaps using the getXconsole function from power-funcs.

Changed in acpi-support (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Steve Langasek (vorlon) wrote :

BTW, the hotkey you cite, 6b, is the hotkey from the asus-a6u-touchpad event script rather than asus-touchpad. It was reported that this script was now handled via the asus-laptop module, and therefore the event script has been removed entirely in karmic. Can you confirm whether the touchpad toggle works correctly for you in the Ubuntu 9.10 beta, without this script?

Steve Langasek (vorlon) wrote :

acpi-support 0.128 in karmic now has a fixed asus-touchpad.sh script that correctly implements toggling of the synaptics touchpad. Does this fix the problem for you? It's easy to make sure we have this working for karmic, but we need your input because we don't have access to the hardware in question.

Changed in acpi-support (Ubuntu):
status: Triaged → Incomplete
Binnette (binnette) wrote :

Hello,

There is the same mater on my Asus F3JV.

== There is also a lot of bugs with all my hot-keys : ==

=== Config ===
* PC : Asus F3JV (alias Z53JV-AP030M)
* OS : Ubuntu 9.10 Karmic Koala

=== No event in xev ===
* Fn+F2 (Wifi on/off)
* Fn+F5 (Brightness down)
* Fn+F6 (Brightness up)
* Fn+F9 (Touchpad on/off)

=== Errors in log file ===
* Fn+F2
no error message

* Fn+F5
kernel: [ 2569.550813] ACPI Error (psargs-0359): [\_SB_.PCI0.P0P2.VGA_.LCDD] Namespace lookup failure, AE_NOT_FOUND
kernel: [ 2569.550831] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_._Q0E] (Node f701acf0), AE_NOT_FOUND

* Fn+F6
kernel: [ 2656.167994] ACPI Error (psargs-0359): [\_SB_.PCI0.P0P2.VGA_.LCDD] Namespace lookup failure, AE_NOT_FOUND
kernel: [ 2656.168036] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_._Q0F] (Node f701ad08), AE_NOT_FOUND

* Fn+F9
no error message

=== acpi_listen events ===
* Fn+F1 (Zzzz) : button/sleep SLPB 00000080
* Fn+F2 (wifi on/off) : nothing
* Fn+F3 (mail) : hotkey ATKD 00000050
* Fn+F4 (internet) : hotkey ATKD 00000051
* Fn+F5 (Brightness down) : nothing
* Fn+F6 (Brightness up) : nothing
* Fn+F7 (screen light off) : hotkey ATKD 00000034
* Fn+F7 (screen light on) : hotkey ATKD 00000033
* Fn+F8 (LCD/CRT) : hotkey ATKD 00000061
* Fn+F9 (touchpad on/off) : hotkey ATKD 0000006b
* Fn+F10 (mute) : hotkey ATKD 00000032
* Fn+F11 (volume down) : hotkey ATKD 00000031
* Fn+F12 (volume up) : hotkey ATKD 00000030
* Fn+espace (screen lock) : hotkey ATKD 0000005c
* Fn+← (previous) : hotkey ATKD 00000040
* Fn+→ (next) : hotkey ATKD 00000041
* Fn+↑ (stop) : hotkey ATKD 00000043
* Fn+↓ (play/pause) : hotkey ATKD 00000045

== Question ==

Do i have to create a new bug in launchpad ? Please answer me by mail. Also if you can help me, i never report a bug on launchpad.

Thanks ! ;-)

If you are going to comment on bugs, please also subscribe to them so that
you will see the replies.

On Tue, Nov 10, 2009 at 11:17:39PM -0000, Albin Manoël wrote:
> There is the same mater on my Asus F3JV.

> * Fn+F9 (touchpad on/off) : hotkey ATKD 0000006b

Which version of Ubuntu are you using?

Thanks,
--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Binnette (binnette) wrote :

Thanks for advice about "subscribe".

I use Ubuntu 9.10 Karmic Koala (It was noticed on my first message).

My version of :
* synclient is 1.1.2
* acpi_listen is acpid-1.0.6

Just tell me, if you want more information :-)

Steve Langasek (vorlon) wrote :

Ok, this will be fixed in lucid.

Unfortunately there's a risk of regression on other models we haven't tested whenever changing hotkey handling, so I don't expect this to be applied to Ubuntu 9.10. For your own usage, you can edit /etc/acpi/events/asus-touchpad to list the correct hotkey for your system.

Changed in acpi-support (Ubuntu):
status: Incomplete → Fix Committed
lumitoro (lumitoro) wrote :

Hello, thanks for the replies.
The thing is, my touchpad hotkey works fine all i had to do was turn on the shmconfig using the hal .fdi files(this is the not very secure method, the other method just doesn't work). I tried to configure all my hotkeys through hal .fdi files but no luck there, and it really doesn't matter because all the keys raise the acpi event as expected. I think this is an asus-laptop issue, some events simply aren't processed by the driver (but i'm not sure).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package acpi-support - 0.130

---------------
acpi-support (0.130) lucid; urgency=low

  * Readd support for ATKD 0000006b to events/asus-touchpad. LP: #314376.
  * Drop dependency on laptop-mode-tools: this is not enabled by default, and
    dropping it lets us remove much of the laptop-mode-tools delta wrt Debian.
 -- Steve Langasek <email address hidden> Wed, 18 Nov 2009 17:22:26 -0600

Changed in acpi-support (Ubuntu):
status: Fix Committed → Fix Released
e X t 7 3 (ext73) wrote :

the same bug is in Ubuntu 10.10 - Asus 1201n ... under my kernel -> http://forum.ubuntu.pl/showpost.php?p=768402&postcount=826 under Ubuntu 10.04 most of FN keys amd special keys (touchpad on/off) working great, but under 10.10 ... enabling/disabling touchpad not working ...

fdanis (frederic-danis) wrote :

This bug also affects me on an Asus eee-pc 1005HA.
FN key and special key have no effect.

After some investigations, I found that the acpi script getXuser (in /usr/share/acpi-support/power-funcs) presuppose that the .Xauthority file can be found under the user home folder.
But, with latest version of GDM, the Xauthority data are located in /var/run/gdm/auth-for-<user>-<variable>/database.
This file can be retrieved by parsing the X command line (see attached patch).

Hope this helps

Eli Karasik (ekarasik) wrote :

works perfectly! thanks

Tom Swartz (tom-swartz07) wrote :

fdanis: I have an Asus eee-pc 1005HAB, and I have experienced the same problems.

I have found that editing /etc/default/grub with SU permissions and adding the line

"acpi_osi=Linux" to GRUB_CMDLINE_LINUX_DEFAULT so that it will look like
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

save and sudo update-grub
and all of the function keys, including the hardware touchpad toggle button (above the esc key) work.

fdanis (frederic-danis) wrote :

Hello Tom,

I already add the acpi_osi=Linux with Ubuntu 10.04 and all functions key works fine.

But, since I upgrade to 10.10, the touchpad function keys (hardware touchpad toggle button and Fn-F3) stops to work. Stopping acpid and running it with debug option allows me to find that the acpi info is received correctly by acpid and it launch the right script (asus-touchpad which indirectly uses getXuser function), but this one generates errors.

Adolfo R. Brandes (arbrandes) wrote :

Hi fdanis,

I can confirm you patch works on my Asus U43JC with Ubuntu 10.10. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers