madwifi wireles not working after software suspend

Bug #23092 reported by Toivo Pedaste on 2005-10-03
This bug report is a duplicate of:  Bug #275692: ath_pci must be reloaded after resume. Edit Remove
16
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Medium
Unassigned

Bug Description

I have an IBM R50 laptop with an atheros wireless
      Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)

When the loptop returns from software suspend the wireless is not working.
Unloading and reloading the madwifi modules fixes the problem.

Version
    linux-restricted-modules-2.6.12-9-686
    linux-image-2.6.12-9-686

Matthew Garrett (mjg59) wrote :

Please edit /etc/acpi/hibernate.sh and add

set -x

just under the #!/bin/bash line. From a terminal in X, run
/etc/acpi/hibernate.sh and attach the output.

Toivo Pedaste (toivo-ucs) wrote :

/etc/acpi/hibernate.sh
+ . /etc/default/acpi-support
++ ACPI_HIBERNATE=true
++ ACPI_SLEEP_MODE=mem
++ MODULES=
++ SAVE_VBE_STATE=true
++ VBESTATE=/var/lib/acpi-support/vbestate
++ POST_VIDEO=true
++ USE_DPMS=true
++ HIBERNATE_MODE=shutdown
++ LOCK_SCREEN=true
++ STOP_SERVICES='mysql '
+ . /usr/share/acpi-support/power-funcs
++
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin:/usr/local/kde-src/qt-copy/bin:/usr/local/kde/bin:/sbin:/usr/sbin:/usr/local/bin:/etc:/usr/etc:/home/toivo/scripts:/usr/local/etc:/usr/games/bin:/usr/games:.:/usr/bin/X11
++ POWERSTATE=/var/lib/acpi-support/powerstate
++ LAPTOP_MODE=/usr/sbin/laptop-mode
++ HDPARM='/sbin/hdparm -q'
++ LIDSTATE=/var/lib/acpi-support/lidstate
+ getXuser
++ who
++ grep -m1 ' :0'
++ awk '{print $1}'
+ user=toivo
+ export XAUTHORITY=/home/toivo/.Xauthority
+ XAUTHORITY=/home/toivo/.Xauthority
+ export DISPLAY=:0
+ DISPLAY=:0
+ '[' xtrue '!=' xtrue ']'
+ unset POST_VIDEO
+ . /etc/acpi/prepare.sh
++ touch /var/lock/acpid
+++ /sbin/ifconfig
+++ awk '/^[^ ]+/ {print $1}'
++ INTERFACES='ath0
lo'
++ for x in '$INTERFACES'
++ ifdown ath0
++ ifconfig ath0 down
++ for x in '$INTERFACES'
++ ifdown lo
++ ifconfig lo down
++ for x in '/sys/class/net/*'
++ '[' -e /sys/class/net/ath0/driver ']'
++ for x in '/sys/class/net/*'
++ '[' -e /sys/class/net/eth0/driver ']'
++ for x in '/sys/class/net/*'
++ '[' -e /sys/class/net/lo/driver ']'
++ for x in '/sys/class/net/*'
++ '[' -e /sys/class/net/sit0/driver ']'
++ for x in '/sys/class/usb_host/*'
++ '[' -e /sys/class/usb_host/usb1/driver ']'
++ for x in '/sys/class/usb_host/*'
++ '[' -e /sys/class/usb_host/usb2/driver ']'
++ for x in '/sys/class/usb_host/*'
++ '[' -e /sys/class/usb_host/usb3/driver ']'
++ for x in '/sys/class/usb_host/*'
++ '[' -e /sys/class/usb_host/usb4/driver ']'
++ cardctl eject
+++ fgconsole
++ CONSOLE=7
++ chvt 12
++ for x in '$STOP_SERVICES'
++ invoke-rc.d --quiet mysql stop
++ '[' xtrue = xtrue ']'
++ vbetool dpms off
++ /usr/local/sbin/radeontool power off
+ '[' xtrue = xtrue ']'
+ . /usr/share/acpi-support/screenblank
++ su toivo -c '(xscreensaver-command -throttle && xscreensaver-command
-lock)'
xscreensaver-command: no screensaver is running on display :0.0
++ xset dpms force off
/usr/share/acpi-support/screenblank: line 4: xset: command not found
+ echo -n shutdown
+ echo -n disk
+ . /etc/acpi/resume.sh
++ /usr/local/sbin/radeontool power on
++ '[' x = xtrue ']'
++ '[' xtrue = xtrue ']'
++ vbetool vbestate restore
/etc/acpi/resume.sh: line 12: /var/lib/acpi-support/vbestate: No such file
or directory
++ cardctl insert
++ ifrename
Warning: Interface name is `eth0' at line 2, can't be mapped reliably.
++ ifup -a
++ hwclock --hctosys
++ '[' xtrue = xtrue ']'
++ vbetool dpms on
++ chvt 7
++ '[' x = xtrue ']'
++ su toivo -c '(xscreensaver-command -deactivate)'
xscreensaver-command: no screensaver is running on display :0.0
++ for x in '$STOP_SERVICES'
++ invoke-rc.d --quiet mysql start
++ rmmod button
++ modprobe button
++ sleep 1
++ rm /var/lock/acpid

Matthew Garrett (mjg59) wrote :

What version of acpi-support do you have installed?

Toivo Pedaste (toivo-ucs) wrote :

I've upgraded to 0.45 but it still happens

Justin Sunseri (jmsunseri) wrote :

I also experience this issue with my laptop using the ipw3945. not every time though.

stefab (bluefuture) wrote :

I have also have this issue on three pc with:
- ipw3945
- ndiswrapper
- acx100.
This bug is still active in 07-10-2006 Edgy snapshot.

Paul Sladen (sladen) wrote :

Justin/stefab: This bug is only about 'madwifi'. If you have another type of wireless chipset, can you please open a new bug report for your issue.

Eric Drechsel (ericdrex) wrote :

same on 2 older Dell desktops running Feisty, both with Atheros cards ( one is b/g, the other is "super g") using madwifi.

After hibernate, the card appears to connect to networks, but no traffic gets through.

Tsukasa (tsukasa1105) wrote :

I get this problem as well using the latest subversion of madiwifi on my 15" Macbook Pro. This is using the latest Hardy Heron beta.

A fix would be greatly appreciated...

Tsukasa (tsukasa1105) wrote :

Might want to look into what happens calling modprobe -r from a script. I tried to do a

gksudo modprobe -r ath_pci
wait 5
gksudo modprobe ath_pci

script and it seemed modprobe -r never even got called.

Tsukasa (tsukasa1105) wrote :

sleep* 5

Chorca (chorca) wrote :

I'm having this issue in Intrepid Alpha 5 with an Atheros chipset Netgear Cardbus card. Pulling and reinserting the card on resume allows the card to operate properly. Seems the module needs to be reloaded after a suspend.

I also have this problem with suspend to RAM. I have to rmmod ath_pci, modprobe it, then ifconfig ath0 up. Otherwise after I resume if I iwlist ath0 scan it will still show the network I was last connected to, even though it's not available at my new location.

I've tried dropping a script in /etc/acpi/resume.d to have this done automatically but it doesn't seem to get run.

Dan McGuirk (incandenza) wrote :

I have the same problem, but I was able to work around it by creating a file called /etc/pm/config.d/madwifi-wix (filename doesn't matter), with the following contents:

SUSPEND_MODULES="$SUSPEND_MODULES ath_pci"

This makes pm-utils unload and reload the module on suspend/resume.

I am on Intrepid, by the way.

Mike O'Connell (wundbread) wrote :

Dan McGuirk fix works for me on my 5212 (Intrepid).

Thanks Dan!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.