Ubuntu

Ubuntu loses keyboard after suspend

Reported by Richard on 2008-05-03
12
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Undecided
Unassigned

Bug Description

I've just installed ubuntu 8.0.4 and very nice it is but when I came out of Suspend the keyboard was not functioning preventing entering password. I tried just rebooting but the Unlock screen kept returning. Only way out of this was forcing quit from the laptop hard reset key. Fortunately restarting was then normal.
the laptop is Dell XPS M1210. Everything else including wifi seems ok.

Please request any further specs if nec,

Richard Laing

Joe Healy (joehealy) wrote :

Also happens on my dell xps m1210. Suspend worked fine under previous ubuntu version 7.10.

Sometimes the mouse (motion, not clicks) works after suspend sometimes it doesn't

Joe Healy (joehealy) wrote :

I followed the instructions at: https://wiki.ubuntu.com/DebuggingKernelSuspend

The first few times a did it, it worked. The last time, I left it suspended for longer and it failed to resume properly.
When it resumed, the mouse was missing, and the keyboard did not work. However when I pressed the power button, the screen faded and the logoff/poweroff menu came up into the center of the screen.

I could not select any of the options on this so I powered off then collected the dmesg output upon restart. The relevant lines (I think...):
[ 11.974229] registered taskstats version 1
[ 11.974396] Magic number: 0:716:241
[ 11.974400] hash matches /build/buildd/linux-2.6.24/drivers/base/power/main.c:97
[ 11.974422] hash matches device ttyse
[ 11.974503] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 11.974506] EDD information not available.

I have attached the dmesg output.
Earlier hash matches from succesful resumes were for ttypb and ttys8. Not sure what these devices are.

Busby (mobusby) wrote :

I can confirm this behavior, also on a Dell XPS m1210. Sometimes the keyboard/mouse works on resume, sometimes it does not.

Joe Healy (joehealy) wrote :

Interestingly, hibernate seems to work fine. Under 7.10, it would not recover from hibernation.

Joe Healy (joehealy) wrote :

The latest kernel 2.6.24-17-generic, seems to have improved the situation, the last two suspends seem to have worked. It does beep loudly when resuming now.

Guilhem Lavaux (guilhem-lavaux) wrote :

I have also a Dell XPS M1210. With 2.6.24-19.34-generic, it seems to suspend/resume most of the time. But sometimes it still resumes without a functioning keyboard and mouse. The power button seems to work though and I can do administration remotely using network and ssh. I have also heard this weird beep. But there is nothing systematic in it.

Guilhem Lavaux (guilhem-lavaux) wrote :

FYI, I initiated a suspend from network using "/etc/acpi/sleep.sh force" and once resumed, the computer had a working keyboard.

Joe Healy (joehealy) wrote :

Good idea, I'll try that next time.

Busby (mobusby) wrote :

I have not had a lockup for some time now. I do occasionally still get the system beep.

Thomas Hotz (thotz) wrote :

Your Ubuntu version is EOL on the desktop. Can you please retry this with a newer and supported Ubuntu version? Thank you!

Changed in acpi-support (Ubuntu):
status: New → Incomplete
summary: - hardy heron loses keyboard after suspend
+ Ubuntu loses keyboard after suspend
Launchpad Janitor (janitor) wrote :

[Expired for acpi-support (Ubuntu) because there has been no activity for 60 days.]

Changed in acpi-support (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments