suspend.d and resume.d shouldn't be shipped

Bug #223879 reported by Mario Limonciello on 2008-04-28
80
This bug affects 8 people
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by Mario Limonciello
Nominated for Jaunty by Jeffrey Baker

Bug Description

Binary package hint: acpi-support

The current released versions of acpi-support and pm-utils confuse end users because both appear to be able to do suspending and resuming.

As I was informed, the acpi-support suspend code isn't used at all since it's all handled by the pm-utils backend instead. This old acpi-support code should then not be shipped.

$ apt-cache policy acpi-support pm-utils
acpi-support:
  Installed: 0.109
  Candidate: 0.109
  Version table:
 *** 0.109 0
        500 http://us.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status
pm-utils:
  Installed: 0.99.2-3ubuntu9
  Candidate: 0.99.2-3ubuntu9
  Version table:
 *** 0.99.2-3ubuntu9 0
        500 http://us.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

Changed in acpi-support:
status: New → Confirmed
Jeffrey Baker (jwbaker) wrote :

This is still a problem in Intrepid.

Luke Schlather (luke2760) wrote :

It's an actual problem in intrepid, since the acpi scripts are broken, so really need to go away., or just get symlinked to their counterparts The symlink might be preferable in a lot of ways, since it would give people a clear pointer to where to look if something goes wrong.

Steve Langasek (vorlon) wrote :

These directories are no longer included in karmic; marking as resolved.

Changed in acpi-support (Ubuntu):
status: Confirmed → Fix Released
maxigas (maxigas) wrote :

I have a fully up-to-date Karmic (installed from Karmic CD (amd64) and did upgrade) and I have "these directories": at least I have /etc/acpi/suspend.d/ and I just tried to put some scripts there, were confused by this bug, asked Google, found this bug, surprised that it's fixed. :) I have the following files under /etc/acpi/

ls -R1

.:
asus-brn-down.sh
asus-brn-up.sh
asus-touchpad.sh
asus-wireless-2.sh
asus-wireless.sh
batterybtn.sh
ejectbtn.sh
events
hibernate.sh
ibm-wireless.sh
lid.sh
lockbtn.sh
mailbtn.sh
mediabtn.sh
mutebtn.sh
nextbtn.sh
playbtn.sh
powerbtn.sh
power.sh
prevbtn.sh
resume.d
rotatescreen.sh
screenblank.sh
sleepbtn.sh
sleep.sh
start.d
stopbtn.sh
suspend.d
thinkpad-stretchortouchpad.sh
tosh-wireless.sh
videobtn.sh
voldownbtn.sh
volupbtn.sh
webbtn.sh

./events:
ac
asus-brightness-down
asus-brightness-up
asus-eee-volume-down
asus-eee-volume-mute
asus-eee-volume-up
asus-f8sv-touchpad
asus-media-eject
asus-rotate
asus-touchpad
asus-video
asus-wireless-2
asus-wireless-off
asus-wireless-on
battery
ibm-wireless
lenovo-touchpad
lidbtn
panasonic-lockbtn
powerbtn
sleepbtn
sony-mute
sony-sleep
sony-volume-down
sony-volume-up
thinkpad-cmos
tosh-battery
tosh-hibernate
tosh-ibutton
tosh-lock
tosh-mail
tosh-media
tosh-next
tosh-play
tosh-prev
tosh-stop
tosh-wireless
tosh-www
videobtn

./resume.d:
91-tpfand-start.sh
99-maxigas-rotate-background.sh

./start.d:
60-asus-wireless-led.sh

./suspend.d:
09-tpfand-stop.sh

Steve Langasek (vorlon) wrote :

If you had files in those directories at the time of upgrading to karmic, they aren't going to be automatically removed for you; but the acpi-support package definitely no longer ships them.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers