Ubuntu

[Hardy] Acpi button actions don't seem to be handled by pm-utils yet

Reported by c_t on 2008-04-14
4
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Undecided
Unassigned
pm-utils (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: acpi-support

I am using Kubuntu Hardy Beta with the kde-guidance-powermanager applet for handling suspend/resume/powersaving. It seems that this applet is using the new pm-utils which I can configure in /etc/pm/config.d/ . Actually in my case I have to blacklist one module to get things working.

So now suspending using the kde-guidance-powermanager applet works perfectly however when I press the Fn+ESC-Key kombo, which triggers the SLEEPBTN this event still seems to be handled by the old scripts that are in /etc/acpi . I also have acpid installed and running.

How is all that stuff meant to work? Shouldn't pm-utils take care of *everything*, including the button-events? Do I even need acpid? What is it good for? Aren't the acpi-button events processed by hal anyways?

I didn't find any resource where this is clearly described. I would highly appreciate any help on understanding this. Thanks!

$ apt-cache policy pm-utils acpi-support kde-guidance-powermanager acpid hal
pm-utils:
  Installiert:0.99.2-3ubuntu9
  Mögliche Pakete:0.99.2-3ubuntu9
  Versions-Tabelle:
 *** 0.99.2-3ubuntu9 0
        500 http://de.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status
acpi-support:
  Installiert:0.108
  Mögliche Pakete:0.108
  Versions-Tabelle:
 *** 0.108 0
        500 http://de.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status
kde-guidance-powermanager:
  Installiert:0.8.0svn20080103-0ubuntu14
  Mögliche Pakete:0.8.0svn20080103-0ubuntu14
  Versions-Tabelle:
 *** 0.8.0svn20080103-0ubuntu14 0
        500 http://de.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status
acpid:
  Installiert:1.0.4-5ubuntu8
  Mögliche Pakete:1.0.4-5ubuntu8
  Versions-Tabelle:
 *** 1.0.4-5ubuntu8 0
        500 http://de.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status
hal:
  Installiert:0.5.11~rc2-1ubuntu6
  Mögliche Pakete:0.5.11~rc2-1ubuntu6
  Versions-Tabelle:
 *** 0.5.11~rc2-1ubuntu6 0
        500 http://de.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

Thomas Hotz (thotz) wrote :

Is this still an issue for you? Which Ubuntu version do you use? Thank you for telling us!

Changed in acpi-support (Ubuntu):
status: New → Incomplete
Changed in pm-utils (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for acpi-support (Ubuntu) because there has been no activity for 60 days.]

Changed in acpi-support (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for pm-utils (Ubuntu) because there has been no activity for 60 days.]

Changed in pm-utils (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers