[Hardy] acpi-support 106 & 107 breaks wireless on Asus U1F

Bug #204378 reported by Linus Harling
20
Affects Status Importance Assigned to Milestone
acpi-support (Debian)
Fix Released
Unknown
acpi-support (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: acpi-support

acpi-support 106 & 107 kills the wireless switch on Asus U1F, I managed to get it working by manually calling setLEDAsusWireless 1 as root. Modifying /etc/acpi/asus-wireless-2.sh to look like:

#!/bin/sh

. /usr/share/acpi-support/state-funcs

ON_VALUE="e"
OFF_VALUE="f"

CHARACTER_POSITION="8"

HOTKEY_VALUE=`echo "$3"| cut -b "$CHARACTER_POSITION"`

if ( isAnyWirelessPoweredOn && [ "$HOTKEY_VALUE" = "$OFF_VALUE" ] ) ; then
 toggleAllWirelessStates && setLEDAsusWireless 1
else ( ! isAnyWirelessPoweredOn && [ "$HOTKEY_VALUE" = "$ON_VALUE" ] ) ; then
 toggleAllWirelessStates && setLEDAsusWireless 0
fi

does NOT help. The previous version (105) worked perfectly.

I don't recall how to catch the keycodes, if someone would remind me I'd be happy to help out.

Regards / Linus Harling

Revision history for this message
Linus Harling (linus-ussarna) wrote :

Oops, when I said wireless switch i meant Fn+F2, the physical kill-switch still works (although it doesn't turn on the wireless as Fn+F2 is stopping it, or whatever).

Revision history for this message
Daniel Hahler (blueyed) wrote :

Thanks for reporting this bug, I'll look into it.

Changed in acpi-support:
assignee: nobody → blueyed
importance: Undecided → High
status: New → In Progress
Revision history for this message
Daniel Hahler (blueyed) wrote :

Jerone, any idea?

Daniel Hahler (blueyed)
Changed in acpi-support:
assignee: blueyed → nobody
status: In Progress → Triaged
Revision history for this message
Jerone Young (jerone) wrote :

using program "acpi_listen" .. you can catch acpi events. Don't know much about the asus issue here. Mine was with thinkpad and it used ibm-wireless.sh. I'll take a look and see if I can add something useful to the bug though.

Revision history for this message
Nicolò Chieffo (yelo3) wrote :

If your problem disappears commenting the line

test -w /sys/devices/platform/asus-laptop/wlan && echo -n "$action" > /sys/devices/platform/asus-laptop/wlan

in the file /usr/share/acpi-support/state-funcs

then this bug is a duplicate of https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/180598

Revision history for this message
Linus Harling (linus-ussarna) wrote :

Nicolo: Hm, yes commenting that line from state-funcs works, but stops the LED going on/off and additionally kills bluetooth permanently (until reboot that is). I'll try with your patch from the other bug to see if it helps.

Any ideas as to what happened in 106 that caused this?

Revision history for this message
Nicolò Chieffo (yelo3) wrote : Re: [Bug 204378] Re: [Hardy] acpi-support 106 & 107 breaks wireless on Asus U1F

This is very strange, especially with bluetooth, that line only
manages the wifi led, and in some cases the wifi switch... try that
patch soon, and tell us the result

Revision history for this message
Linus Harling (linus-ussarna) wrote :

Nicolò Chieffo skrev:
> This is very strange, especially with bluetooth, that line only
> manages the wifi led, and in some cases the wifi switch... try that
> patch soon, and tell us the result
>
I've applied the patch, with varying result. I have a couple of ideas as
to what might be causing it, I have to be off for a while now, but will
continue testing this afternoon.

Revision history for this message
Nicolò Chieffo (yelo3) wrote :

I've seen that your laptop is using asus-wireless-2.sh. This file is wrong in my opinion. I will try to apply some changes to it, and then I will upload a patch here.

Revision history for this message
Nicolò Chieffo (yelo3) wrote :

you can try this. It must be applied to a clean /etc/acpi/asus-wireless-2.sh

Revision history for this message
Linus Harling (linus-ussarna) wrote : Re: [Bug 204378] Re: [Hardy] acpi-support 106 & 107 breaks wireless on Asus U1F

Nicolò Chieffo skrev:
> I've seen that your laptop is using asus-wireless-2.sh. This file is
> wrong in my opinion. I will try to apply some changes to it, and then I
> will upload a patch here.
>
Actually I think it uses asus-wireless, I was wrong in my first report.
The keycode is 5d and 7e (probably for the bluetooth) when turning off
(first keypress), and 5d and 7d when turning on (second keypress).

Revision history for this message
Nicolò Chieffo (yelo3) wrote : Re: [Bug 204378] Re: [Hardy] acpi-support 106 & 107 breaks wireless on Asus U1F

check it which file is invoked:
sudo tail -f /var/log/acpid

and then press the hotkey.

Revision history for this message
Linus Harling (linus-ussarna) wrote :

Checked, it uses both.

Here's two keypresses of Fn+F2:
hotkey ATKD 0000005d 00000021
hotkey ATKD 0000007d 0000000b
hotkey ATKD 0000005d 00000022
hotkey ATKD 0000007e 0000001f

I think I've found the problem though; you can't control the wireless card via /sys/class/net/wlan0_rename/device/rf_kill as state-funcs is trying, at least not on the u1f. Disabling or enabling via /sys/devices/platform/asus-laptop/wlan and /sys/devices/platform/asus-laptop/bluetooth works like a charm though.

I'm going to start writing a small u1f script to see what can be done.

Revision history for this message
Linus Harling (linus-ussarna) wrote :

OK, I've made some scripts for the U1F now, it's ugly as batshit, but works. TODO is to make it exclusive to the U1F as I don't want to kill some other models. Also it would probably be a good idea to make asus-wireless-2 exclusive to the models it's written for ( the U6E???? )

Revision history for this message
Linus Harling (linus-ussarna) wrote :

And the script

Revision history for this message
Linus Harling (linus-ussarna) wrote :

Forgot to mention that I'm using Nicolò's patch from bug https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/180598

To test my scripts I've commented out events/asus-wireless and events/asus-wireless-2 to stop them interfering.

Revision history for this message
Bernhard Bock (bernhard-bock) wrote :

This problem also occurs on the Asus R1F.

Revision history for this message
Daniel Hahler (blueyed) wrote : fixed in 0.108?

Is it fixed with acpi-support 0.108?
Steve has addressed bug 180598 there, which seems to be related.

Revision history for this message
Linus Harling (linus-ussarna) wrote :

Nope, it's partially resovled in 180598, the wireless card gets turned on and off with 108 installed (kind of), but there remains three issues:

- The LED doesn't show the status, it's always lit
- Bluetooth is turned off on the first press of Fn+F2, but is not turned on by the second
- The wireless comes right back on again, it doesn't stay off.

Here's my guess as to why:
The U1F triggers the following keycodes on Fn+F2:
First press:
hotkey ATKD 0000005d 00000021
hotkey ATKD 0000007d 0000000b
Second press:
hotkey ATKD 0000005d 00000022
hotkey ATKD 0000007e 0000001f

5d triggers the asus-wireless.sh script
7e triggers the asus-wireless-2.sh script

As long as bluetooth is OFF Fn+F2 always triggers 7e, while forcing it on (by using the physical kill-switch or the sys interface) causes the next keypress to trigger a 7d.

As the keypress starts both scripts you get a nice little conflict of interests. The interesting thing is that commenting out the events for asus-wireless-2 gives you this little cycle (with everything on to begin with):

First Press:
Bluetooth LED goes off, WLAN LED still on. Bluetooth turns off, so does WLAN.

Second Press:
Bluetooth LED still off, WLAN LED turns off, BT & WLAN still OFF

Third Press:
Both LEDs turn on, BT & WLAN turns on

One problem is that toggleAllWirelessStates() in state-funcs tries to control the wireless by using rf_state, which _doesn't work_ on the U1F at least. setLEDAsusWireless() in state-funcs on the other hand uses /sys/devices/platform/asus-laptop/wlan, which _can_ be used to turn the WLAN on and off.

Revision history for this message
Nicolò Chieffo (yelo3) wrote : Re: [Bug 204378] Re: [Hardy] acpi-support 106 & 107 breaks wireless on Asus U1F

Does this bug still occur, after the release of acpi-support 0.108? I
don't think so...

I'm interested in what happens if you use, instead of the laptop
hotkey, the script from acpi-support:

sudo /etc/acpi/asus-wireless.sh

tell me if this script has the correct behavior.
As regards bluetooth on/off, this is correct, as the bluetooth power
switch is hardware based. we can't do anything about this.

Revision history for this message
Linus Harling (linus-ussarna) wrote :

Nicolò Chieffo skrev:
> Does this bug still occur, after the release of acpi-support 0.108? I
> don't think so...
>
> I'm interested in what happens if you use, instead of the laptop
> hotkey, the script from acpi-support:
>
> sudo /etc/acpi/asus-wireless.sh
>
> tell me if this script has the correct behavior.
> As regards bluetooth on/off, this is correct, as the bluetooth power
> switch is hardware based. we can't do anything about this.
>

No, the behaviour from asus-wireless.sh is incorrect. On the U1F the LED
should NOT be controlled separately from the WLAN, starting the WLAN
turns the LED on, stopping it turns it off.

If you take a look at the script i posted a while earlier
asus-u1f-wireless.sh there is an example of how you can do it on the U1F
(inluding starting/stopping bluetooth).

Revision history for this message
Silvio (winky) wrote :

gentleman,

I am testing on Ubuntu Hardy64 version full upgraded. the acpi.support is 0.108
The asus I am testing is a Pro57sn (alias M51Sn)
I can confirm that after 0.108 there no more need to remark out the line 'test -w /sys/devices/platform/asus-laptop/........'made by Nicolò on /usr/share/acpi-support/state-funcs
.
Infact after 0.108 the wifi light perfectly works with that line present and operative.

But on keyboard Functionkey+F2 button is not properly working.
out of my tests I can say that the first keypress (Fn+F2) it disable the wole wireless system and the light goes off.
Pressing again as second time the fn+2f2 the same will happen with blutooth.
on the third keypress the wifi light will turn again but system will freeze for about 30 seconds (mouse is frozen too)
After this 30/40 secs the system will become again alive, and on the menubar the wifi icon will appear as working. but if I ask it to search for signals it will not find any wireless signal. (so no reconnection is possible)
I've also noted that restarting the system, it will not shut down properly as at the last operations it will display a broken gray windows and will hung there as dead 4ever.
To shut it down I had to force it pressing power button for >4sec.

Please accept my apologises for my terrible english

regards
ciao

Revision history for this message
Nicolò Chieffo (yelo3) wrote :

So the hotkey fires 2 acpi events... the first is for wifi, and the
second for bluetooth (not sure).
At the third keypress, the events are the same as the second keypress,
since bluetooth does no more come back on, but this is not our
problem. you should file another bug.

Linus, can you please tell me which wifi chip have you got? and what
happens if you do
echo 1 | sudo tee /sys/class/net/wlan0_rename/device/rf_kill
does it print an error? or simply it does not change the file content?
which is the file content when the wifi is off?

BTW: 7e does not fire asus-wireless-2.sh, as tou can see in
/etc/acpi/events/asus-wireless-2 maybe you should reinstall
acpi-support
sudo apt-get --purge --reinstall install acpi-support

Now let's try these things.

Silvio, open another bug please! you can send me the link after, but
I'm not sure I can fix it. It might be a kernel problem

Revision history for this message
Silvio (winky) wrote :

ty so much Nicolò for your kind and fast interest on the matter.
below I link the bug.
https://bugs.launchpad.net/ubuntu/+bug/205110

rgds

Revision history for this message
Linus Harling (linus-ussarna) wrote :

Nicolò Chieffo skrev:
> So the hotkey fires 2 acpi events... the first is for wifi, and the
> second for bluetooth (not sure).
> At the third keypress, the events are the same as the second keypress,
> since bluetooth does no more come back on, but this is not our
> problem. you should file another bug.
>
> Linus, can you please tell me which wifi chip have you got?

01:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG
Network Connection (rev 02)

> and what happens if you do
> echo 1 | sudo tee /sys/class/net/wlan0_rename/device/rf_kill

root@ior:~# cat /sys/class/net/wlan0_rename/device/rf_kill
0
root@ior:~# echo 1 > /sys/class/net/wlan0_rename/device/rf_kill
root@ior:~# echo 2 > /sys/class/net/wlan0_rename/device/rf_kill
root@ior:~# cat /sys/class/net/wlan0_rename/device/rf_kill
0
root@ior:~#

> does it print an error? or simply it does not change the file content?
> which is the file content when the wifi is off?
root@ior:~# cat /sys/class/net/wlan0_rename/device/rf_kill
3
root@ior:~# echo 0 > /sys/class/net/wlan0_rename/device/rf_kill
root@ior:~# cat /sys/class/net/wlan0_rename/device/rf_kill
2

>
> BTW: 7e does not fire asus-wireless-2.sh, as tou can see in
> /etc/acpi/events/asus-wireless-2 maybe you should reinstall
> acpi-support
> sudo apt-get --purge --reinstall install acpi-support
Wasn't quite that simple, had to:
apt-get purge acpi-support and then apt-get install ubuntu-desktop.

After reinstall the behaviour changed, now WLAN won't come back on
unless I use setLEDAsusWireless 1 again. But BT does, on the third try,
and doesn't go off again until I enable WLAN again manually.
>
> Now let's try these things.
>
> Silvio, open another bug please! you can send me the link after, but
> I'm not sure I can fix it. It might be a kernel problem
>

Revision history for this message
Linus Harling (linus-ussarna) wrote :

More fun:

After fiddling around for a while with device/rf_kill and asus-laptop/wlan ksoftirqd hangs with 100% CPU usage :-)

Revision history for this message
Nicolò Chieffo (yelo3) wrote :

That's right.
Could you tell me if asus-wireless-2.sh is still called? if not we
should be near to the solution

Revision history for this message
Linus Harling (linus-ussarna) wrote :

Nicolò Chieffo skrev:
> That's right.
> Could you tell me if asus-wireless-2.sh is still called? if not we
> should be near to the solution
>

It's not called by Fn+F2, but it's called by the hardware kill-switch
(which uses 5f and 7d)

Revision history for this message
Nicolò Chieffo (yelo3) wrote :

:(
If you remove asus-wireless-2.sh does it work for you?

Revision history for this message
Steve Langasek (vorlon) wrote :

> One problem is that toggleAllWirelessStates() in state-funcs tries to control the wireless by using rf_state, which
> _doesn't work_ on the U1F at least. setLEDAsusWireless() in state-funcs on the other hand uses
> /sys/devices/platform/asus-laptop/wlan, which _can_ be used to turn the WLAN on and off.

So the rf_kill interface *exists* for asus wireless, but doesn't correctly perform its sole function?

Shouldn't this be treated as a bug in the kernel driver, and fixed there, before trying to pile on further workarounds in the asus-specific scripts? I expect this would be fixed in a later kernel version anyway, possibly breaking any workarounds that are implemented now.

Revision history for this message
Linus Harling (linus-ussarna) wrote :

I agree Steve, and so does some other people :-) found these now (didn't know about rf_kill before I ran into these problems):

http://groups.google.se/group/linux.kernel/browse_thread/thread/3dbe888c7f54a1cd
http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1606

Thank you all for the help, Nicolò and Steve; I'm hugely impressed by your responsiveness and willingness to assist.

Revision history for this message
Nicolò Chieffo (yelo3) wrote :

Wait: the rfkill works as expected:
0 is no kill
1 is software kill
2 is hardware kill
3 is hardware + software kill

you cannot disable hardware kill using an software

Revision history for this message
Linus Harling (linus-ussarna) wrote :

Nicolò Chieffo skrev:
> Wait: the rfkill works as expected:
> 0 is no kill
> 1 is software kill
> 2 is hardware kill
> 3 is hardware + software kill
>
> you cannot disable hardware kill using an software
>
OK, but why is it set to 3 or 2 by Fn+F2 (it still has to be the kernel
right?)? Shouldn't keyboard switches be controlled by software?

The hardware kill-switch, a "real" switch on the side I can understand
setting it to 3 or 2, but not Fn+F2.

Revision history for this message
Nicolò Chieffo (yelo3) wrote :

fn+f2 is a hardware switch, since in yur laptop it disables and
enables the kill without any script. you can try if I'm wrong

Revision history for this message
Daniel Hahler (blueyed) wrote :

Please check if this has regressed because of the fix for bug 105929.
This added the two files /etc/acpi/events/asus-wireless-2 and /etc/asus-wireless-2.sh. Please move them away to test this.

I don't see why asus-wireless-2.sh should get used, because it matches "0000005[ef]" and your laptop triggers "5d", "7d" and "7e" only (according to the comment above). That may be irrelevant/a misunderstanding.

I put my money on the following patch, which was introduced to fix bug 189889. Please check, if removing this line fixes it for you:
diff -Nru /tmp/IaTr27BRHx/acpi-support-0.105/lib/state-funcs /tmp/0bsAeQkJkJ/acpi-support-0.107/lib/state-funcs
--- acpi-support-0.105/lib/state-funcs 2007-03-26 02:31:01.000000000 +0200
+++ acpi-support-0.107/lib/state-funcs 2008-03-16 11:59:05.000000000 +0100
@@ -70,4 +70,5 @@
 {
     action=`test "$1" -ne 0 && echo 1 || echo 0`
     test -w /proc/acpi/asus/wled && echo -n "$action" > /proc/acpi/asus/wled
+ test -w /sys/devices/platform/asus-laptop/wlan && echo -n "$action" > /sys/devices/platform/asus-laptop/wlan
 }

Revision history for this message
Daniel Hahler (blueyed) wrote :

I've linked a related Debian bug report, which may provide more info.
I've attached my acpi-support branch, which at least provides a better/cleaner fix for bug 189889, merged from Debian and other fixes. You can either checkout the bzr branch [1], view the changes and/or build the package yourself or test the package from my PPA [2].
Maybe it helps already.

[1] https://code.edge.launchpad.net/~blueyed/acpi-support/cherry-pick
[2] https://edge.launchpad.net/~blueyed/+archive/+index?field.name_filter=acpi-support (0.109~blueyedppa14 or later)

Changed in acpi-support:
status: Unknown → New
Changed in acpi-support:
status: New → Fix Committed
Changed in acpi-support:
status: Fix Committed → Fix Released
Revision history for this message
Nikolaus Filus (nfilus) wrote :

... almost a year later ...
I have a Samsung P35 wich is also handled by asus-laptop and since I upgraded to Intrepid, I can't toggle my wireless anymore, which I need sometimes when association with an AP doesn't work.

On my Samsung I can switch the WLAN off by pressing the WLAN key, but switching on doesn't work anymore.

Problem are cases where rf_kill=3 which is not handled in the scripts and so does fail here. On the Samsung you can switch independently hardware (wlan key with LED) and software switch (rf_kill).

I attached a diff to /usr/share/acpi-support/state-funcs which solved the case for me with acpi-support 0.114-0intrepid2 and kernel 2.6.27-11-generic.

Revision history for this message
Nikolaus Filus (nfilus) wrote :

Sorry, but my last patch doesn't work in all cases, because in the asus-wireless.sh
acpi event handler the wrong logic is used. For full support one needs 2 additional changes:

- toggleAllWirelessStates has to return switching state
- asus-wireless.sh must check against toggleAllWirelessStates and NOT agains isAnyWirelessOn

The new patch superseeds the old one.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package acpi-support - 0.132

---------------
acpi-support (0.132) lucid; urgency=low

  * lib/state-funcs, start.d/60-asus-wireless-led.sh, asus-wireless.sh:
    eliminate setLEDAsusWireless altogether; this needs to be handled
    directly by the kernel when the kill switch is toggled, not in a racy
    and inconsistently-applied manner by acpi-support; and in at least some
    cases we know this already *does* happen because of reports that
    /sys/devices/platform/asus-laptop/wlan, used for toggling "the LED" with
    the current kernel module, is actually an interface for toggling *the
    antenna* that happens to also toggle the LED. Likewise, we should not
    be responsible for bringing up the antenna at boot, so get rid of the
    file in the start.d directory. LP: #293943, #204378, #334368.
  * Now that the last script is gone from start.d, kill off the directory
    and the init script handling too.
  * Remove the asus-wireless-2 event handler, which is completely redundant
    with the pre-existing asus-wireless-{off,on} handlers. LP: #207871.

  [ Erik Andrén ]
  * Add support for ATKD 00000037 to events/asus-touchpad.
    This makes the disable touchpad buttons (!) on the EeePc 1005HA work as
    intended. LP: #502720.
 -- Steve Langasek <email address hidden> Mon, 04 Jan 2010 15:52:56 -0800

Changed in acpi-support (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
smile2andy (mailbox4andre) wrote :

Hello.
acpi-support (0.132) lucid doesn`t fix problem.
I`ve got asus u1f laptop and this bug still occurs.
When i press Fn+f2 - WiFi and Bt stops but WiFi LED keep glowing.
Then Fn+F2 only starts\stops WiFi - Bt is always off, WiFi LED keep glowing.

Revision history for this message
Steve Langasek (vorlon) wrote :

If the light isn't being toggled with the antenna, this is a kernel bug. Please file a separate bug report against the linux package.

The failure to bring bluetooth back up is interesting. What is the output of 'ls -l /sys/class/net' on your system? What is the output of 'acpi_listen' when you press Fn+F2?

Revision history for this message
smile2andy (mailbox4andre) wrote :

Thank you for answer.
i`m newbie in Linux, this is my 2nd attempt to install it on my laptop instead of Windows.
I`m really impressed that thing called community support really works.

> What is the output of 'ls -l /sys/class/net' on your system?
root@asus-u1:/home/smile2andy# ls -l /sys/class/net
total 0
lrwxrwxrwx 1 root root 0 2010-01-24 16:02 eth0 -> ../../devices/pci0000:00/0000:00:1e.0/0000:05:04.0/net/eth0
lrwxrwxrwx 1 root root 0 2010-01-24 21:02 lo -> ../../devices/virtual/net/lo
lrwxrwxrwx 1 root root 0 2010-01-24 16:03 pan0 -> ../../devices/virtual/net/pan0
lrwxrwxrwx 1 root root 0 2010-01-24 16:03 wlan0 -> ../../devices/pci0000:00/0000:00:1c.0/0000:01:00.0/net/wlan0
lrwxrwxrwx 1 root root 0 2010-01-24 16:03 wmaster0 -> ../../devices/pci0000:00/0000:00:1c.0/0000:01:00.0/net/wmaster0
root@asus-u1:/home/smile2andy#

> What is the output of 'acpi_listen' when you press Fn+F2?
root@asus-u1:/home/smile2andy# acpi_listen
hotkey ATKD 0000005d 00000000
hotkey ATKD 0000007e 00000000

sorry for my english.

Revision history for this message
smile2andy (mailbox4andre) wrote :

by the way,
there is a switch at the right side of my laptop
when i move it in "off" position - wifi & bt stops, LEDs are off
acpi_listen say
hotkey ATKD 0000005f 00000004
hotkey ATKD 0000007e 00000006

when i move it back in "on" position - Bt starts working, WiFi is off - LEDs show it correctly.
acpi_listen say
hotkey ATKD 0000005d 00000006
hotkey ATKD 0000007d 00000004

after that i can no longer run WiFi, untill restart.

Changed in acpi-support (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Steve Langasek (vorlon) wrote :

Hmm, it looks like you might have a different BIOS revision than the original bug submitter, since you have different acpi events for the same button.

Can you try installing the attached file as /etc/acpi/events/asus-wireless-on on your system? (Save to your desktop, then run 'sudo cp ~/Desktop/asus-wireless-on /etc/acpi/events/asus-wireless-on' from a terminal)

Revision history for this message
smile2andy (mailbox4andre) wrote :

it changes nothing.
the only way i managed to get my wifi come back - was to use script from Linus Harling (wrote on 2008-03-21) asus-u1f-wireless.sh (610 bytes, text/x-sh)
But it works strange: WiFi and Bt LEDs works together, but WiFi starts only first time after acpid restart.

Revision history for this message
smile2andy (mailbox4andre) wrote :

oh, and using that script cause kernel oops sometimes.

Revision history for this message
smile2andy (mailbox4andre) wrote :

Hello Steve
i`ve almost made my radio switch work with acpi-support .129
but i wonder if there any command to emulate acpi event (for e.g.hotkey ATKD 0000005d)?

Revision history for this message
Steve Langasek (vorlon) wrote :

I'm going to close this bug again. The original issue was fixed many years ago, and the acpi-support package is being deprecated. If you find that there are still issues with the wireless hotkey handling in 12.04 beta 1, please open a new bug report so that we can look at it separately without getting tangled in historical issues.

Changed in acpi-support (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.