Ubuntu

Please sponsor cherrypicked fixes for acpi-support into Hardy

Reported by Daniel Hahler on 2008-02-20
14
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Medium
Steve Langasek
Nominated for Hardy by Jerone Young

Bug Description

I've cherrypicked a lot of available fixes regarding acpi-support, which were all "laying around" already in Launchpad.
Please sponsor the upload for Hardy.

  * ibm-wireless.sh: Add better behavior & fix for bluetooth with Lenovo
    Thinkpads; patch from Jerone Young (LP: #183682)
  * lib/state-funcs: make wireless led work with asus-laptop (the new module);
    patch from Nicolò Chieffo (LP: #189889)
  * lib/state-funcs: change isAnyWirelessPoweredOn() according to the
    removal of the old status kernel interface; patch from Nicolò Chieffo
    (LP: #180598)
  * Add events/asus-video to support asus switch video hotkey; patch from
    Nicolò Chieffo (LP: #138228)
  * events/asus-wireless-2, asus-wireless-2.sh:
    Support Fn+F2 on Asus A8Js; patch from Matteo Collina (LP: #105929)
  * Fix the value range in sonybright.sh (0-7 instead of 1-8); patch from unggnu
    (LP: #136380)
  * "lib/FUJITSU SIEMENS.config":
    - Enable suspend for Fujitsu-Siemens C1110 (LP: #52970)
    - Enable STR for Fujitsu-Siemens Lifebook S7020, S7110
  * resume.d/50-time.sh, suspend.d/88-time.sh:
    Fix handling of hardware clock before/after suspend; patch from Rodrigo
    Novo (LP: #36815)
  * events/asus-*: Fix event key names for ASUS (HOTK); patch from
    Jeroen van der Vegt (LP: #25784)
  * Fix names in comments for events/panasonic-{mute,volume-down,volume-up}
  * debian/rules, README.toshiba: Drop toshiba_acpi.modprobe, which only
    contained an invalid/obsolete option "hotkeys_over_acpi" (LP: #180678)
  * debian/control: Standards-Version 3.7.3

Related branches

Daniel Hahler (blueyed) wrote :
Changed in acpi-support:
milestone: none → hardy-alpha-6
Jerone Young (jerone) wrote :

I've added another bug report for 1 last issue for Thinkpads T6x series (and all other thinkpads),
bugzilla #194679
found here:
https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/194679

Jerone Young (jerone) wrote :

Here is one for the Thinkpad eject button:
bugzilla #194609

https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/194609

Daniel Hahler (blueyed) wrote :

Thanks, Jerone for providing these additional fixes. I've added them to the debdiff:
  * Drop thinkpad_acpi.modprobe: the workarounds therein are not needed for
    thinkpad_acpi in Hardy anymore; investigations by Jerone Young (LP: #194679)
  * Add events/lenovo-eject to handle the Thinkpad eject button (Fn+F9); patch
    from Jerone Young (LP: #194609)

Jerone Young (jerone) wrote :

I noticed in your diff you drop the install fro the toshiba_acpi.modprobe & thinkpad_acpi.modprobe in debian/rules . You may want to keep these installing these (they just whould not have any options in them of course). This way if by some off chance users do need to place options .. they can easily do so.

So for file toshiba_acpi.modprobe you would just have the contents:
options toshiba_acpi

Same goes for thinkpad_acpi.modprobe ( but the patch already does this :-) )

Daniel Hahler (blueyed) wrote :

Well, my idea was that it's not too difficult to create a new file in case it's needed and that it's better to have less (useless) files laying around.
But as you've mentioned, I've not properly nuked thinkpad_acpi.modprobe (although it does not get installed anymore).
I need to adjust the patch in either way.. do you (and others) think that it makes sense to have config file stubs laying around?

Jerone Young (jerone) wrote :

Acutally looking at modprobe.d directory there are not a lot of files. Meaning that only the modules that NEED options are there. So I would say nuke both files completely since they there options are no longer needed.

Daniel Hahler (blueyed) on 2008-02-26
Changed in acpi-support:
assignee: nobody → blueyed
status: Triaged → In Progress
Daniel Hahler (blueyed) wrote :

Ok. Both nuked. Waiting for a sponsor again.. :)

Changed in acpi-support:
assignee: blueyed → nobody
status: In Progress → Triaged
Jerone Young (jerone) wrote :

The big question is who is the freakin maintainer of acpi-support for ubuntu ? Thanks for the work Daniel .. it appears Ubuntu forked acpi-support then doesn't even want to maintain it. Users submit patches and they all seem to be getting ignored.

Steve Langasek (vorlon) wrote :

Hi Daniel,

I've followed up to bugs 183682 and 180598 with comments. I don't believe these patches are correct as written.

As 180598 superseded my own bug report about the same issue, I have a vested interest in seeing some of these acpi-support fixes get in and would be happy to sponsor an upload provided that these concerns are addressed.

Steve Langasek (vorlon) on 2008-03-01
Changed in acpi-support:
milestone: hardy-alpha-6 → ubuntu-8.04-beta
Jerone Young (jerone) wrote :

To get this into gutsy. I think you should just drop the 2 that Steve has issue with .. can fight those fights later. But there are other fixes for me (Drop thinkpad-acpi.modprobe) .. that seem more important. Hotkey stuff can easily be fixed by users if need be...sigh..sad that's it's come to this point..seeing how these bugs have had ample time.

Daniel Hahler (blueyed) wrote :

I've dropped the patches for bug 183682 and 180598 now.
Please find the new debdiff attached.

I've created a bzr branch to better track changes to it at https://code.launchpad.net/~blueyed/acpi-support/cherry-pick

Colin Watson (cjwatson) wrote :

Jerone: for the record, Ubuntu *wrote* acpi-support in the first place; we didn't fork it.

Colin Watson (cjwatson) wrote :

Assigning to Steve per this morning's platform team meeting.

Changed in acpi-support:
assignee: nobody → vorlon
Steve Langasek (vorlon) wrote :

Thanks for all of your work on this, Daniel. The new package seems to fix all of my own acpi hotkey issues, so I'm happy to sponsor it. :)

I'm uploading this package, with one small change: I've changed asus-wireless-2.sh to be a /bin/sh script instead of a bash script, since there's nothing bash-specific in it and bash is much heavier than dash.

BTW, did you notice the comment in 194609 about the 'eject' button being for a dock eject, not a CD eject? I confirm that my wife's X61 has an eject hotkey, and the X61 doesn't come with an optical drive, so I think Chris may be right. I've uploaded anyway, though; this isn't a regression since the hotkey currently isn't doing anything at all...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package acpi-support - 0.106

---------------
acpi-support (0.106) hardy; urgency=low

  * Cherrypicked bugfix patches from Launchpad (LP: #193842)
  * lib/state-funcs: make wireless led work with asus-laptop (the new module);
    patch from Nicolò Chieffo (LP: #189889)
  * Add events/asus-video to support asus switch video hotkey; patch from
    Nicolò Chieffo (LP: #138228)
  * events/asus-wireless-2, asus-wireless-2.sh:
    Support Fn+F2 on Asus A8Js; patch from Matteo Collina (LP: #105929)
  * Fix the value range in sonybright.sh (0-7 instead of 1-8); patch from unggnu
    (LP: #136380)
  * "lib/FUJITSU SIEMENS.config":
    - Enable suspend for Fujitsu-Siemens C1110 (LP: #52970)
    - Enable STR for Fujitsu-Siemens Lifebook S7020, S7110
  * resume.d/50-time.sh, suspend.d/88-time.sh:
    Fix handling of hardware clock before/after suspend; patch from Rodrigo
    Novo (LP: #36815)
  * events/asus-*: Fix event key names for ASUS (HOTK); patch from
    Jeroen van der Vegt (LP: #25784)
  * Fix names in comments for events/panasonic-{mute,volume-down,volume-up}
  * debian/rules, README.toshiba: Drop toshiba_acpi.modprobe, which only
    contained an invalid/obsolete option "hotkeys_over_acpi" (LP: #180678)
  * debian/control: Standards-Version 3.7.3
  * Drop thinkpad_acpi.modprobe: the workarounds therein are not needed for
    thinkpad_acpi in Hardy anymore; investigations by Jerone Young (LP: #194679)
  * Add events/lenovo-eject to handle the Thinkpad eject button (Fn+F9); patch
    from Jerone Young (LP: #194609)

 -- Daniel Hahler <email address hidden> Thu, 06 Mar 2008 02:15:54 +0100

Changed in acpi-support:
status: Triaged → Fix Released
Reed Loden (reed) wrote :

I'm confused... You removed the installs of thinkpad_acpi.modprobe and toshiba_acpi.modprobe on new systems (good), but you left old systems with the old files without any notice that they need to remove them. Instead, you should have removed the files completely or at least overwritten them with an empty file. As it currently stands, I have the latest acpi-support package installed, but I clearly still have the old thinkpad_acpi.modprobe and toshiba_acpi.modprobe files in /etc/modprobe.d/. Think means I'm stuck with the old (and broken) files that cause my laptop (a Thinkpad) to have "broken" function keys since it still has the old settings. Please think about current users of packages when you remove files instead of only fixing things for people who do complete reinstalls.

Daniel Hahler (blueyed) wrote :

Reed, you make a good point: I've noticed the obsolete files, but forgot about forcing removal of them.. I wasn't aware that this should get done.

The fix for this is included in the debdiff attached to bug 203369, which also fixes a severe regression for Fujitsu notebooks, caused by a typo.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers