suspend/resume scripts cause "Your computer failed to suspend" on resume.

Bug #144105 reported by jbj on 2007-09-22
2
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: acpi-support

Two things:
/etc/acpi/resume.d/72-acpi-pain.sh:
refers to acpi_sbs instead of sbs, causing error output that makes the hal suspend call fail.

/etc/acpi/suspend.d/55-down-interfaces.sh a/etc/acpi/resume.d/62-ifup.shnd :
Assumes all interfaces that are reported 'up' with ifconfig will be sanely dealt with by ifdown/ifup (none of my interfaces are in /etc/. If I redirect stdout and stderr of the ifdown/ifup calls, hal doesn't report failure.

The sort of output that comes out of ifdown and ifup that makes hal think suspend failed:
ifdown: interface eth0 not configured

Ignoring unknown interface eth0=eth0.

I don't know what the intelligent fix for these two scripts is.

jbj (jbj-ubu) wrote :

Might have been hasty... Can't tell if this would cause that problem, but nevertheless, the scripts have a problem.

Hans Deragon (deragon) wrote :

I have this error showing up in Hardy Heron Beta. However, this is probably a duplicate of another bug. We cannot be the only one suffering from this bug.

Changed in acpi-support:
status: New → Confirmed
chourave (gaston72) wrote :

I have the same error in Gutsy, concerning the script 72-acpi-pain.sh :
I'm currently trying to fix resume failure, so I have tryed to run :
sudo /etc/acpi/resume.sh (with set -x added at the beginning of the script)
It gives :
....
+ . /etc/acpi/resume.d/72-acpi-pain.sh
....
++ modprobe -r acpi_sbs
FATAL: Module acpi_sbs not found.
....

I replaced "acpi_sbs" (this module isn't present in my system) by "sbs" (this module exist) in the file 72-acpi-pain.sh.
result : some messages like :
"hash matches device ttyc7" or "hash matches device ptya1"
seem to disappear in dmesg, but it doesn't help me in fixing my suspend / resume problem...

I don't understand clearly what's the matter with ifdown/ifup, could you explain the problem and the way to test it ?

Linux NEANT 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux
Laptop Lenovo 3000 C200 8922AZG

chourave (gaston72) wrote :

Installing the new kernel (2-6-24-16-generic) on Gutsy solved the problem (resume failure) for me

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers