acpi-call 1.1.0-2 ADT test failure with linux-hwe-edge 4.13.0-16.19~16.04.3

Bug #1724862 reported by Seth Forshee on 2017-10-19
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
acpi-call (Debian)
Fix Released
Unknown
acpi-call (Ubuntu)
Undecided
Marcelo Cerri
Nominated for Xenial by Marcelo Cerri
Xenial
Undecided
Unassigned

Bug Description

[Impact]

Currently the DKMS package fails to install in supported custom kernels that are based on 4.11 or 4.13. That includes the current 4.11 hwe-edge and the upcoming 4.13 hwe-edge kernels and some of the custom and cloud kernels as well.

[Test Case]

Install the DKMS package with the 4.13 hwe-edge kernel from -proposed. The package installation should proceed without any errors.

[Regression Potential]

Although new patches were added, the regression risk is very low since the new changes are conditionally compiled based on the kernel version.

Besides that the new package was tested with the following kernels in an amd64 environment:

- linux-generic 4.4
- linux-hwe 4.10
- linux-hwe-edge 4.11
- linux-hwe-edge 4.13 (from xenial-proposed)
- linux-azure 4.11
- linux-azure-edge 4.13 (which is in process of getting promoted to
  xenial-proposed)

[Original description]

Testing failed on:
    amd64: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/a/acpi-call/20171018_121140_0c63b@/log.gz
    armhf: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/armhf/a/acpi-call/20171018_120650_0c63b@/log.gz
    i386: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/i386/a/acpi-call/20171018_120646_0c63b@/log.gz
    ppc64el: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/ppc64el/a/acpi-call/20171018_120452_0c63b@/log.gz

Seth Forshee (sforshee) wrote :
tags: added: kernel-adt-failure
Seth Forshee (sforshee) on 2017-10-25
tags: added: kernel-adt-failure-hwe-edge-4.11
removed: kernel-adt-failure
tags: added: kernel-adt-failure-hwe-edge-4.13
removed: kernel-adt-failure-hwe-edge-4.11
Marcelo Cerri (mhcerri) on 2017-10-27
description: updated
Raphaël HALIMI (raph) wrote :

Hi,

Debian developer here. This bug was fixed in 1.1.0-4 (artful) thanks to a patch from Colin Ian King (see https://bugs.launchpad.net/ubuntu/+source/acpi-call/+bug/1700783). I'm not sure how Ubuntu updates/backports work, but I guess you can either request a backport, or ask an Ubuntu developer to release an updated version of the package including the patch.

Marcelo Cerri (mhcerri) on 2017-11-01
Changed in acpi-call (Ubuntu):
status: New → In Progress
assignee: nobody → Marcelo Cerri (mhcerri)

Hello Seth, or anyone else affected,

Accepted acpi-call into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/acpi-call/1.1.0-2ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in acpi-call (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial
Changed in acpi-call (Ubuntu):
status: In Progress → Fix Released
Changed in acpi-call (Debian):
status: Unknown → Fix Released
Marcelo Cerri (mhcerri) on 2017-11-30
tags: added: verification-done-xenial
removed: verification-needed-xenial
tags: added: verification-done
removed: verification-needed
Brian Murray (brian-murray) wrote :

Please provide some details about the verification.

Changed in acpi-call (Ubuntu Xenial):
status: Fix Committed → Incomplete
Robie Basak (racb) on 2017-12-06
tags: added: verification-needed verification-needed-xenial
removed: verification-done verification-done-xenial
David Martinka (mainmachine) wrote :

The proposed fix resolves this issue for me.

added xenial proposed, upgraded acpi-call-dkms to 1.1.0-2ubuntu1 as per comment #3 above, DKMS build succeeded for the two kernels I have installed that were affected:

4.13.0-19-generic
4.13.0-21-generic

I triggered a DKMS rebuild as a confirmation test, which also succeeded:

ls /var/lib/initramfs-tools | sudo xargs -n1 /usr/lib/dkms/dkms_autoinstaller start

So this proposed fix seems to work.

Thank you! :)

Dave Long (longwave) wrote :

The proposed fix resolves this issue for me as well.

This now affects xenial with the standard HWE stack enabled (not just hwe-edge) as linux-generic-hwe-16.04 currently selects kernel 4.13.0-26.29, but this errors during the build when dkms is installed due to this issue.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package acpi-call - 1.1.0-2ubuntu1

---------------
acpi-call (1.1.0-2ubuntu1) xenial; urgency=medium

  * Upload to xenial for kernel 4.11 and 4.13 (LP: #1724862)
    - 0002-Fix-build-4.12-copy-from-user.patch

 -- Marcelo Henrique Cerri <email address hidden> Fri, 27 Oct 2017 14:42:46 -0200

Changed in acpi-call (Ubuntu Xenial):
status: Incomplete → Fix Released

The verification of the Stable Release Update for acpi-call has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.