[feisty-gutsy-hardy-jaunty] acidbase depends on both the MySQL and PostgreSQL client

Bug #223405 reported by Pierre Buard
12
Affects Status Importance Assigned to Milestone
acidbase (Ubuntu)
Fix Released
Undecided
Ubuntu Server

Bug Description

Binary package hint: acidbase

Even though I only want the MySQL part, I'm forced to install both.

In a perfect world, I would have a choice between the two.
(Like mailx which allows me to select between exim4 or another mail-transport-agent)

Changed in acidbase:
assignee: nobody → ubuntu-server
Revision history for this message
Clayton (claytong) wrote :

Additionally it requires the mysql-client package which only points to mysql-client-5.0 . I have mysql-client-5.1 installed which should fulfill the dependency.

Perhaps the solution is to change the dependency to a suggest?

Revision history for this message
Charles Hooper (chooper) wrote :

Confirmed in Ubuntu 9.04 (Jaunty) acidbase-1.3.9

Depends: ${misc:Depends}, dbconfig-common, mysql-client | virtual-mysql-client, postgresql-client, php5 | php4 | php5-cli | php4-cli, libphp-adodb (>= 4.62), libwww-perl
Suggests: snort-mysql | snort-pgsql

Changed in acidbase (Ubuntu):
status: New → Incomplete
status: Incomplete → Confirmed
Revision history for this message
Charles Hooper (chooper) wrote :

Changing to the following should be acceptable, no?

Depends: ${misc:Depends}, dbconfig-common, mysql-client | virtual-mysql-client | postgresql-client, php5 | php4 | php5-cli | php4-cli, libphp-adodb (>= 4.62), libwww-perl

summary: - [feisty-gutsy-hardy] acidbase depends on both the MySQL and PostgreSQL
- client
+ [feisty-gutsy-hardy-jaunty] acidbase depends on both the MySQL and
+ PostgreSQL client
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package acidbase - 1.4.4-3

---------------
acidbase (1.4.4-3) unstable; urgency=medium

  * debian/control: Dependencies for php-mail and php-mail-mime (Closes:
    #561321) - thanks to Thomas Mueller <email address hidden>

acidbase (1.4.4-2) unstable; urgency=low

  * debian/control: Update depends against mysql & postgresql (LP:
    #223405)
  * debian/control: Add Vcs-* headers
  * debian/gbp.conf: Add GBP config settings
 -- Ubuntu Archive Auto-Sync <email address hidden> Fri, 01 Jan 2010 10:08:11 +0000

Changed in acidbase (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers