Merge acct 6.5.4-2 (main) from Debian unstable (main)

Bug #609754 reported by Artur Rona on 2010-07-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
acct (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: acct

 acct (6.5.4-2) unstable; urgency=low

   * Re-add patch 03-acct-file.patch applied upstream in 6.5.1, seems the
     change is no longer there in 6.5.4. (Closes: 579483)
   * Update Standards-Version to 3.9.0.
   * Revert to division by CURR_AHZ rather sysconf(_SC_CLK_TCK) (Closes: 581421)

 -- Mathieu Trudel <email address hidden> Fri, 23 Jul 2010 08:58:38 +0200

acct (6.5.4-1) unstable; urgency=low

  * New upstream release: 6.5.4
  * Updated patch to remove last from the documentation.
    - updated debian/patches/01-last.patch
  * Drop lastcomm's strict-match documentation patch, applied upstream.
    - deleted debian/patches/06-lastcomm-manpage-strict-match.patch
    - updated debian/patches/series
  * Drop manpage updates to remove PD macros.
    - deleted debian/patches/07-manpage-PD-macros.patch
    - updated debian/patches/series
  * Drop lastcomm manpage update for typos (B macro).
    - deleted debian/patches/08-lastcomm-manpage-hyphen-as-minus-sign.patch
    - updated debian/patches/series
  * Update field descriptions for lastcomm's reports (Closes: #414300)
    - added debian/patches/414300-lastcomm-fields-descr.patch
  * Update FILES section in lastcomm's manpage (Closes: #512729)
    - added debian/patches/512729-lastcomm-files.patch
    - updated debian/patches/series
  * Correct default unit in sa manpage, thanks Dominique Brazziel
    (Closes: #488731)
    - added debian/patches/488731-sa-manpage-default-unit.patch
    - updates debian/patches/series
  * Update acct init.d script to use lsb init-functions (Closes: #457976)
    - updated debian/acct.init.d
  * Create debian/source/format, switch to format 3.0 (quilt).
    - added debian/source/format
  * Bump Standards-Version to 3.8.4
    - update debian/control
  * Drop dircategory/direntry additions to accounting.texi, applied upstream.
    - deleted debian/patches/09-info-dir-entry.patch
    - updated debian/patches/series

 -- Mathieu Trudel <email address hidden> Sun, 25 Apr 2010 23:08:23 -0400

Related branches

Artur Rona (ari-tczew) on 2010-07-25
Changed in acct (Ubuntu):
status: New → Confirmed

As there is an important but in acct 6.5.4-1, perhaps it would be best to wait for 6.5.4-2 (waiting for sponsorship in Debian), or additionally re-patch configure to set the correct ACCT_FILE paths.

Daniel Holbach (dholbach) wrote :

6.5.4-2 is in sid, can you you do another merge?

I'll unsubscribe sponsors for now.

Artur Rona (ari-tczew) on 2010-08-03
summary: - Merge acct 6.5.4-1 (main) from Debian unstable (main)
+ Merge acct 6.5.4-2 (main) from Debian unstable (main)
description: updated
Artur Rona (ari-tczew) wrote :

Updated debdiff.

Didier Roche (didrocks) wrote :

Hey Artur,

thanks for your work!
Just a quick note: you should remove the postinst change.
Indeed, as we only support lucid -> maverick and lucid -> next LTS upload, the dpkg-compare used to remove the symlink which was pre-hardy isn't needed anymore. Cleaning the cruft is sometimes good.
Can you propose a new debdiff taking that into account and ping me? thanks a lot!

Artur Rona (ari-tczew) wrote :
Artur Rona (ari-tczew) wrote :

Maybe is it a sync?

Arthur, not a sync because of runlevel changes. I will check if the changes
can be brought in debian.

On Aug 5, 2010 6:50 PM, "Artur Rona" <email address hidden> wrote:

Maybe is it a sync?

-- Merge acct 6.5.4-2 (main) from Debian unstable (main)
https://bugs.launchpad.net/bugs/609754 Yo...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package acct - 6.5.4-2ubuntu1

---------------
acct (6.5.4-2ubuntu1) maverick; urgency=low

  * Merge from Debian testing, remaining changes: (LP: #609754)
    - Remove stop links from rc0 and rc6.

acct (6.5.4-2) unstable; urgency=low

  * Re-add patch 03-acct-file.patch applied upstream in 6.5.1, seems the
    change is no longer there in 6.5.4. (Closes: 579483)
  * Update Standards-Version to 3.9.0.
  * Revert to division by CURR_AHZ rather sysconf(_SC_CLK_TCK) (Closes: 581421)

acct (6.5.4-1) unstable; urgency=low

  * New upstream release: 6.5.4
  * Updated patch to remove last from the documentation.
    - updated debian/patches/01-last.patch
  * Drop lastcomm's strict-match documentation patch, applied upstream.
    - deleted debian/patches/06-lastcomm-manpage-strict-match.patch
    - updated debian/patches/series
  * Drop manpage updates to remove PD macros.
    - deleted debian/patches/07-manpage-PD-macros.patch
    - updated debian/patches/series
  * Drop lastcomm manpage update for typos (B macro).
    - deleted debian/patches/08-lastcomm-manpage-hyphen-as-minus-sign.patch
    - updated debian/patches/series
  * Update field descriptions for lastcomm's reports (Closes: #414300)
    - added debian/patches/414300-lastcomm-fields-descr.patch
  * Update FILES section in lastcomm's manpage (Closes: #512729)
    - added debian/patches/512729-lastcomm-files.patch
    - updated debian/patches/series
  * Correct default unit in sa manpage, thanks Dominique Brazziel
    (Closes: #488731)
    - added debian/patches/488731-sa-manpage-default-unit.patch
    - updates debian/patches/series
  * Update acct init.d script to use lsb init-functions (Closes: #457976)
    - updated debian/acct.init.d
  * Create debian/source/format, switch to format 3.0 (quilt).
    - added debian/source/format
  * Bump Standards-Version to 3.8.4
    - update debian/control
  * Drop dircategory/direntry additions to accounting.texi, applied upstream.
    - deleted debian/patches/09-info-dir-entry.patch
    - updated debian/patches/series
 -- Artur Rona <email address hidden> Thu, 05 Aug 2010 00:08:34 +0200

Changed in acct (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers