Various programs crashed with SIGSEGV in g_str_hash() from g_hash_table_lookup_node() / g_hash_table_lookup() from accountsservice 0.6.55-0ubuntu5/6

Bug #1841382 reported by Christian Kirbach on 2019-08-25
106
This bug affects 14 people
Affects Status Importance Assigned to Milestone
accountsservice
Fix Released
Unknown
accountsservice (Ubuntu)
High
Robert Ancell

Bug Description

https://errors.ubuntu.com/problem/3a817938d76d231fdfc8f698392fbf5e3724084f
https://errors.ubuntu.com/problem/597be858df957473f357a9249b002b0e39f42781
https://errors.ubuntu.com/problem/0075340d0eeeef484f9b5d37821d3023970cc12d

I do not know what triggered the crash.

ProblemType: Crash
DistroRelease: Ubuntu 19.10
Package: gnome-shell 3.32.2-2ubuntu1
ProcVersionSignature: Ubuntu 5.2.0-10.11-generic 5.2.4
Uname: Linux 5.2.0-10-generic x86_64
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sun Aug 25 20:45:09 2019
DisplayManager: gdm3
ExecutablePath: /usr/bin/gnome-shell
InstallationDate: Installed on 2019-08-24 (1 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Alpha amd64 (20190819)
ProcCmdline: /usr/bin/gnome-shell
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
RelatedPackageVersions: mutter-common 3.32.2+git20190711-2ubuntu1
Signal: 11
SourcePackage: gnome-shell
StacktraceTop:
 g_str_hash () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_hash_table_lookup () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libaccountsservice.so.0
 ?? ()
 ?? ()
Title: gnome-shell crashed with SIGSEGV in g_str_hash()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
separator:

information type: Private → Public

StacktraceTop:
 g_str_hash (v=0x0) at ../../../glib/ghash.c:2324
 g_hash_table_lookup_node (hash_return=<synthetic pointer>, key=0x0, hash_table=0x55bece1ac360) at ../../../glib/ghash.c:473
 g_hash_table_lookup (hash_table=0x55bece1ac360, key=0x0) at ../../../glib/ghash.c:1509
 console_kit_session_default_init (iface=0x0) at src/libaccountsservice/ck-session-generated.c:1128
 ?? ()

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Looks to me like a problem in libaccountsservice

summary: - gnome-shell crashed with SIGSEGV in g_str_hash()
+ gnome-shell crashed with SIGSEGV in g_str_hash() from
+ g_hash_table_lookup_node() from g_hash_table_lookup() from
+ console_kit_session_default_init()
summary: - gnome-shell crashed with SIGSEGV in g_str_hash() from
+ Various programs crashed with SIGSEGV in g_str_hash() from
g_hash_table_lookup_node() from g_hash_table_lookup() from
console_kit_session_default_init()
affects: gnome-shell (Ubuntu) → accountsservice (Ubuntu)
no longer affects: gnome-settings-daemon (Ubuntu)
summary: Various programs crashed with SIGSEGV in g_str_hash() from
g_hash_table_lookup_node() from g_hash_table_lookup() from
- console_kit_session_default_init()
+ console_kit_session_default_init() with accountsservice 0.6.55-0ubuntu5

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in accountsservice (Ubuntu):
status: New → Confirmed
summary: Various programs crashed with SIGSEGV in g_str_hash() from
- g_hash_table_lookup_node() from g_hash_table_lookup() from
- console_kit_session_default_init() with accountsservice 0.6.55-0ubuntu5
+ g_hash_table_lookup_node() / g_hash_table_lookup() from accountsservice
description: updated
description: updated
Daniel van Vugt (vanvugt) wrote :
description: updated
Changed in accountsservice (Ubuntu):
importance: Medium → High
tags: added: regression-release
summary: Various programs crashed with SIGSEGV in g_str_hash() from
g_hash_table_lookup_node() / g_hash_table_lookup() from accountsservice
+ 0.6.55-0ubuntu5
summary: Various programs crashed with SIGSEGV in g_str_hash() from
g_hash_table_lookup_node() / g_hash_table_lookup() from accountsservice
- 0.6.55-0ubuntu5
+ 0.6.55-0ubuntu5/6
Changed in accountsservice (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Daniel van Vugt (vanvugt) wrote :

If anyone experiences this crash repeatedly then please help us to debug it by downgrading to the last known non-crashing version:

  https://launchpad.net/ubuntu/+source/accountsservice/0.6.55-0ubuntu4 (click amd64)

and tell us if that avoids the crash. If that still crashes then try:

  https://launchpad.net/ubuntu/+source/accountsservice/0.6.55-0ubuntu3

and so on.

tags: added: rls-ee-incoming
Daniel van Vugt (vanvugt) wrote :

Maybe not a regression. Seems some older releases have been seeing these crashes too. It just suddenly became more common this week.

tags: removed: regression-release
Robert Ancell (robert-ancell) wrote :

It looks like it's crashing in this code:

        username = act_user_get_user_name (user);
        if (g_hash_table_lookup (priv->system_users_by_name, username) != NULL) {

and username is probably NULL.

A possible cause of this is the user object for some reason might not have a DBus proxy backing it.

Robert Ancell (robert-ancell) wrote :

If the above theory is correct then this commit caused the bug:
https://gitlab.freedesktop.org/accountsservice/accountsservice/commit/9b4108755a6e1f5f04d80fef92dd3f81423857ad

This commit came when we migrated from 0.6.45 to 0.6.50, which explains why this is being seen in disco and eoan.

Changed in accountsservice:
status: Unknown → New
Robert Ancell (robert-ancell) wrote :

The main issue is when I updated to 0.6.55 the new Meson based build systemd didn't build with systemd support by default. So I've uploaded a build with this enabled. There may still be an underlying issue, but this should fix the eoan issues.

Changed in accountsservice (Ubuntu):
status: Confirmed → Fix Committed
Changed in accountsservice:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package accountsservice - 0.6.55-0ubuntu8

---------------
accountsservice (0.6.55-0ubuntu8) eoan; urgency=medium

  * debian/rules:
    - Compile with -Dsystemd=true to fix libaccountsservice not working properly
      (LP: #1841382)

 -- Robert Ancell <email address hidden> Fri, 06 Sep 2019 15:33:47 +1200

Changed in accountsservice (Ubuntu):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Still tracking similar crashes in bug 1843982 now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.