Changing language has no effect

Bug #1351308 reported by Jean-Baptiste Lallement on 2014-08-01
50
This bug affects 5 people
Affects Status Importance Assigned to Milestone
accountsservice (Ubuntu)
High
Michael Terry

Bug Description

broken on mako #164
Last known good image: #163

TEST CASE:
1. On a device in English, go to "System Settings/Language & Text/Display Language"
2. Scroll down the list and select another language i.e "Français (France)"
3. Tap "Confirm"

ACTUAL RESULT
Language did not change (the label in front of "Display language" is still English) and is still English (even after a reboot)

EXPECTED LANGUAGE
Setting is set to French and UI is localized after a reboot.

Same problem with the wizard. The language changes *inside* the wizard but changes are not written to ~/.pam_environment

Downgrading accountsservice to 0.6.37-1ubuntu6 on #167 fixes the issue
Upgrading accountsservice to 0.6.37-1ubuntu7 on #164 reproduces the issue

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: ubuntu-system-settings 0.3+14.10.20140730-0ubuntu1
Uname: Linux 3.4.0-5-mako armv7l
ApportVersion: 2.14.5-0ubuntu2
Architecture: armhf
Date: Fri Aug 1 15:05:35 2014
InstallationDate: Installed on 2014-08-01 (0 days ago)
InstallationMedia: Ubuntu Utopic Unicorn (development branch) - armhf (20140801-020205)
SourcePackage: ubuntu-system-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → High

Yeah, seems broken on latest proposed image here.

description: updated
tags: added: lt-blocker lt-category-visible lt-prio-high
Sebastien Bacher (seb128) wrote :

duplicate of bug #1240875?

Sebastien Bacher (seb128) wrote :

oh, no, you said it's not applied at all ... settings didn't change, could be a toolkit issue

Jean-Baptiste Lallement (jibel) wrote :

Right, it is not a duplicate because the setting is not applied at all, so a reboot won't do anything since the language didn't change.

Jean-Baptiste Lallement (jibel) wrote :

It also affects the wizard, filed bug 1351569 but likely a duplicate

description: updated
Michał Sawicz (saviq) wrote :

For me it applies *inside* settings / wizard, but doesn't write the changes to .pam_environment.

Jean-Baptiste Lallement (jibel) wrote :

It's a regression in accountsservice 0.6.37-1ubuntu7

I reproduced by flashing #163 (last known good image) and upgrading:

accountsservice:armhf (0.6.37-1ubuntu6, 0.6.37-1ubuntu7)
libaccountsservice0:armhf (0.6.37-1ubuntu6, 0.6.37-1ubuntu7)

reassigning to accountsservice

affects: ubuntu-system-settings (Ubuntu) → accountsservice (Ubuntu)
description: updated
description: updated
Gunnar Hjalmarsson (gunnarhj) wrote :

Changing language works on an updated utopic desktop with accountsservice 0.6.37-1ubuntu7. Can it be that some library needs to be added to the touch image rather than changing accountsservice?

Changed in accountsservice (Ubuntu):
assignee: nobody → Michael Terry (mterry)
Michael Terry (mterry) wrote :

This also effects setting a password.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package accountsservice - 0.6.37-1ubuntu8

---------------
accountsservice (0.6.37-1ubuntu8) utopic; urgency=medium

  * debian/rules:
    - Use -O1 instead of -O2 because it works around a problem with
      the manager object never reporting its readiness to users of
      libaccountsservice. Hoping this fixes LP: #1351308
 -- Michael Terry <email address hidden> Mon, 04 Aug 2014 20:07:12 -0400

Changed in accountsservice (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers