Unable to access Facebook online account

Bug #1304798 reported by Felix M. Cobos on 2014-04-09
146
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Online Accounts: Account plugins
Critical
Alberto Mardegan
12.10
Undecided
Unassigned
13.04
Undecided
Unassigned
13.10
Undecided
Unassigned
account-plugins (Ubuntu)
High
Alberto Mardegan
Saucy
Undecided
Robert Bruce Park
Trusty
High
Alberto Mardegan

Bug Description

[Impact]

 * Facebook integration has failed due to API token becoming invalidated.

 * No Saucy users are able to integrate Facebook in either Empathy or Friends.

[Test Case]

 * Open Ubuntu Online Accounts, attempt to register a Facebook account. Facebook gives an error message saying your app is either deleted or invalid.

[Regression Potential]

 * Zero, stable release is already broken.

Related branches

affects: empathy (Ubuntu) → account-plugins (Ubuntu)
Changed in account-plugins (Ubuntu):
assignee: nobody → Alberto Mardegan (mardy)
importance: Undecided → High
milestone: none → ubuntu-14.04
Alberto Mardegan (mardy) wrote :

Thanks Felix for reporting this bug, we'll try to get it solved ASAP.

Changed in account-plugins:
status: New → In Progress
Changed in account-plugins (Ubuntu Trusty):
status: New → Confirmed
Changed in account-plugins:
importance: Undecided → Critical
assignee: nobody → Alberto Mardegan (mardy)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
Changed in friends-app (Ubuntu):
status: New → Confirmed
David Barth (dbarth) wrote :

Our central Facebook API key has been revoked.

The impact is that Ubuntu users cannot use the Facebook integration anymore, ie post messages or photos from applications using our central key: Empathy, the Photo scope, the Friends app and Shotwell to a lesser extent.

All releases (14.04, 12.10+) are impacted.

Users can still use Facebook normally in the browser. The Facebook webapp is not affected either.

Here is the plan we have defined and are executing right now:

 * IS to register new API keys [DONE]
 * Alberto is reviewing the registration process to assist IS during this [DONE]
 * Alberto to MP a branch with the new keys in account-plugin-facebook [DONE]
 * Silo landing and upload to 14.04 asap [INPROGRESS]
 * Backport of the new key to supported releases as an SRU [TODO]

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package account-plugins - 0.11+14.04.20140409.1-0ubuntu1

---------------
account-plugins (0.11+14.04.20140409.1-0ubuntu1) trusty; urgency=low

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Alberto Mardegan ]
  * Use new Canonical-owned facebook application key (LP: #1304798)

  [ David Barth ]
  * This change is to fix the maintainer scripts for the flickr
    settings. It mostly undoes the changes of
    https://code.launchpad.net/~mardy/account-
    plugins/lp1299659/+merge/213415 which are considered dangerous. (LP:
    #1299659)

account-plugins (0.11+14.04.20140401-0ubuntu1) trusty; urgency=low

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Alberto Mardegan ]
  * Restore the ability to create flickr accounts. This has the
    unfortunate side-effect of re-opening bug 1041744, by making the
    unsupported "login with Facebook" and "login with Google" buttons
    visible again, but that's a necessary evil. (LP: #1041744, #1299659)
 -- Ubuntu daily release <email address hidden> Wed, 09 Apr 2014 17:58:25 +0000

Changed in account-plugins (Ubuntu Trusty):
status: Confirmed → Fix Released
Changed in empathy (Ubuntu Saucy):
status: New → Invalid
Changed in friends-app (Ubuntu Saucy):
status: New → Invalid
Changed in account-plugins (Ubuntu Saucy):
assignee: nobody → Robert Bruce Park (robru)
status: New → In Progress
description: updated
Robert Bruce Park (robru) wrote :

The saucy package is currently building in ppa:ubuntu-unity/sru-staging. SRU team, please accept into saucy-proposed. Thanks.

Brian Murray (brian-murray) wrote :

The sync request is for this version of the package (0.11+13.10.20140414-0ubuntu1), but 0.11+13.10.20140414.1-0ubuntu1 isc currently in the SRU staging PPA. It looks to me like we really want to sync 201404.14.1 so I think I need request needs to be submitted.

Robert Bruce Park (robru) wrote :

Version 0.11+13.10.20140414-0ubuntu1 contained two independant bugfixes, however one of them was found to be ineffective / the problem was resolved by the service provider outside our control. So 0.11+13.10.20140414.1-0ubuntu1 contains a revert of the ineffective fix, but still contains the one fix that is important, the facebook API key change.

Please accept 0.11+13.10.20140414.1-0ubuntu1 into saucy-proposed for testing.

Hello Felix, or anyone else affected,

Accepted account-plugins into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/account-plugins/0.11+13.10.20140414.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in account-plugins (Ubuntu Saucy):
status: In Progress → Fix Committed
tags: added: verification-needed
Bruno Nova (brunonova) wrote :

I upgraded account-plugin-facebook to the version in saucy-proposed (13.10.20140414.2-0ubuntu1), and I confirm that this package fixes the bug.
I can now add my Facebook account in Online Accounts.

I also updated to saucy-proposed all other packages built from account-plugins that I had installed (found no problems):
* libaccount-plugin-google
* libaccount-plugin-generic-oauth
* account-plugin-windows-live
* account-plugin-twitter
* account-plugin-google
* account-plugin-flickr

tags: added: verification-done
removed: verification-needed
QkiZ (qkiz) wrote :

Ubuntu 14.04, account-plugin-facebook 0.11+14.04.20140409.1-0ubuntu1 - all problems gone :)

Samizdata (samizdata) wrote :

Well, with a fully updated AMD64 Trusty install I am still getting the error. Any suggestions?

Robert Bruce Park (robru) wrote :

Yes Samizdata, you can either install the updated package (0.11+14.04.20140409.1-0ubuntu1) from trusty-proposed, or wait for it to be released to trusty-updates, and then update it. The fix has not yet been released for Trusty, so it is not expected that "a fully updated AMD64 Trusty install" would have the fix in it yet.

The verification of the Stable Release Update for account-plugins has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package account-plugins - 0.11+13.10.20140414.2-0ubuntu1

---------------
account-plugins (0.11+13.10.20140414.2-0ubuntu1) saucy; urgency=low

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Robert Bruce Park ]
  * Revert erroneous maintscript creation.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 133

account-plugins (0.11+13.10.20140414-0ubuntu1) saucy; urgency=low

  [ Alberto Mardegan ]
  * Use new Canonical-owned facebook application key (LP: #1304798)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 129
 -- Ubuntu daily release <email address hidden> Mon, 14 Apr 2014 20:26:36 +0000

Changed in account-plugins (Ubuntu Saucy):
status: Fix Committed → Fix Released
Changed in empathy (Ubuntu):
status: Confirmed → Fix Released
Changed in empathy (Ubuntu Trusty):
status: Confirmed → Fix Released
no longer affects: empathy (Ubuntu)
no longer affects: friends-app (Ubuntu)
Changed in account-plugins:
status: In Progress → Fix Released
no longer affects: empathy (Ubuntu Saucy)
no longer affects: empathy (Ubuntu Trusty)
no longer affects: friends-app (Ubuntu Saucy)
no longer affects: friends-app (Ubuntu Trusty)
David Girault (dfgweb) wrote :

Ubuntu 14.04, account-plugin-facebook 0.11+14.04.20140409.1-0ubuntu1 (after ppa-purge of gnome3 ppa).
Still have empty login dialog when adding Facebook account (see detail on joinned log file):

(gnome-control-center.real:16388): goa-DEBUG: > GET /dialog/oauth?response_type=token&redirect_uri=https%3A%2F%2Fwww.facebook.com%2Fconnect%2Flogin_success.html&client_id=297654143624603&scope=user_events%2Cread_mailbox%2Cxmpp_login%2Cemail HTTP/1.1

(gnome-control-center.real:16388): goa-DEBUG: < HTTP/1.1 302 forced.302
(gnome-control-center.real:16388): goa-DEBUG: < Location: https://www.facebook.com/v1.0/dialog/oauth?redirect_uri=https%3A%2F%2Fwww.facebook.com%2Fconnect%2Flogin_success.html&scope=user_events%2Cread_mailbox%2Cxmpp_login%2Cemail&response_type=token&client_id=297654143624603&_rdr

(gnome-control-center.real:16388): goa-DEBUG: > GET /v1.0/dialog/oauth?redirect_uri=https%3A%2F%2Fwww.facebook.com%2Fconnect%2Flogin_success.html&scope=user_events%2Cread_mailbox%2Cxmpp_login%2Cemail&response_type=token&client_id=297654143624603&_rdr HTTP/1.1
(gnome-control-center.real:16388): goa-DEBUG: < HTTP/1.1 500 Internal Server Error
(gnome-control-center.real:16388): goa-DEBUG: < P3P: CP="Facebook does not have a P3P policy. Learn why here: http://fb.me/p3p"

Le 26/05/2014 15:52, David Girault a écrit :
> Ubuntu 14.04, account-plugin-facebook 0.11+14.04.20140409.1-0ubuntu1 (after ppa-purge of gnome3 ppa).
Works here on the base install, so I guess this is something in your
local config.

The "HTTP/1.1 500 Internal Server Error" in the logs seems to indicate
that the server request fails. Can you try with another FB user account
for example?

David

Robert Bruce Park (robru) wrote :

Hi David,

Can you please report a new bug for that against gnome-control-center?

This bug has to do with the Facebook API key used by Ubuntu Online Accounts, as accessed through unity-control-center. What you're experiencing with Gnome Online Accounts with gnome-control-center is unrelated.

(also I just re-confirmed that this bug is really fixed in latest trusty)

Thanks!

David Girault (dfgweb) wrote :

It seems my facebook account creation don't rely on account-plugin-facebook!
It works correctly when I use the 'credentials-preferences'!

dg@pc-david:~$ account-console list
No accounts
dg@pc-david:~$ credentials-preferences
... create FB account ok here ...
dg@pc-david:~$ account-console list
account: id 1, enabled, provider: facebook

So my existing google and imap/smtp accounts aren't managed through
account-console / credentials-preferences but with something else!

dg@pc-david:~$ mc-tool list
gabble/jabber/chat_2efacebook_2ecom0
gabble/jabber/goa_google_account_1400750022_1

David Girault (dfgweb) wrote :

Robert,
This bug is really fixed, but it's very hard to find where/how to create online account and which package is related.

I create this bug instead: https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1323351

Regards,
David

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers