accerciser crashed with TypeError in __subclasscheck__(): issubclass() arg 1 must be a class

Bug #1224497 reported by Jean-Baptiste Lallement
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
accerciser (Ubuntu)
Fix Released
High
Unassigned

Bug Description

Crashes on start on Ubuntu Saucy

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: accerciser 3.8.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-7.13-generic 3.11.0
Uname: Linux 3.11.0-7-generic x86_64
ApportVersion: 2.12.1-0ubuntu3
Architecture: amd64
Date: Thu Sep 12 10:12:26 2013
ExecutablePath: /usr/bin/accerciser
InstallationDate: Installed on 2013-09-03 (8 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130902)
InterpreterPath: /usr/bin/python3.3
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/bin/accerciser
PythonArgs: ['/usr/bin/accerciser']
SourcePackage: accerciser
Title: accerciser crashed with TypeError in __subclasscheck__(): issubclass() arg 1 must be a class
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm autopilot cdrom dip lpadmin plugdev sambashare sudo

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
tags: removed: need-duplicate-check
Changed in accerciser (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Still crashing on trusty

information type: Private → Public
Changed in accerciser (Ubuntu):
importance: Medium → High
status: New → Confirmed
Revision history for this message
Jarek Czekalski (jarekczek) wrote :

I have the same problem on Debian, with accerciser 3.8.2-1. That's what I get from a debugging line put inside __instancecheck__ in abc.py:

        print ("obj " + str(instance) + ", class: " + str(instance.__class__) + ", class^2: " + str(instance.__class__.__class__))

obj <ValidatorViewport object at 0xac6a1194 (validate+ValidatorViewport at 0x8dfbaa0)>, class: <accerciser.plugin.base_plugin.Plugin._PluginMethodWrapper object at 0xac696cec>, class^2: <class 'accerciser.plugin.base_plugin.Plugin._PluginMethodWrapper'>

This means that the __class__ member of ValidatorViewport is not a class. How could that happen?

Revision history for this message
Jarek Czekalski (jarekczek) wrote :

Fixed upstream. I reproduce the problem on upstream 3.8.2, but cannot reproduce on 3.12.0. Between these 2 versions there are only 3.11.9x tags, which look like unstable and I didn't test them.

Revision history for this message
Luke Yelavich (themuso) wrote :

Debian now has 3.12, so I am going to update the Ubuntu trusty package to that, so we have a functional accerciser again.

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

fixed with 3.12

Changed in accerciser (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers