Ubuntu

Abiword 2.8.1 freezes with document lost when help is clicked or F1 is pressed

Reported by Charlie Kravetz on 2010-02-09
62
This bug affects 8 people
Affects Status Importance Assigned to Milestone
AbiWord
Fix Released
Medium
Release Notes for Ubuntu
Undecided
Unassigned
abiword (Fedora)
Unknown
Unknown
abiword (Ubuntu)
Critical
Andrew Starr-Bochicchio
Lucid
Critical
Martin Erik Werner

Bug Description

PROBLEM

Every time help is clicked, including all items under Help in the menu, except 'About Abiword', Abiword freezes and the document you are working in is lost.

TEST CASE

1. Launch Abiword
2. Press [F1]
* Abiword locks up

PATCH

Patch by Michal Schmidt from https://bugzilla.redhat.com/show_bug.cgi?id=554899#c12 seems to fix this issue. Patch comment:
"remove harmful calls to xml{Init,Cleanup}Parser. Do not call xmlCleanupParser() ever to prevent TLS data corruption. And it seems that xmlInitParser() is not needed either, as libxml2 calls it itself when it's needed."
...And were not originally related to the specific crash reported here (it seems).

OTHER

ProblemType: Bug
Architecture: i386
Date: Tue Feb 9 15:42:15 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
Package: abiword 2.8.1-2ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
SourcePackage: abiword
Uname: Linux 2.6.32-12-generic i686

R.M. (ry-ryno27) wrote :

I can recreate this in lucid

Changed in abiword (Ubuntu):
status: New → Confirmed
Changed in abiword (Ubuntu):
importance: Undecided → High
msevior (msevior-gmail) wrote :

This is a bug in the Ubuntu package. It does not appear in 2.8.1 distributed with Fedora 12.

Changed in abiword:
status: Unknown → Confirmed
tags: added: iso-testing
Changed in abiword (Ubuntu Lucid):
status: Confirmed → Triaged

Raising the importance to critical. If lucid is released with this bug, it makes abiword almost useless.

Changed in abiword (Ubuntu Lucid):
importance: High → Critical

In case this can be helpful to someone in fixing the bug; here's the "interesting" part of the backtrace I was able to generate by rebuilding abiword with debugging symbols enabled:

#13 0x00007ffff79deaae in UT_go_url_show (url=0x80 <Address 0x80 out of bounds>) at ut_go_file.cpp:1668
        err = 0x0
#14 0x00007ffff7980968 in XAP_UnixAppImpl::openURL (this=<value optimized out>, url=0xd05cd0 "http://www.abisource.com/help/en-US/index.html") at xap_UnixAppImpl.cpp:48
        err = <value optimized out>
#15 0x00007ffff78b0dff in XAP_App::openHelpURL (pathBeforeLang=<value optimized out>, pathAfterLang=0x7ffff7a56ef2 "index", remoteURLbase=0x7ffff7a2e750 "http://www.abisource.com/help/")
    at ../../../../src/af/xap/xp/xap_App.h:236
No locals.
#16 _helpOpenURL (pathBeforeLang=<value optimized out>, pathAfterLang=0x7ffff7a56ef2 "index", remoteURLbase=0x7ffff7a2e750 "http://www.abisource.com/help/") at ap_EditMethods.cpp:3483
No locals.
#17 helpLocalizeAndOpenURL (pathBeforeLang=<value optimized out>, pathAfterLang=0x7ffff7a56ef2 "index", remoteURLbase=0x7ffff7a2e750 "http://www.abisource.com/help/")
    at ap_EditMethods.cpp:3494
        url = {pimpl = 0xd11700}
#18 0x00007ffff7a001eb in EV_Menu::invokeMenuMethod (this=<value optimized out>, pView=0xc832b0, pEM=0x7ffff7dd6600, stScriptName=...) at ev_Menu.cpp:188
        t = 4294966784
        emcd = {m_pData = 0x0, m_dataLength = 0, m_bAllocatedData = false, m_xPos = 0, m_yPos = 0, m_stScriptName = {pimpl = 0x8a3c00}}
#19 0x00007ffff79f5e0a in EV_UnixMenu::menuEvent (this=0x7b2ce0, id=<value optimized out>) at ev_UnixMenu.cpp:337
        script_name = {pimpl = 0xd10be0}
        pMenuActionSet = <value optimized out>
        pAction = <value optimized out>
        szMethodName = <value optimized out>
        pEMC = <value optimized out>
        pEM = 0x7ffff7dd6600

Michael Vogt (mvo) wrote :

Has someone checked if debian is affected by this bug?

Michael Vogt (mvo) wrote :

A strace looks like like we have two processes doing a futex() FUTEX_WAIT_PRIVATE and one doing a orbit request.

Robbie Williamson (robbiew) wrote :

Lowering to "High", because while AbiWord would be useless if Lucid ships with this...Lucid itself is not.

Changed in abiword (Ubuntu Lucid):
importance: Critical → High
Lionel Le Folgoc (mrpouit) wrote :

 > Lowering to "High", because while AbiWord would be useless if Lucid ships with this...Lucid itself is not.

Interesting reasoning... Could you elaborate a little? This bug concerns *abiword*, it's critical for *abiword*...

Changed in abiword (Ubuntu Lucid):
importance: High → Critical
Robbie Williamson (robbiew) wrote :
Changed in abiword (Ubuntu Lucid):
importance: Critical → High
Lionel Le Folgoc (mrpouit) wrote :

Abiword has been in main until lucid (so a potential large user base), therefore if you had stated the reason clearly from the start, we wouldn't have both wasted our time. Thanks anyway.

Barry Warsaw (barry) wrote :

I'm pretty sure abiword is in universe, not main, so not a critical bug for Lucid. I see that Charlie has opened a bug in upstream's bugzilla which at this point is probably the best place to track it, until it can be confirmed an Ubuntu-only bug (comment #3 notwithstanding).

FWIW, I can definitely confirm it happens. :/

Hi everyone,

I can also confirm that this is packaging bug. It works fine on Fedora
12. I suggest you see if it occurs in Debian.

Best Regards,

Martin Sevior

On Wed, Apr 7, 2010 at 12:44 PM, Barry Warsaw <email address hidden> wrote:
> I'm pretty sure abiword is in universe, not main, so not a critical bug
> for Lucid.  I see that Charlie has opened a bug in upstream's bugzilla
> which at this point is probably the best place to track it, until it can
> be confirmed an Ubuntu-only bug (comment #3 notwithstanding).
>
> FWIW, I can definitely confirm it happens. :/
>
> --
> Abiword 2.8.1 freezes with document lost when help is clicked or F1 is pressed
> https://bugs.launchpad.net/bugs/519541
> You received this bug notification because you are a member of AbiWord
> Stable Builds, which is subscribed to AbiWord.
>
> Status in AbiWord: Confirmed
> Status in “abiword” package in Ubuntu: Triaged
> Status in “abiword” source package in Lucid: Triaged
>
> Bug description:
> Binary package hint: abiword
>
> Every time help is clicked, including all items under Help in the menu, except 'About Abiword', Abiword freezes and the document you are working in is lost.
>
> ProblemType: Bug
> Architecture: i386
> Date: Tue Feb  9 15:42:15 2010
> DistroRelease: Ubuntu 10.04
> InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
> Package: abiword 2.8.1-2ubuntu1
> ProcEnviron:
>  PATH=(custom, user)
>  LANG=en_US.utf8
>  SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
> SourcePackage: abiword
> Uname: Linux 2.6.32-12-generic i686
>
>
>

Please correct me if I am wrong, but I was under the impression based on https://wiki.ubuntu.com/Bugs/Importance that importance was set on projected impact on users, not based on repositories. The fact that abiword is in universe is not used to set importance. This bug will impact every user of Abiword. It won't matter if they use Ubuntu, Kubuntu, Xubuntu, or some other mix. The bug still should be critical based on projected impact of the users.

Lionel Le Folgoc (mrpouit) wrote :

Charlie: unfortunately, if you read what Robbie and Barry wrote, abiword package (that was in main from dapper to karmic, shipped on the dvd live, also by edubuntu, and some time by une/r) lost magically all its users when it was demoted to universe (in lucid). That's why it can't be critical. Convincing, isn't it?

Well, per the guidance we actually have, I am marking this critical. It should stay critical based on https://wiki.ubuntu.com/Bugs/Importance.

Changed in abiword (Ubuntu Lucid):
importance: High → Critical

Attaching the gdb backtrace, one on my own system, one on another system.

Barry Warsaw (barry) wrote :

I'm not totally convinced this is a bug specific to Ubuntu. I disabled all the patches in the source package, then built it and it still froze. Maybe this is a bug in upstream that Fedora has fixed? Is there any way you can check that? Because this is a package in universe, it isn't a bug that is going to hold up Lucid, and we could use your help in fixing it.

msevior (msevior-gmail) wrote :

We've made a couple more releases with important bug fixes since then.
We're up to 2.8.3 in Fedora 12 and we'll likely release 2.8.4 within a
day.

Maybe we could ask our Debian friends to package 2.8.3 and see if the
bug persists.

Cheers

Martin

On Wed, Apr 14, 2010 at 10:21 AM, Barry Warsaw <email address hidden> wrote:
> I'm not totally convinced this is a bug specific to Ubuntu.  I disabled
> all the patches in the source package, then built it and it still froze.
> Maybe this is a bug in upstream that Fedora has fixed?  Is there any way
> you can check that?  Because this is a package in universe, it isn't a
> bug that is going to hold up Lucid, and we could use your help in fixing
> it.
>
> --
> Abiword 2.8.1 freezes with document lost when help is clicked or F1 is pressed
> https://bugs.launchpad.net/bugs/519541
> You received this bug notification because you are a member of AbiWord
> Stable Builds, which is subscribed to AbiWord.
>
> Status in AbiWord: Confirmed
> Status in “abiword” package in Ubuntu: Triaged
> Status in “abiword” source package in Lucid: Triaged
>
> Bug description:
> Binary package hint: abiword
>
> Every time help is clicked, including all items under Help in the menu, except 'About Abiword', Abiword freezes and the document you are working in is lost.
>
> ProblemType: Bug
> Architecture: i386
> Date: Tue Feb  9 15:42:15 2010
> DistroRelease: Ubuntu 10.04
> InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
> Package: abiword 2.8.1-2ubuntu1
> ProcEnviron:
>  PATH=(custom, user)
>  LANG=en_US.utf8
>  SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
> SourcePackage: abiword
> Uname: Linux 2.6.32-12-generic i686
>
>
>

I tested Abiword 2.8.2 (abiword_2.8.2-2) on Debian Squeeze, It freezes as described here.

Jani Monoses (jani) wrote :

could it be that in ubuntu/debian different build flags or different versions of the build tools are used than in Fedora?

I can confirm that this does not occur in the newest upstream Abiword release.

The past two releases seem to be bugfix releases, and should be appropriate for Lucid. See their changelogs here:

AbiWord v2.8.3 Changelog - www.abisource.com/changelogs/2.8.3.phtml
AbiWord v2.8.4 Changelog - www.abisource.com/changelogs/2.8.4.phtml

The package can be found in this PPA for testing:

https://edge.launchpad.net/~andrewsomething/+archive/experimental

Build log: http://launchpadlibrarian.net/44488830/buildlog_ubuntu-lucid-i386.abiword_2.8.4-0ubuntu1_FULLYBUILT.txt.gz

Attaching debdiff, and diff.gz.

Subscribing Release Team for approval.

Martin Pitt (pitti) wrote :

There are a lot of changes in there, plus completely new code (a crypto library). This looks a bit dangerous this close to release? Wouldn't it be better to backport the fix for this crash instead?

If you want to push for the new release, please submit an upstream changelog, a rationale for copying in a crypto library instead of using the system one, and how much this new version has been tested on current lucid. Thanks!

Steve Langasek (vorlon) wrote :

The only change to the GNOME frontend that we don't already have is this, which looks rather telling:

--- abiword-2.8.2/plugins/goffice/unix/AbiGOComponent.cpp 2009-12-13 15:21:44.000000000 -0500
+++ abiword-2.8.4/plugins/goffice/unix/AbiGOComponent.cpp 2010-04-14 17:50:16.000000000 -0400
@@ -225,6 +225,12 @@
     return true;
 }

+static bool button_press_cb(GtkDialog *dlg, GdkEventButton *ev)
+{
+ if (ev->type == GDK_2BUTTON_PRESS)
+ gtk_dialog_response(dlg, GTK_RESPONSE_OK);
+ return false;
+}
 //
 // AbiGOComponent_Create
 // -------------------
@@ -240,6 +246,7 @@
                GTK_STOCK_CANCEL, GTK_RESPONSE_CANCEL, GTK_STOCK_OK, GTK_RESPONS
E_OK, NULL));
        GtkListStore *list = gtk_list_store_new (2, G_TYPE_STRING, G_TYPE_STRING
);
        GtkWidget *w = gtk_tree_view_new_with_model (GTK_TREE_MODEL (list));
+ g_signal_connect_swapped(w, "button-press-event", G_CALLBACK(button_press_cb), dialog);
        GtkCellRenderer *renderer;
        GtkTreeViewColumn *column;
        renderer = gtk_cell_renderer_text_new ();

Perhaps someone can check if that fixes the hang?

msevior (msevior-gmail) wrote :

Hi Martin,

Those are all excellent bug fixes in our stable release cycle. 2.8.x.

Please upgrade to 2.8.4 it is far better and safer than 2.8.1.

Cheers

Martin

On Mon, Apr 19, 2010 at 6:29 PM, Martin Pitt <email address hidden> wrote:
> There are a lot of changes in there, plus completely new code (a crypto
> library). This looks a bit dangerous this close to release? Wouldn't it
> be better to backport the fix for this crash instead?
>
> If you want to push for the new release, please submit an upstream
> changelog, a rationale for copying in a crypto library instead of using
> the system one, and how much this new version has been tested on current
> lucid. Thanks!
>
> --
> Abiword 2.8.1 freezes with document lost when help is clicked or F1 is pressed
> https://bugs.launchpad.net/bugs/519541
> You received this bug notification because you are a member of AbiWord
> Stable Builds, which is subscribed to AbiWord.
>
> Status in AbiWord: Confirmed
> Status in “abiword” package in Ubuntu: Triaged
> Status in “abiword” source package in Lucid: Triaged
>
> Bug description:
> Binary package hint: abiword
>
> Every time help is clicked, including all items under Help in the menu, except 'About Abiword', Abiword freezes and the document you are working in is lost.
>
> ProblemType: Bug
> Architecture: i386
> Date: Tue Feb  9 15:42:15 2010
> DistroRelease: Ubuntu 10.04
> InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
> Package: abiword 2.8.1-2ubuntu1
> ProcEnviron:
>  PATH=(custom, user)
>  LANG=en_US.utf8
>  SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
> SourcePackage: abiword
> Uname: Linux 2.6.32-12-generic i686
>
>
>

Steve, tested the patch and it doesn't seem to work for me.

Unfortunately, I personally don't have the time to try to bisect the fix for this issue.

The changelogs are already linked above. For further info, the svn log for the 2.8.x stable series can be found here:

http://www.abisource.com/viewvc/abiword/branches/ABI-2-8-0-STABLE/?sortby=file&view=log

The crypto lib was added to fix upstream bug #9913, Abiword won't open password protected ODT files:

 http://bugzilla.abisource.com/show_bug.cgi?id=9913

The exact commit is here:

http://www.abisource.com/viewvc?view=rev&sortby=file&revision=28741

Tested Andrews PPA-Packages, the Bug is fixed there.

Jarno Suni (jarnos) on 2010-04-28
tags: added: xubuntu
Steve Langasek (vorlon) wrote :

Documented at <https://wiki.ubuntu.com/LucidLynx/ReleaseNotes#AbiWord%20freezes%20when%20accessing%20help%20documentation>:

A bug in the AbiWord package in Ubuntu causes the application to hang whenever accessing the help interface, either from the menu or by pressing F1. Until this bug is fixed, users should avoid pressing F1 in AbiWord. (519541)

Changed in ubuntu-release-notes:
status: New → Fix Released
msevior (msevior-gmail) wrote :

HI everyone,

While it useful to warn users about this, I can't but think that the
Ubuntu process is *really broken*. An extremely simple fix for this
exists. All you have to do is ship abiword-2.8.4! Fedora 12 has no
problem at all with this and I use it every day.

Martin

On Thu, Apr 29, 2010 at 2:14 AM, Steve Langasek
<email address hidden> wrote:
> Documented at
> <https://wiki.ubuntu.com/LucidLynx/ReleaseNotes#AbiWord%20freezes%20when%20accessing%20help%20documentation>:
>
> A bug in the AbiWord package in Ubuntu causes the application to hang
> whenever accessing the help interface, either from the menu or by
> pressing F1. Until this bug is fixed, users should avoid pressing F1 in
> AbiWord. (519541)
>
> ** Changed in: ubuntu-release-notes
>       Status: New => Fix Released
>
> --
> Abiword 2.8.1 freezes with document lost when help is clicked or F1 is pressed
> https://bugs.launchpad.net/bugs/519541
> You received this bug notification because you are a member of AbiWord
> Stable Builds, which is subscribed to AbiWord.
>
> Status in AbiWord: Confirmed
> Status in Ubuntu Release Notes: Fix Released
> Status in “abiword” package in Ubuntu: Triaged
> Status in “abiword” source package in Lucid: Triaged
>
> Bug description:
> Binary package hint: abiword
>
> Every time help is clicked, including all items under Help in the menu, except 'About Abiword', Abiword freezes and the document you are working in is lost.
>
> ProblemType: Bug
> Architecture: i386
> Date: Tue Feb  9 15:42:15 2010
> DistroRelease: Ubuntu 10.04
> InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
> Package: abiword 2.8.1-2ubuntu1
> ProcEnviron:
>  PATH=(custom, user)
>  LANG=en_US.utf8
>  SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
> SourcePackage: abiword
> Uname: Linux 2.6.32-12-generic i686
>
>
>

Martin Erik Werner (arand) wrote :

It seems like the 2.8.1-2ubuntu2~rp1 version available from https://edge.launchpad.net/~abiword-stable/+archive/ppa/ does not experience this crash if installed in lucid.

...Might be of interest in narrowing down the cause.

Martin Erik Werner (arand) wrote :

Are we likely to end up pulling in 2.8.4 for the SRU here?

I've started poking around in the intermidiate versions, but are we at this point still preferring a smaller SRU, if it does exist?

Attached the debdiff for the 2.8.1-2ubuntu2~rp1 -> 2.8.2-2ubuntu1 change.

I'm currently looking poking in helpLocalizeAndOpenURL to see if changing back "help" -> "Abiword/help" might do anything.
(I'm likely wrong...)

I'm also looking at 2.8.3 , to see if the error occurs there.

msevior (msevior-gmail) wrote :

On Fri, Apr 30, 2010 at 10:18 AM, arand <email address hidden> wrote:
> Are we likely to end up pulling in 2.8.4 for the SRU here?
>
> I've started poking around in the intermidiate versions, but are we at
> this point still preferring a smaller SRU, if it does exist?
>
> Attached the debdiff for the  2.8.1-2ubuntu2~rp1 -> 2.8.2-2ubuntu1
> change.
>
> I'm currently looking poking in helpLocalizeAndOpenURL to see if changing back "help" -> "Abiword/help" might do anything.
> (I'm likely wrong...)
>
> I'm also looking at 2.8.3 , to see if the error occurs there.
>
> ** Patch added: "debdiff for 2.8.1-2ubuntu2~rp1 -> 2.8.2-2ubuntu1"
>   http://launchpadlibrarian.net/46412411/rptonew.debdiff
>

Sorry, I don't understand the process here. We've done a lot of work
to enhance abiword and fix bugs. Our best abiword is version 2.8.4.

Why are you even considering 2.8.1, 2.8.2 or 2.8.3 when we've
identified and fixed many bugs in all those versions?

Do you want to develop abiword yourselves?

Just Curious,

Martin

> --
> Abiword 2.8.1 freezes with document lost when help is clicked or F1 is pressed
> https://bugs.launchpad.net/bugs/519541
> You received this bug notification because you are a member of AbiWord
> Stable Builds, which is subscribed to AbiWord.
>
> Status in AbiWord: Confirmed
> Status in Ubuntu Release Notes: Fix Released
> Status in “abiword” package in Ubuntu: Triaged
> Status in “abiword” source package in Lucid: Triaged
>
> Bug description:
> Binary package hint: abiword
>
> Every time help is clicked, including all items under Help in the menu, except 'About Abiword', Abiword freezes and the document you are working in is lost.
>
> ProblemType: Bug
> Architecture: i386
> Date: Tue Feb  9 15:42:15 2010
> DistroRelease: Ubuntu 10.04
> InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
> Package: abiword 2.8.1-2ubuntu1
> ProcEnviron:
>  PATH=(custom, user)
>  LANG=en_US.utf8
>  SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
> SourcePackage: abiword
> Uname: Linux 2.6.32-12-generic i686
>
>
>

Martin Erik Werner (arand) wrote :

2.8.3 does not have this problem either, so that hopefully narrows the scope down somewhat...

N.B. I have arbitrarily disabled the mime-types and svn-backports patches in this diff since they didn't apply cleanly.

Martin Erik Werner (arand) wrote :

@msevior
It's just normal paranoia-policy for ubuntu SRUs: https://wiki.ubuntu.com/StableReleaseUpdates
Policy demands a smaller fix, not much to do about that.

---

I spoke Charlie Kravetz (IRC) who pointed out that this is already being looked at by other's. So I'm going to stop poking for now at least

@ arand

If the release team failed to approve uploading 2.8.4, then I think it is most likely that the SRU team will not let it in as an update either. The best hope for fixing this directly in Lucid seems to be to bisect the actually change that fixes this specific problem. As soon as Maverick's archive opens, I will upload 2.8.4-0ubuntu1 that is currently in my PPA linked above. Then we can push this into lucid-backports.

@ msevior

I certainly agree this is an unfortunate set of events. The problem is that there doesn't seem to be anyone very actively maintaining abiword in Ubuntu, and 2.8.2 is the version we inherited from Debian. It looks like Lionel has put some work into it, but I imagine Xubuntu is under manned as it is. I personally agree that 2.8.4 should have been included in Lucid, but I understand the Release team's concerns about the timing as well. It comes down to the fact that we are not a rolling release distro. We have to choose a cut off date in order to maintain the stability of the distro as a whole, and sometime individual packages are hurt by this fact. I wish I had a better answer for you....

Gabor Karsay (gabor-karsay) wrote :

I wonder if this is of any help: You can simply install it from source and it works. Here is what i did under Lucid Lynx:

apt-get source abiword
cd abiword-2.8.2
(... install the necessary dev-files ...)
./configure
make
(... wait ...)
sudo make install
cd /usr/lib
sudo ln -s /usr/local/lib/libabiword-2.8.so
/usr/local/bin/abiword

Now click for help or press F1, and you get help. No freeze, no problem.

Martin Erik Werner (arand) wrote :

@Gabor Karsay

I still get the exact same freeze following your instructions on my 32bit VBox instance.
Was there any particular further steps missed?

Gabor Karsay (gabor-karsay) wrote :

@ arand

Only uninstalled abiword before (every package containing "abiword"). This is a 64bit machine, a "real" one, no virtualization.
I attach the terminal output of the whole process, maybe there are differences at ./configure. (Forgot to switch to English locale, but I guess it doesn't matter.)

Martin Erik Werner (arand) wrote :

Couldn't resist poking a bit more, and since activity seems to have ceased...
More fun facts:
If this version (2.8.2) is manually compiled and installed on Karmic 32bit, everything works fine.

Could it be isolated to 32bit Lucid?

Martin Erik Werner (arand) wrote :

Simple binary search gave me r28765:
"
r28765 | uwog | 2010-03-31 22:09:49 +0100 (Wed, 31 Mar 2010) | 3 lines

Fix 12670: abiword uses libxml2 API badly, leads to crashes (Michal Schmidt, RedHat). Please backport.
"

64-65 applies cleanly and fixes problem on my system, diff attached.
I plan on getting a debdiff and PPA builds up soonish.

Changed in abiword (Ubuntu Lucid):
assignee: nobody → arand (arand)
status: Triaged → In Progress
Martin Erik Werner (arand) wrote :

debdiff attached, hope it's in order, please sponsor if it is.
Testing packages available (currently building) from my "Main" PPA: https://edge.launchpad.net/~arand/+archive/ppa

Subscribing sponsors and SRU team

Changed in abiword:
status: Confirmed → Unknown

@arand:
Thanks for helping resolve this issue. Unfortunately, it can not be isolated to 32-bit. I run both 64 bit and 32 bit systems and the issue appears on both.

Martin Erik Werner (arand) wrote :

@Charlie Kravetz:
My patch there has nothing to do with my earlier assumption about arch-specifics.

I'm fixing up the patch for DEP-3 as well, so I'll remake the patch & debdiff, and make one for Maverick as well, right?

Martin Erik Werner (arand) wrote :

Patch in what I hope is a good DEP-3 format.

Patch author is Michal Schmidt, see linked Fedora bug (Not me as might be mistakenly implied above).

Changed in abiword:
status: Unknown → Fix Released
Martin Erik Werner (arand) wrote :

New debdiff for lucid

Martin Erik Werner (arand) wrote :

Dito maverick

Changed in abiword (Ubuntu):
assignee: nobody → arand (arand)
status: Triaged → In Progress
Steve Langasek (vorlon) wrote :

Uploaded to lucid-proposed. Thank you for your contribution to Ubuntu!

For maverick, since this bug is already fixed upstream, the better approach is to get us moved over to the new upstream version instead of backporting a patch.

Changed in abiword (Ubuntu):
assignee: arand (arand) → Andrew Starr-Bochicchio (andrewsomething)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package abiword - 2.8.4-0ubuntu1

---------------
abiword (2.8.4-0ubuntu1) maverick; urgency=low

  * New upstream release (LP: #519541).
  * debian/patches/fixes:
   - Refresh mime-types.diff to apply on new release.
   - Drop svn-backports.diff, applied upstream.
 -- Andrew Starr-Bochicchio <email address hidden> Mon, 17 May 2010 18:22:23 -0400

Changed in abiword (Ubuntu):
status: In Progress → Fix Released
Martin Erik Werner (arand) wrote :

Updated description with test case etc. to fit SRU-policy

description: updated
Jonathan Riddell (jr) wrote :

waiting on ubuntu-sru approval before accepting into -proposed

Accepted into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in abiword (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed

Yes, it works fine. F1 works know and opens the online-help. Thanks!

Steve Langasek (vorlon) on 2010-05-19
tags: added: verification-done
removed: verification-needed

I would like this fixed as much as anyone. Unfortunately, the package in proposed only works for 32bit systems. I tested it on both 32bit and 64bit, and on the 64bit system, the packages were not all available.

On 32bit systems, proposed contains the following:
abiword-common
abiword-plugin-grammar
abiword-plugin-mathview

On 64bit systems, proposed contains the following:
abiword-common

The missing plugin packages are needed for help to work correctly. Without them, the 64bit systems are still broken.

Chris Coulson (chrisccoulson) wrote :

That's because the build for amd64 only finished 50 minutes ago.

Martin Erik Werner (arand) wrote :

@Charlie Kravetz:
The amd64 arch seems to have finished building just ~45min ago or so, so you might want to grab a cup of patience ;)

Well, Sorry for jumping the gun. I tested 64bit again now, with all the packages, and it works great! Thanks to all who worked so hard on this issue.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package abiword - 2.8.2-2ubuntu1.1

---------------
abiword (2.8.2-2ubuntu1.1) lucid-proposed; urgency=low

  * debian/patches/debian/abiword-libxml2-xmlCleanupParser-is-harmful.patch
    - Fix by Michal Schmidt (Fedora Bug: #554899)
      "remove harmful calls to xml{Init,Cleanup}Parser"
    - Fixes Abiword locking up when opening help (LP: #519541)
 -- Arand Nash <email address hidden> Mon, 17 May 2010 16:11:16 +0100

Changed in abiword (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in abiword:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.