Comment 68 for bug 202174

Ryan Pavlik (abiryan) wrote :

Scrolling bit has already been mentioned - it's something weird with Ubuntu only, will take a look later though I fear it's lower in the stack than Abi and so I have little experience debugging down there.

Fixed the bug issues in the changelog. (formatting and location) I tried to find the appropriate formatting before I made that, but google only found me contradicting examples, so I picked one that looked authoritative.

Ditched the libgoffice - see above discussion. The reason it "worked"with 2.4.6 is because the configure will just disable plugins whose deps aren't satisfied - there is no actual libgoffice plugin installed on 2.4.6-3ubuntu3 (I checked). There is no way it will work with 0.6 until we get a cairo backend and move to/add gtkprint instead of libgnomeprint.

Fixed line length - another example of following bad examples. All wrapped to 72 or less.

Poppler: We now look for pdftotext or pdftoabw (which come with poppler) at runtime, there is actually no build dep I found out. (The corresponding code was moved over to poppler.)

For the issues that are just changelog formatting, I re-formatted the changelog. For the actual changes, I added a new changelog entry, 0ubuntu2. Hopefully this was the right thing to do - asked in ubuntu-devel but it seems my time zones don't line up.

New package should be on my PPA. I have attached the debdiff from the 0ubuntu1 package reviewed.