Abiword icon has extra smaller icons included

Bug #1586708 reported by Jeremy Bicha on 2016-05-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
abiword (Ubuntu)
Low
Unassigned
Wily
Low
Unassigned
Xenial
Low
Unassigned

Bug Description

[Original Bug Report]
=====================
The Abiword large icon has smaller versions of itself included. See the attached screenshot. This can be seen in the application launcher in Unity or GNOME Shell and also the Alt-Tab switcher in those desktops.

I believe this bug was introduced in Abiword 3.0.1 (so it would affect Ubuntu 15.04, 15.10 and 16.04 LTS. It is fixed in abiword 3.0.1-7 for Ubuntu 16.10 (development).

[Test case]
===========
1. Install Abiword
2a. From Unity (the default user interface of Ubuntu), click the top left icon to open the Dash. Click the 2nd icon at the bottom to open the Applications view and look for Abiword.

or
2b. From GNOME (the default user interface of Ubuntu GNOME), click the Activities button. Click the Show Applications button at the bottom left.

I don't think other desktops like XFCE and LXDE show the high-resolution application icon so this bug is not as noticable there.

3. Verify the icon displays correctly without embedded smaller versions of itself.

See the visual diff at

https://github.com/AbiWord/abiword/commit/b0c7c0c971d15091b280ff9ba0d4abbfc94f9d1b?short_path=10fc502#diff-10fc5020166685caf25ae700dcee4921

[Regression potential]
=======================
Low. The patch to fix this only affects the high-resolution .svg application icon. The low-resolution icons used elsewhere are .pngs and are not affected.

The patch was committed to Abiword's ABI-3-0-0-STABLE branch 7 months ago but Abiword has not made a stable release tarball with the fix.

I will attach a .debdiff for sponsoring to bug 1432271.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: abiword 3.0.1-6ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-23.41-generic 4.4.10
Uname: Linux 4.4.0-23-generic x86_64
ApportVersion: 2.20.1-0ubuntu4
Architecture: amd64
CurrentDesktop: GNOME
Date: Sat May 28 19:20:09 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-04-09 (48 days ago)
InstallationMedia: Ubuntu-GNOME 16.04 LTS "Xenial Xerus" - Beta amd64 (20160408)
SourcePackage: abiword
UpgradeStatus: No upgrade log present (probably fresh install)

Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) on 2016-06-11
Changed in abiword (Ubuntu):
status: New → Fix Released
description: updated

Hello Jeremy, or anyone else affected,

Accepted abiword into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/abiword/3.0.1-6ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in abiword (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Jeremy, or anyone else affected,

Accepted abiword into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/abiword/3.0.1-4ubuntu0.15.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in abiword (Ubuntu Wily):
status: New → Fix Committed
Changed in abiword (Ubuntu):
importance: Undecided → Low
Changed in abiword (Ubuntu Xenial):
importance: Undecided → Low
Changed in abiword (Ubuntu Wily):
importance: Undecided → Low
Jeremy Bicha (jbicha) wrote :

Installed Abiword on Ubuntu GNOME 16.04 LTS. Verified the extra smaller icons inside the app icon in the GNOME Shell Activities Overview.

Installed the proposed update. The app icon now looks normal without extra embedded icons.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package abiword - 3.0.1-6ubuntu0.16.04.1

---------------
abiword (3.0.1-6ubuntu0.16.04.1) xenial; urgency=medium

  * abiword-common.install:
    - Install telepathy client. Fixes Abiword autostarting a blank
      document on log in when Empathy is installed and configured
      with Online Accounts. Thanks Alban Browaeys for identifying the cause.
      (LP: #1432271)
  * 0005_language-dialog-scroll.patch:
    - Fix unusable "Set Language" dialog (LP: #1484785)
  * 0009_clean-svg-icon.patch:
    - Fix Abiword high resolution app icon (as used by Unity or GNOME Shell)
      (LP: #1586708)

 -- Jeremy Bicha <email address hidden> Fri, 10 Jun 2016 22:58:12 -0400

Changed in abiword (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for abiword has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

tags: added: verification-done-xenial verification-needed
removed: verification-done
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers