language selector text cut off in abiword

Bug #1484785 reported by Nairwolf on 2015-08-14
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
AbiWord
Fix Released
Medium
abiword (Ubuntu)
High
Julien Lavergne
Wily
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

[Impact]
========
It is nearly impossible for Abiword users to change or set a document's language.

STEPS TO REPRODUCE
==================
1. Launch abiword
2. Right-click on empty space in the document itself
3. Click Set Language

EXPECTED RESULTS
================
I should be able to change the language in that menu.

ACTUAL RESULTS
==============
There is a graphical error (window is cut off) that makes it so you cannot set the language.
There is a screenshot of this graphical issue : http://pix.toile-libre.org/upload/original/1439527801.png

AFFECTS
=======
 * Abiword version 3.0.1 and on
 * 15.10 Wily Werewolf Alpha and on
 * i386 AND amd64

[Regression Potential]
======================
Very low. This has been fixed upstream in the 3.0 stable svn branch.
The very minimal 2-line patch has been applied in Debian testing and Ubuntu 16.10 (development).

Patch for sponsorship will be attached to bug 1432271.

Nairwolf (nairwolf) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1484785

tags: added: package-qa-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in abiword (Ubuntu):
status: New → Confirmed
Simon Quigley (tsimonq2) wrote :

Steps to reproduce:
1. Launch abiword
2. Right-click on empty space(in the document itself)
3. Click Set Language
4. There is the graphical error...

Expected results:
I should be able to change the language in that menu.

Actual results:
There is a graphical error that makes it so you cannot set the language.

Affects:
Abiword version 3.0.1, Lubuntu 15.10 Wily Werewolf Alpha.

Simon Quigley (tsimonq2) wrote :

Note: under Affects, I use i386

Simon Quigley (tsimonq2) on 2015-08-14
description: updated
Walter Lapchynski (wxl) on 2015-08-14
description: updated
Changed in abiword (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Simon Quigley (tsimonq2) on 2015-08-14
tags: added: i386
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1484785

tags: added: iso-testing
Simon Quigley (tsimonq2) on 2015-09-26
Changed in abiword (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
status: Triaged → In Progress
Simon Quigley (tsimonq2) on 2015-10-07
Changed in abiword (Ubuntu):
assignee: Simon Quigley (tsimonq2) → nobody
Phill Whiteside (phillw) wrote :

This error is not seen in ubuntu-MATE when adding the application to that flavour. The language window appears as expected.

Walter Lapchynski (wxl) on 2015-10-20
Changed in abiword (Ubuntu):
status: In Progress → Triaged
Redwolf (viking.redwolf) wrote :

Not a theme problem. Tested with several ones, same problem.

Phill Whiteside (phillw) wrote :

The issue also appears in Ubuntu Wily.

Henk Terhell (hterhell) wrote :

I re-installed abiword (version 3.0.0-4ubuntu1.1) in Lubuntu 14.04 LTS but this bug does not occur there.
So either the update in abiword to 3.0.1-4 or the update in openbox (3.5.2-6 to 3.6.1-1) may have caused this bug.

Henk Terhell (hterhell) wrote :

I installed abiword on Debian 8 and also here this bug does not occur.
Versions:
Abiword 3.0.0-8+b1
Openbox 3.5.2-8

Henk Terhell (hterhell) wrote :

Abiword 3.0.1-4 installed on Xubuntu Xenial (w/o Openbox) does not show this bug either.

Wen Jie (seowwjpg) wrote :

Abiword 3.0.1 on Lubuntu Xenial (build 20151220) shows this bug.

Walter Lapchynski (wxl) on 2016-01-04
description: updated
tags: added: vivid xenial
Henk Terhell (hterhell) wrote :

I had a look at Manjaro LXDE 16.03 released a few days ago. This is using Openbox 3.6.1. and Abiword 3.0.1 so the same as for Lubuntu Xenial. This bug was not present in the live session. Checking the version of Abiword in Manjaro LXDE there was no error message, but for L. Xenial the attached error was shown. So maybe this bug is not an Openbox nor Abiword issue.

Simon Quigley (tsimonq2) wrote :

Confirmed in Lubuntu Xenial 20160409.

Julien Lavergne (gilir) on 2016-04-10
Changed in abiword (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Julien Lavergne (gilir)
Julien Lavergne (gilir) wrote :

I'm pushing a possible fix in https://launchpad.net/~lubuntu-dev/+archive/ubuntu/staging (abiword_3.0.1-6ubuntu1~ppa1). Let me know if it's better with this version (it will be available in a few minutes, time to build it).

Den 2016-04-10 kl. 12:36, skrev Julien Lavergne:
> I'm pushing a possible fix in https://launchpad.net/~lubuntu-
> dev/+archive/ubuntu/staging (abiword_3.0.1-6ubuntu1~ppa1). Let me know
> if it's better with this version (it will be available in a few minutes,
> time to build it).
>

Yes, I think it works :-)

See the attachment - created after installing your version via the PPA.

Best regards
Nio

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package abiword - 3.0.1-6ubuntu1

---------------
abiword (3.0.1-6ubuntu1) yakkety; urgency=medium

  * debian/patches/fix_language_dialog.patch:
   - Force the size of the scrollwindows, to actually show the languages
     (LP: #1484785).

 -- Julien Lavergne <email address hidden> Mon, 16 May 2016 15:37:33 +0200

Changed in abiword (Ubuntu):
status: In Progress → Fix Released
Changed in abiword:
importance: Unknown → Medium
status: Unknown → Fix Released
Julien Lavergne (gilir) wrote :

Thanks Jeremy :-) I didn't see it last time I checked for this bug on the bug tracker. This workaround could be replaced by the actual upstream fix for the next upload.

Henk Terhell (hterhell) wrote :

Is OK now in Lubuntu Yakkety but has not been fixed in L 16.04 LTS.

Jeremy Bicha (jbicha) on 2016-06-11
description: updated
Simon Quigley (tsimonq2) wrote :

@Henk it needs an SRU, I'll make one

Jeremy Bicha (jbicha) wrote :

Simon, I already prepared the SRU. I just need it sponsored (my debdiff is attached to bug 1432271 ).

Simon Quigley (tsimonq2) wrote :

@Jeremy Thanks, nevermind then. :)

Hello Nairwolf, or anyone else affected,

Accepted abiword into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/abiword/3.0.1-6ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in abiword (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Nairwolf, or anyone else affected,

Accepted abiword into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/abiword/3.0.1-4ubuntu0.15.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in abiword (Ubuntu Wily):
status: New → Fix Committed
Simon Quigley (tsimonq2) wrote :

This is fixed on Xenial.

Changed in abiword (Ubuntu Xenial):
importance: Undecided → Medium
Changed in abiword (Ubuntu Wily):
importance: Undecided → Medium
Jeremy Bicha (jbicha) wrote :

Works for me and see previous comment.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package abiword - 3.0.1-6ubuntu0.16.04.1

---------------
abiword (3.0.1-6ubuntu0.16.04.1) xenial; urgency=medium

  * abiword-common.install:
    - Install telepathy client. Fixes Abiword autostarting a blank
      document on log in when Empathy is installed and configured
      with Online Accounts. Thanks Alban Browaeys for identifying the cause.
      (LP: #1432271)
  * 0005_language-dialog-scroll.patch:
    - Fix unusable "Set Language" dialog (LP: #1484785)
  * 0009_clean-svg-icon.patch:
    - Fix Abiword high resolution app icon (as used by Unity or GNOME Shell)
      (LP: #1586708)

 -- Jeremy Bicha <email address hidden> Fri, 10 Jun 2016 22:58:12 -0400

Changed in abiword (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for abiword has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

tags: added: verification-done-xenial verification-needed
removed: verification-done
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.