[SRU] Abiword always starts after logging in

Bug #1432271 reported by LGB [Gábor Lénárt] on 2015-03-14
392
This bug affects 84 people
Affects Status Importance Assigned to Milestone
AbiWord
Fix Released
Medium
One Hundred Papercuts
High
Unassigned
abiword (Debian)
Fix Released
Unknown
abiword (Ubuntu)
High
Unassigned
Declined for Vivid by Daniel Holbach
Wily
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

.debdiff for sponsoring is located below at comment #38

[Impact]
========
Individuals who have abiword and a telepathy-based client (like Empathy) installed and who have set up their online account with Ubuntu will see Abiword open a blank document every time they log in!

Lubuntu is the only Ubuntu 16.04 LTS flavor to ship Abiword and Ubuntu GNOME is the only one to still include empathy by default. (Xubuntu included Abiword until 15.10 and Ubuntu included Empathy before 16.04.)

[Test Case]
===========
1. Install abiword and empathy
2. Run empathy

What happens
------------
Empathy starts...but so does Abiword!

What should happen
-------------
Empathy starts. Abiword doesn't start unless you specifically start Abiword.

[Regression Potential]
======================
Low. The Abiword packaging in Debian and Ubuntu mistakenly did not include /usr/share/telepathy/clients/AbiCollab.client in the abiword package. This has been fixed in Debian "testing" and Ubuntu 16.10 development.

[Original Bug Report]
===================
I upgraded to Ubuntu 15.04 some days ago. Not so much problem noticed since then, but only one (not a fatal one though): abiword - for some reason - always starts (automatically, without any user interaction) after logging in (to unity desktop). For sure, I can close it, but it's kinda strange it happens anyway, and I can't tell why. I could only find the following page which describes something similar (but I guess it's more on the gnome3 desktop from the OP, I mean about the "regular" Unity desktop of Ubuntu):

http://ubuntuforums.org/showthread.php?t=2268651

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: abiword 3.0.1-1
ProcVersionSignature: Ubuntu 3.19.0-9.9-generic 3.19.1
Uname: Linux 3.19.0-9-generic i686
ApportVersion: 2.16.2-0ubuntu3
Architecture: i386
CurrentDesktop: Unity
Date: Sun Mar 15 00:52:30 2015
InstallationDate: Installed on 2012-03-03 (1106 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
SourcePackage: abiword
UpgradeStatus: Upgraded to vivid on 2014-10-24 (141 days ago)

LGB [Gábor Lénárt] (lgb) wrote :
description: updated
description: updated
Mirco Müller (macslow) wrote :

I have this too and looking into it.

Changed in abiword (Ubuntu):
status: New → Confirmed
Changed in abiword (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → High
Sean Davis (bluesabre) wrote :

One of our Xubuntu members experienced a similar issue in the past. It was because of an Abiword collaboration plugin in telepathy (empathy). I'm not sure which, but if you can determine what it is, please note it here in the comments.

LGB [Gábor Lénárt] (lgb) wrote :

Just checked out: abiwprd process' parent was "upstart --user", if it helps. Since Sean above suggested telepathy/empathy issue, and I found two cadidates of telepathy related processes:

lgb 2231 0.0 0.5 91864 20252 ? Sl 20:50 0:00 telepathy-indicator
lgb 2237 0.0 0.3 72532 14072 ? Sl 20:50 0:00 /usr/lib/telepathy/mission-control-5

I simply checked out which package owns the files and removed the packages, that means some packages:

The following packages will be REMOVED:
  account-plugin-aim* account-plugin-jabber* account-plugin-salut*
  account-plugin-yahoo* empathy* kde-telepathy* kde-telepathy-minimal*
  mcp-account-manager-goa* mcp-account-manager-uoa*
  telepathy-mission-control-5*
0 upgraded, 0 newly installed, 10 to remove and 0 not upgraded.

After that indeed, no abiword is started after logging in, so there should be connection.

vmagnin (vincent-magnin) wrote :

Same problem with Kubuntu 15.04 for around 7 or 10 days. Abiword starts every time I log in KDE, although it does not appear in the "Automatically Started Applications" in the KDE configuration window.

Erick Brunzell (lbsolost) wrote :

Also effects Ubuntu GNOME Vivid.

tags: added: ubuntu-gnome
paulle (orj-paulle) wrote :

Ubuntu GNOME Vivid. Same here.

Erick Brunzell (lbsolost) wrote :

Does not effect Ubuntu Mate, I've yet to get Lubuntu installed so don't know about it.

Karl (mail-kfr) wrote :

Here it's with gnome additionally installed on xubuntu.

Raf (4263004-noduck) wrote :

Removing /usr/share/dbus-1/services/org.freedesktop.Telepathy.Client.AbiCollab.service (which was installed by abiword-common) also fixes the problem.

Paul (paul-klingelhuber-m) wrote :

Also affected by this, trying the removing AbiCollab.service fix now, if it doesn't work I'll report back.

vmagnin (vincent-magnin) wrote :

This bug has disappeared from my Kubuntu 15.04 some weeks ago.

Tony Houghton (h-realh) wrote :

Why is upstart running anyway? It's supposed to have been replaced by systemd.

Jaromir Obr (jaromir-obr) wrote :

It happens to me in Gnome Flashback Compiz, after upgrade to 15.04

I am using Ubuntu with lubuntu-desktop installed in a second time.
I've got the issue after doing apt-get --reinstall install lubuntu-desktop

Sergey (sergey1369) wrote :

#10 works for me! Thanks, Raf!
sudo rm -f /usr/share/dbus-1/services/org.freedesktop.Telepathy.Client.AbiCollab.service

Changed in abiword (Debian):
status: Unknown → New
Stephan (stephan-stephanx) wrote :

Also affecting me, since upgrading to 15.04 64-bit. removing AbiCollab.service also worked for me

arsen stasic (arsen) wrote :

#10 worked for me too! I was also affected since upgrading to 15.04 32bit.

Swizz69 (swizz69) wrote :

#10 worked here too on our 64bit Unity install. Thanks all! :)

Felix (felixq78-r) wrote :

My solution is simple uninstall Abiword. Libre is fine for my purposes.

Changed in abiword (Ubuntu):
importance: High → Medium
Changed in hundredpapercuts:
importance: High → Medium
Changed in abiword (Ubuntu):
importance: Medium → High
Changed in hundredpapercuts:
importance: Medium → High
Changed in abiword (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: Confirmed → Triaged
Gelefisk (gelefisk) wrote :

Might be safer to make a backup:

cd /usr/share/dbus-1/services/
sudo mv org.freedesktop.Telepathy.Client.AbiCollab.service org.freedesktop.Telepathy.Client.AbiCollab.service.bak

Surprisingly, deleting this file doesn't seem to have any effect on the collaboration option in AbiWord?

imbezol (travis-c) wrote :

I'm running Kubuntu 15.10 and had the same problem. Following the advise in post #10 solved it for me too.

tags: added: wily
Brian Wright (bdw) wrote :

I'm confirming that this issue does reappear when upgrading to Kubuntu 15.10 (wily) and the post in #10 resolves it.

Michał Faflik (faflu) wrote :

Still not resolved in 15.10. Ubuntu

still not resolved in 16.04. Ubuntu

Stephan Kern (swmmrman) wrote :

Found in 16.04 base ubuntu with Kububntu Xubuntu and Lubuntu desktop environments installed. I have others installed as well. However i think it appeared after installing the Kubuntu desktop(those 3 were installed at once). #10 worked for me as well.

Experiencing the same in 15.10.

Louis Luangkesorn (lluang) wrote :

This happened to me upon upgrading to 15.10. #10 worked for me as well.

vmagnin (vincent-magnin) wrote :

The bug came back after upgrading today to Kubuntu 16.04 beta1.

Thomas Schiex (thomas-schiex) wrote :

Same here, bug present in Ubuntu 16.04 beta1.

Simon Quigley (tsimonq2) wrote :

This is not present in Lubuntu, it's probably a Unity problem.

aren (aren-t) wrote :

I had the same problem after upgrading to Lubuntu 16.04. I have gnome installed and have had KDE, and unity installed. #10 worked for me.

I had this again after upgrading to 16.04 (I had previously had the problem after upgrading to 15.10)

Sam Van den Eynde (samvde) wrote :

:-/

16.04 brought it back...

Changed in abiword:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in abiword (Debian):
status: New → Confirmed
Changed in abiword:
status: Confirmed → Invalid

According to the just-closed AbiWord bug http://bugzilla.abisource.com/show_bug.cgi?id=13778 this is a packaging bug in Debian/Ubuntu:

/usr/share/telepathy/clients/AbiCollab.client
was not being installed.

raven322 (spike85051) wrote :

ubu 16:

yep...but its not loo.
And loo needs some help. I was rather hoping to use straight loo to install from as it doesnt install all the gnome3 sheet, but since loo was broken....and this backhanded approach as-if we all want gnome3 is the wrong mindset. note the known gnome3 bug stating "ati hardware will probly not work under gnome and cause it to (sad face) crash.."

do what debbie does on this:

make the distro first.
have others help with the ui/respins( or have ubu core team produce them all)
..and if you have it working under a working install, the installer or live disc should never fail.

telepathy...herd of pidgin? this isnt right.

..and who said we wanted that connection? use growl on inotify as it were. sounds like someone doesnt know how to code or do thier homework as to how things are done. just because it CAN be forked 50 ways, doesnt mean you SHOULD.

standards people...

yes I have many suite installed, so if it goes away when removed, then buh bye..too basic for my needs.noting the bugs ive found in libre, it helps to keep a spare.

Changed in abiword (Debian):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package abiword - 3.0.1-7

---------------
abiword (3.0.1-7) unstable; urgency=low

  [ Jeremy Bicha ]
  * QA upload.
  * abiword-common.install:
    - Install telepathy client. Fixes Abiword autostarting a blank
      document on log in. Thanks Alban Browaeys for identifying the cause.
      (Closes: #781764) (LP: #1432271)
  * Backport patches from stable 3.0 branch:
    - 0001_export-paragraph-to-odt.patch
    - 0002_svg-printing.patch (Closes: #682668)
    - 0003_null-column-crash.patch
    - 0004_apply-default-header-style.patch
    - 0005_language-dialog-scroll.patch (LP: #1484785)
    - 0006_protect-against-null-string.patch
    - 0007_gtk-image-scaling.patch
    - 0008_do-nothing-with-unchecked-radio-buttons.patch
    - 0009_clean-svg-icon.patch
    - 0010_fix-parallel-build.patch
  * debian/patches/build-with-aiksaurus-1-2.patch:
    - Look for aiksaurus*-1.2.pc (because that's what is provided in Debian)
    - Note that the Aiksaurus plugin is not installed because Aiksaurus
      is still GTK2
  * debian/control: Bump minimum aiksaurus version to match the above patch
  * Drop obsolete packaging:
    - .menu and .xpm files
    - build-dependencies (gtk2, imagemagick and svn)
    - old README.Debian note about abiword-gnome
    - abiword.preinst: defoma is long gone
    - mimeinfo: replaced by MimeType in .desktop
    - Use automatic dbsym packages instead of manual abiword-dbg package
    - Use dh_strip --dbsym-migration and build-depend on required debhelper
  * Re-enable parallel builds on Linux
  * Explicitly build with all hardening flags
  * Bump Standards-Version to 3.9.8

  [ Gianfranco Costamagna ]
  * VCS in secure mode
  * Drop quilt from b-d

 -- Jeremy Bicha <email address hidden> Thu, 26 May 2016 19:55:18 -0400

Changed in abiword (Ubuntu):
status: Triaged → Fix Released
Jeremy Bicha (jbicha) on 2016-06-11
description: updated
Jeremy Bicha (jbicha) wrote :

Here's the .debdiff for sponsoring. It also includes the fixes for bug 1484785 and bug 1586708. Thank you!

description: updated
Jeremy Bicha (jbicha) wrote :
summary: - [vivid] Abiword always starts after logging in
+ [SRU] Abiword always starts after logging in
tags: added: xenial
Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :

And a .debdiff for sponsoring for wily too.

I test-built on wily but I don't have a wily install handy to test run it. The wily and xenial packaging is very similar though. This is all that was changed during Xenial:

https://launchpadlibrarian.net/235054558/abiword_3.0.1-4build3_3.0.1-5.diff.gz
https://launchpadlibrarian.net/241270659/abiword_3.0.1-5_3.0.1-6.diff.gz

Jeremy Bicha (jbicha) wrote :
Daniel Holbach (dholbach) wrote :

Uploaded to wily and xenial.

Changed in abiword (Ubuntu Wily):
status: New → Fix Committed
Changed in abiword (Ubuntu Xenial):
status: New → Fix Committed

Hello LGB, or anyone else affected,

Accepted abiword into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/abiword/3.0.1-6ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello LGB, or anyone else affected,

Accepted abiword into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/abiword/3.0.1-4ubuntu0.15.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Jeremy Bicha (jbicha) on 2016-06-16
Changed in hundredpapercuts:
status: Triaged → Fix Committed
Changed in abiword (Ubuntu Xenial):
importance: Undecided → Medium
Changed in abiword (Ubuntu Wily):
importance: Undecided → Medium
Jeremy Bicha (jbicha) wrote :

Installed Abiword in Ubuntu GNOME 16.04 LTS. Logged out. Logged in. Abiword automatically opened a blank document a few moments later.

Installed proposed update. Logged out. Logged in. Abiword did not automatically start a blank document. Abiword does open and work fine if I intentionally start it though!

tags: added: verification-done
removed: verification-needed
Martin Pitt (pitti) on 2016-07-04
tags: added: verification-done-xenial verification-needed
removed: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package abiword - 3.0.1-6ubuntu0.16.04.1

---------------
abiword (3.0.1-6ubuntu0.16.04.1) xenial; urgency=medium

  * abiword-common.install:
    - Install telepathy client. Fixes Abiword autostarting a blank
      document on log in when Empathy is installed and configured
      with Online Accounts. Thanks Alban Browaeys for identifying the cause.
      (LP: #1432271)
  * 0005_language-dialog-scroll.patch:
    - Fix unusable "Set Language" dialog (LP: #1484785)
  * 0009_clean-svg-icon.patch:
    - Fix Abiword high resolution app icon (as used by Unity or GNOME Shell)
      (LP: #1586708)

 -- Jeremy Bicha <email address hidden> Fri, 10 Jun 2016 22:58:12 -0400

Changed in abiword (Ubuntu Xenial):
status: Fix Committed → Fix Released
Changed in abiword:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.