Abiword opens multiple windows when spacebar is pressed, until a new file is opened

Bug #1395323 reported by Jack Fromm on 2014-11-22
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
AbiWord
Fix Released
Medium
abiword (Ubuntu)
High
Unassigned

Bug Description

To reproduce:
Launch AbiWord and just start typing text. Nothing appears until you hit the
spacebar and then another AbiWord window opens. This will continue indefinitely
every time you hit space.
If you do a File->New before you start typing, everything works as expected.
And that seems to prevent the problem from reoccurring on subsequent launches.

Xubuntu 14.10, 15.04 (development)

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: abiword 3.0.0-5ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-24.32-generic 3.16.4
Uname: Linux 3.16.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.7-0ubuntu10
Architecture: amd64
CurrentDesktop: XFCE
Date: Sat Nov 22 09:10:49 2014
InstallationDate: Installed on 2014-11-05 (16 days ago)
InstallationMedia: Xubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20141105)
SourcePackage: abiword
UpgradeStatus: No upgrade log present (probably fresh install)

Jack Fromm (jjfrv8) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1395323

tags: added: package-qa-testing
Changed in abiword:
importance: Unknown → Medium
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in abiword (Ubuntu):
status: New → Confirmed
Elfy (elfy) wrote :

Can confirm

removing ~/.config/abiword then causes the issue to reappear

Changed in abiword (Ubuntu):
importance: Undecided → High
tags: added: i386
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1395323

tags: added: iso-testing

I cannot reproduce this bug (15.04, up-to-date).

Elfy (elfy) wrote :

I can still confirm this in an up to date 15.04

If previously you have used Abiword then you need to remove the .config/abiword folder to reproduce.

Jack Fromm (jjfrv8) wrote :

Further experimentation yielded another clue. It seems to depend on the position of the mouse pointer. If AbiWord launches in an unmaximized window and the mouse pointer is located outside of that window, the bug behavior happens. If you reposition the mouse pointer, either before opening AbiWord or afterwards, so that the pointer is located in the body of the new document, typing behavior is normal.

Changed in abiword:
status: Confirmed → Fix Released
Dave Kokandy (drkokandy) wrote :

Also creates a new document on hitting Enter.

Walter Lapchynski (wxl) on 2015-01-22
summary: - Entering text on first launch, multiple windows open every time you hit
- spacebar.
+ Abiword opens multiple windows when spacebar is pressed, until a new
+ file is opened
Dave Kokandy (drkokandy) wrote :

This bug has been fixed in the latest release of Abiword - http://www.abisource.com/release-notes/3.0.1.phtml - which is still in debian experimental.

Jack Fromm (jjfrv8) wrote :

3.0.1 made it to the Xubuntu staging PPA. Updated today and tested okay.

Sean Davis (bluesabre) wrote :

Marking as Fixed, 3.0.1-1 is now in Vivid.

Changed in abiword (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.