SHIFT-CTRL-CURSOR_KEY combos don't work anymore to select text

Bug #1315949 reported by amigamagic on 2014-05-04
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
AbiWord
Fix Released
Medium
abiword (Ubuntu)
Medium
Unassigned
Trusty
Low
Thomas Ward

Bug Description

[Impact]

This bug affects all the users that are used to the common shortcut to select words of text in a generic text editor / word processing software:

the "CTRL + SHIFT + LEFT/RIGHT CURSOR KEY" combo.

This shortcut is, from decades, a "de facto standard" in nearly all the text/word processing software with a GUI. It's not a missing feature of Abiword, because previous versions of it had this functionality, but in the package from the current ubuntu repositories (3.0.0-4ubuntu1) it doesn't work anymore.

The impact of the bug depends from the user habits. If you are like me, ie you are used to select entire words of text with this combo very often, Abiword will seem almost inusable to you.

Notice that the bug was already reported, fixed and committed some months ago by the Abiword dev team in the svn of the stable release branch: http://bugzilla.abisource.com/show_bug.cgi?id=13596

[Test Case]

The bug is very simple to reproduce: open Abiword, write some words and try to use the standard CTRL-SHIFT-LEFT/RIGHT_CURSOR_KEY combo to select the words faster. You will see that it doesn't work, albeit the CTRL-LEFT/RIGHT_CURSOR_KEY combo work as expected to make the cursor jump between words.

[Regression Potential]

I don't see particular regression problems from the reported fix, and abiword dev team should think in the same way if they committed the fix to their stable branch. The patchfix is very small... From what I can see, only an "if" condition added to the previous code.

------------------------------------------------------------------------------

I attached the bugfix from bugzilla.abisource.com here for your convenience.

Cheers,
amigamagic

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: abiword 3.0.0-4ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun May 4 23:45:06 2014
InstallationDate: Installed on 2014-04-12 (22 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Daily amd64 (20140411)
SourcePackage: abiword
UpgradeStatus: No upgrade log present (probably fresh install)

amigamagic (debianmaverick) wrote :
description: updated
tags: added: cherry-pick
Changed in abiword (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Thomas Ward (teward) wrote :

Attached is a debdiff for consideration on this bug. The patch needed some very minor modifications to apply, but it's still all of upstream's patch, nothing else.

Changed in abiword:
importance: Unknown → Medium
status: Unknown → Fix Released
Thomas Ward (teward) wrote :

This bug is missing the standard SRU template, please keep this in mind when working on this bug from this point forward. For an SRU it will need the template filled in. The template can be found at https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

The attachment "Diff file for fixing the shift-ctrl shortcut bug." seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
description: updated
amigamagic (debianmaverick) wrote :

Updated the bug description to follow the template from here:
https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

amigamagic (debianmaverick) wrote :

I don't know if it could be of help, but I applied the debdiff from Thomas Ward to the current ubuntu package (abiword 3.0.0-4ubuntu1) and it works flawlessly: the CTRL-SHIFT-CURSOR_KEY shortcut has returned to work again after applying the patch.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package abiword - 3.0.0-4ubuntu2

---------------
abiword (3.0.0-4ubuntu2) utopic; urgency=low

  * debian/patches/fix-keyboard-combo-for-text-selection.patch (LP: #1315949)
    + New upstream patch to fix SHIFT-CTRL-CURSOR_KEY text selection key
      combinations.
 -- Thomas Ward <email address hidden> Sun, 04 May 2014 19:32:06 -0400

Changed in abiword (Ubuntu):
status: Triaged → Fix Released
Changed in abiword (Ubuntu Trusty):
importance: Undecided → Low
status: New → Triaged
Iain Lane (laney) wrote :

I uploaded the SRU, thanks.

Changed in abiword (Ubuntu Trusty):
status: Triaged → In Progress
assignee: nobody → Thomas Ward (teward)

Hello amigamagic, or anyone else affected,

Accepted abiword into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/abiword/3.0.0-4ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in abiword (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Mathew Hodson (mathew-hodson) wrote :

Works with abiword 3.0.0-4ubuntu1.1

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for abiword has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package abiword - 3.0.0-4ubuntu1.1

---------------
abiword (3.0.0-4ubuntu1.1) trusty; urgency=low

  * debian/patches/fix-keyboard-combo-for-text-selection.patch (LP: #1315949)
    + New upstream patch to fix SHIFT-CTRL-CURSOR_KEY text selection key
      combinations.
 -- Thomas Ward <email address hidden> Sun, 04 May 2014 19:32:06 -0400

Changed in abiword (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.