incorrect id3v2 option

Bug #576450 reported by bigoperm on 2010-05-06
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
abcde (Debian)
Fix Released
Unknown
abcde (Ubuntu)
Medium
Unassigned
Lucid
Medium
Unassigned

Bug Description

SRU Justification:
This bug prevents users from using abcde to generate correctly tagged mp3s.

TEST CASE:
1) install abcde and id3v2
2) attempt to convert audio cd to mp3s with "abcde -o mp3"
3) use id3v2 to query generated mp3s (e.g. id3v2 -l path/to/file.mp3)
If working correctly, information about the mp3 should be returned; if incorrectly, id3v2 will return "No ID3 tag"

Regression potential:
There is a small risk of breaking tagging mp3s for multi-artist cds, testing should verify that it does not get broken.

Old Description:

abcde is passing unsupported options to id3v2. Here is a partial output from abcde:

...
Tagging track 12 of 12: Voulez-Vous?...
/usr/bin/id3v2: unrecognized option '--TPE2 "Various"'
Usage: /usr/bin/id3v2 [OPTION]... [FILE]...
...

Once abcde is done, further inspection reveals that no id3 tag was written at all. I've only seen this problem since upgrading my system to 10.04 (i am running "Ubuntu 10.04 LTS - the Lucid Lynx")

Related branches

Aren Tyr (a-tyr-public) wrote :

The fix for this bug is in the Debian archives, a package maintainer just needs to migrate it across.

http://<email address hidden>/msg711030.html

bigoperm (bigoperm) wrote :

Thanks! Should I contact the maintainers directly?

Michael S. (jellicle) wrote :

Debian has fixed this problem with abcde version 2.4.1-1, see here:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=554030

Can someone in Ubuntu please upload 2.4.1-1 for Lucid, since this bug essentially makes abcde on Lucid useless? Thanks.

In the meantime, Ubuntu users can download the Debian .deb file here:

http://packages.debian.org/sid/all/abcde/download

And install it like so:

$ sudo dpkg -i abcde_2.4.1-1_all.deb

and it will work.

Steve Beattie (sbeattie) wrote :

abcde 2.4.1-1 has already been synced from debian in maverick, marking it fix-released there.

Changed in abcde (Ubuntu):
status: New → Fix Released
Changed in abcde (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Medium
Changed in abcde (Ubuntu):
importance: Undecided → Medium
Steve Beattie (sbeattie) on 2010-05-25
description: updated
Steve Beattie (sbeattie) wrote :

I've reproduced the problem (to my chagrin) and can confirm that incorporating the patch from debian bug 554030 fixes the issue without breaking mp3 encoding in any visible way. I've linked a branch to be submitted for a Stable Release Update as well as have a test package waiting to be built in my ppa at https://launchpad.net/~sbeattie/+archive/ppa/+packages.

Steve, I've installed the Package from your PPA and can confirm that tagging is working with that version. Thanks!

Accepted abcde into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in abcde (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed

Tested the Package from proposed. I can confirm that it works.

Martin Pitt (pitti) on 2010-06-01
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package abcde - 2.4.0-1ubuntu1.1

---------------
abcde (2.4.0-1ubuntu1.1) lucid-proposed; urgency=low

  * Fix for mp3 tagging by removing quotes that expanded to an empty argument
    if there was a single artist, which id3v2 will choke on.
    Patch by Christof Douma and taken from Debian bug 554030. (LP: #576450)
 -- Steve Beattie <email address hidden> Mon, 24 May 2010 21:44:42 -0700

Changed in abcde (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in abcde (Debian):
status: Unknown → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.