package 389-ds-base 1.2.10.2-0ubuntu2 failed to install/upgrade: sub-processo script post-installation instalado retornou estado de saída de erro 1

Bug #946815 reported by gilfeitoza on 2012-03-05
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
389-ds-base (Ubuntu)
High
Timo Aaltonen

Bug Description

Não sei que se trata esse erro. Acredito que seja o source.list do unbutu 10.04 e o que estou usando agora é 12.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: 389-ds-base 1.2.10.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic i686
ApportVersion: 1.94-0ubuntu1
AptOrdering:
 nmap: Install
 389-ds-base: Configure
 389-admin: Configure
 nmap: Configure
Architecture: i386
Date: Sun Mar 4 23:42:56 2012
ErrorMessage: sub-processo script post-installation instalado retornou estado de saída de erro 1
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
SourcePackage: 389-ds-base
Title: package 389-ds-base 1.2.10.2-0ubuntu2 failed to install/upgrade: sub-processo script post-installation instalado retornou estado de saída de erro 1
UpgradeStatus: Upgraded to precise on 2012-02-23 (11 days ago)

gilfeitoza (gilfeitoza) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in 389-ds-base (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

Please use English only when reporting bugs.

The postinst script needs to be fixed to not fail when there is no instance configured.

Changed in 389-ds-base (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
importance: Undecided → High
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package 389-ds-base - 1.2.10.4-0ubuntu1

---------------
389-ds-base (1.2.10.4-0ubuntu1) precise; urgency=low

  * Merge from debian git.
    - rules, postinst:
      Add an error handler function for dh_installinit, so
      that clean installs don't fail due to missing configuration.
      (LP: #946815)
    - postinst: Run the update tool.
    - fix the initscript to handle multiple instances and detach ns-slapd
      so postinst doesn't hang.
  * New upstream bugfix release.
    + #304 - Fix kernel version checking in dsktune
    + #306 - void function cannot return value
    + #305 - Certain CMP operations hang or cause ns-slapd to crash
    + handle null smods
    + memleaks in mep_parse_config_entry, normalize_mods2bvals
 -- Timo Aaltonen <email address hidden> Thu, 15 Mar 2012 14:21:24 +0200

Changed in 389-ds-base (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers